summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-11-28 19:20:22 +0100
committerMike Gilbert <floppym@gentoo.org>2017-11-28 13:36:30 -0500
commit408445cf6e63c28764aa01142b53130efaafce8f (patch)
tree713c18f203e5b45f32fec05be35ac36c70f658ec
parentapp-i18n/fcitx-cloudpinyin: Version bump (0.3.6). (diff)
downloadgentoo-408445cf6e63c28764aa01142b53130efaafce8f.tar.gz
gentoo-408445cf6e63c28764aa01142b53130efaafce8f.tar.bz2
gentoo-408445cf6e63c28764aa01142b53130efaafce8f.zip
app-i18n/fcitx-qt5: Version bump (1.2.1).
-rw-r--r--app-i18n/fcitx-qt5/Manifest1
-rw-r--r--app-i18n/fcitx-qt5/fcitx-qt5-1.2.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-i18n/fcitx-qt5/Manifest b/app-i18n/fcitx-qt5/Manifest
index 9147671973e8..9e7fb4366421 100644
--- a/app-i18n/fcitx-qt5/Manifest
+++ b/app-i18n/fcitx-qt5/Manifest
@@ -1,2 +1,3 @@
DIST fcitx-qt5-1.1.1.tar.xz 56352 BLAKE2B 1fea4484f79fa9f9bcd52ac59b4e64cb9947a2cdc46e3df3c3729ef37d136c4fcf787d7a8abd946e5a0d02f909c0a94b6d19b98a93cf9dc2ec49d172a5f19550 SHA512 ea7faa953561527fd0f6224a06ab97ab84a9e36a06d44f9807e38e6d8e537ab2c7126c4cda2d4718473ace1245709ce6175ac9431b6f0527a63b2d6e92feb18c
DIST fcitx-qt5-1.2.0.tar.xz 134224 BLAKE2B 8358ec0b1cf95534f15536dd9529d4f7da47e6c08c050cc93503db958348ce4d940eb1903be8f161fec8adeca58c03838f021e36ecf39908361cddee40d806d4 SHA512 38d49d626e4aaee80f44ddeb627b07e45430c6eb1c1c37f2a5fb0c73d5dae6da5ed276366c40c3b6e8609543af95396091e240b5a88b684f399752b3eceee915
+DIST fcitx-qt5-1.2.1.tar.xz 134304 BLAKE2B c158b20bdcb287e9cb52aa74d6a7f66f113a759538b6748b1d38dcbb2213956e88dec54ed29307427d45d84861654bf5e70c9effba70d88738bf0a1a664cc3cd SHA512 0fd726974492e173084e29d3308aa1d97141a1e4034b7192cf505391540533eff473849929e931e4a84589d233fefac70cbd9c122cf6d0d0de412150cad1b1d3
diff --git a/app-i18n/fcitx-qt5/fcitx-qt5-1.2.1.ebuild b/app-i18n/fcitx-qt5/fcitx-qt5-1.2.1.ebuild
new file mode 100644
index 000000000000..a7aa45d5e1dd
--- /dev/null
+++ b/app-i18n/fcitx-qt5/fcitx-qt5-1.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-qt5"
+fi
+
+DESCRIPTION="Fcitx input method module for Qt 5"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-qt5"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="BSD GPL-2+ GPL-3+ LGPL-2+"
+SLOT="4"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+# Private headers of dev-qt/qtgui:5 used.
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ virtual/libintl
+ x11-libs/libxkbcommon"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+ kde-frameworks/extra-cmake-modules:5
+ virtual/pkgconfig"
+
+DOCS=()