summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-09-11 23:47:59 -0400
committerMike Frysinger <vapier@gentoo.org>2015-09-11 23:47:59 -0400
commit40c56e010bd9cd674ac3b4366cb678eaa1544ac4 (patch)
tree527da95d99727e9c654041c1bb882bcb7c0f7b8b
parentsys-apps/dmapi: drop old versions (diff)
downloadgentoo-40c56e010bd9cd674ac3b4366cb678eaa1544ac4.tar.gz
gentoo-40c56e010bd9cd674ac3b4366cb678eaa1544ac4.tar.bz2
gentoo-40c56e010bd9cd674ac3b4366cb678eaa1544ac4.zip
sys-apps/dmapi: fix build w/newer glibc #560212
As glibc cleans up its headers to not implicitly include things, packages like dmapi break a little as they don't include headers they need.
-rw-r--r--sys-apps/dmapi/dmapi-2.2.12-r1.ebuild1
-rw-r--r--sys-apps/dmapi/files/dmapi-2.2.12-headers.patch16
2 files changed, 17 insertions, 0 deletions
diff --git a/sys-apps/dmapi/dmapi-2.2.12-r1.ebuild b/sys-apps/dmapi/dmapi-2.2.12-r1.ebuild
index 54291171b34a..8c8af810c53a 100644
--- a/sys-apps/dmapi/dmapi-2.2.12-r1.ebuild
+++ b/sys-apps/dmapi/dmapi-2.2.12-r1.ebuild
@@ -24,6 +24,7 @@ src_prepare() {
-e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
include/builddefs.in \
|| die
+ epatch "${FILESDIR}"/${P}-headers.patch
multilib_copy_sources
}
diff --git a/sys-apps/dmapi/files/dmapi-2.2.12-headers.patch b/sys-apps/dmapi/files/dmapi-2.2.12-headers.patch
new file mode 100644
index 000000000000..259e1aec3a09
--- /dev/null
+++ b/sys-apps/dmapi/files/dmapi-2.2.12-headers.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/560212
+
+pull in headers for funcs that are used
+
+--- a/libdm/dm_handle2path.c
++++ b/libdm/dm_handle2path.c
+@@ -20,6 +20,9 @@
+ #include <dmapi_kern.h>
+ #include "dmapi_lib.h"
+
++#include <fcntl.h> /* open */
++#include <unistd.h> /* close */
++#include <string.h> /* strlen */
+ #include <mntent.h>
+ #include <dirent.h>
+ #ifdef linux