summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2016-05-29 21:17:06 -0700
committerMatt Turner <mattst88@gentoo.org>2016-05-29 21:17:21 -0700
commit4117f540eecfb16209d6fe3d75eb915208ed154f (patch)
tree2a41c161c76b6aaf0e874cf7520ef782473abfec
parentapp-vim/gentoo-syntax: version bump to 20160530 (diff)
downloadgentoo-4117f540eecfb16209d6fe3d75eb915208ed154f.tar.gz
gentoo-4117f540eecfb16209d6fe3d75eb915208ed154f.tar.bz2
gentoo-4117f540eecfb16209d6fe3d75eb915208ed154f.zip
dev-lang/python: Drop append-flags -fPIC alpha workaround.
Unknown what it was working around. The same existed for amd64 and hppa but both were removed more than ten years ago.
-rw-r--r--dev-lang/python/python-2.7.11-r2.ebuild2
-rw-r--r--dev-lang/python/python-3.3.5-r8.ebuild2
-rw-r--r--dev-lang/python/python-3.4.3-r7.ebuild2
-rw-r--r--dev-lang/python/python-3.5.0-r2.ebuild2
-rw-r--r--dev-lang/python/python-3.5.1-r2.ebuild2
5 files changed, 0 insertions, 10 deletions
diff --git a/dev-lang/python/python-2.7.11-r2.ebuild b/dev-lang/python/python-2.7.11-r2.ebuild
index 5e7b2b60b9ff..50bc7a255dbb 100644
--- a/dev-lang/python/python-2.7.11-r2.ebuild
+++ b/dev-lang/python/python-2.7.11-r2.ebuild
@@ -151,8 +151,6 @@ src_configure() {
filter-flags -malign-double
- [[ "${ARCH}" == "alpha" ]] && append-flags -fPIC
-
# https://bugs.gentoo.org/show_bug.cgi?id=50309
if is-flagq -O3; then
is-flagq -fstack-protector-all && replace-flags -O3 -O2
diff --git a/dev-lang/python/python-3.3.5-r8.ebuild b/dev-lang/python/python-3.3.5-r8.ebuild
index 3964d8a4c977..996044988259 100644
--- a/dev-lang/python/python-3.3.5-r8.ebuild
+++ b/dev-lang/python/python-3.3.5-r8.ebuild
@@ -136,8 +136,6 @@ src_configure() {
filter-flags -malign-double
- [[ "${ARCH}" == "alpha" ]] && append-flags -fPIC
-
# https://bugs.gentoo.org/show_bug.cgi?id=50309
if is-flagq -O3; then
is-flagq -fstack-protector-all && replace-flags -O3 -O2
diff --git a/dev-lang/python/python-3.4.3-r7.ebuild b/dev-lang/python/python-3.4.3-r7.ebuild
index e281de48745d..38e922817b31 100644
--- a/dev-lang/python/python-3.4.3-r7.ebuild
+++ b/dev-lang/python/python-3.4.3-r7.ebuild
@@ -118,8 +118,6 @@ src_configure() {
filter-flags -malign-double
- [[ "${ARCH}" == "alpha" ]] && append-flags -fPIC
-
# https://bugs.gentoo.org/show_bug.cgi?id=50309
if is-flagq -O3; then
is-flagq -fstack-protector-all && replace-flags -O3 -O2
diff --git a/dev-lang/python/python-3.5.0-r2.ebuild b/dev-lang/python/python-3.5.0-r2.ebuild
index cde95c3b5aca..69046a9c32ac 100644
--- a/dev-lang/python/python-3.5.0-r2.ebuild
+++ b/dev-lang/python/python-3.5.0-r2.ebuild
@@ -120,8 +120,6 @@ src_configure() {
filter-flags -malign-double
- [[ "${ARCH}" == "alpha" ]] && append-flags -fPIC
-
# https://bugs.gentoo.org/show_bug.cgi?id=50309
if is-flagq -O3; then
is-flagq -fstack-protector-all && replace-flags -O3 -O2
diff --git a/dev-lang/python/python-3.5.1-r2.ebuild b/dev-lang/python/python-3.5.1-r2.ebuild
index 480c6ad515ae..3d70eec000cb 100644
--- a/dev-lang/python/python-3.5.1-r2.ebuild
+++ b/dev-lang/python/python-3.5.1-r2.ebuild
@@ -117,8 +117,6 @@ src_configure() {
filter-flags -malign-double
- [[ "${ARCH}" == "alpha" ]] && append-flags -fPIC
-
# https://bugs.gentoo.org/show_bug.cgi?id=50309
if is-flagq -O3; then
is-flagq -fstack-protector-all && replace-flags -O3 -O2