summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-12-08 16:45:09 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-12-08 16:52:06 -0600
commit413be532fe8a623565bda58c258d30245f7cb714 (patch)
treefdc83f8235644e8bdef03a95fe2bac7cd919cb3b
parentapp-crypt/acme: update 9999 (diff)
downloadgentoo-413be532fe8a623565bda58c258d30245f7cb714.tar.gz
gentoo-413be532fe8a623565bda58c258d30245f7cb714.tar.bz2
gentoo-413be532fe8a623565bda58c258d30245f7cb714.zip
app-crypt/certbot: 0.20.0 bup
Package-Manager: Portage-2.3.14, Repoman-2.3.6
-rw-r--r--app-crypt/certbot/Manifest5
-rw-r--r--app-crypt/certbot/certbot-0.20.0.ebuild54
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild4
3 files changed, 60 insertions, 3 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index 6b09ec52c854..f8758e2b5cf5 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1,2 +1,3 @@
-DIST certbot-0.18.2.tar.gz 1044019 SHA256 c8a94e3e2dfa8efa379912a8dc67f561cf6daf7d8e13dbb76b40a38cfb40c08d SHA512 30dea063cf8d4bd714a40c1a82a7f4aab51e3a7d4de0d5f9a923f95badb2881562562c4a198da6a4c3cd1db7f9e2d124c2def70f3a245faca0040438586bf6a4 WHIRLPOOL 79105ea9d54fdd42dbb4327dd3afa7beb80e5a13eef0a1d3236f5150b42281b299a06391a93372c80a04f0bd962565522e3ddd239cd4d2186e32262fedf97481
-DIST certbot-0.19.0.tar.gz 1061557 SHA256 164b496cc111f19619da1eac9e3fe03baac5ad5a97c2fa19eeffe07273c4b723 SHA512 d29c9e2041171f2574bf2ee9ff7442b80b261a03f9e82e4dd40aad0617730aca6bff17fcc728496bda4133f86a4894cf21d083dacb0d0df2dec11d23e4e1541b WHIRLPOOL 203f00121dfc95136821dcbe224419b02f4f03aa1bfaf1d5516baa7f3e43aa898f30488026a18ffb27d238c5603892df8fca059d0670993f6b72b27af7ac82a1
+DIST certbot-0.18.2.tar.gz 1044019 BLAKE2B d198252c1e3e24a80bcadeecde7fd133e454036df6bd782585b31234ddd8d393fc2ab792e60f381eabd9fb453ee2a57d132ba7d41254c8acd9cf64dbfb94fb89 SHA512 30dea063cf8d4bd714a40c1a82a7f4aab51e3a7d4de0d5f9a923f95badb2881562562c4a198da6a4c3cd1db7f9e2d124c2def70f3a245faca0040438586bf6a4
+DIST certbot-0.19.0.tar.gz 1061557 BLAKE2B 4f1c623276cbcc88d414dd9d135b65f472d1e35cfef74901fb8031d40d414266870229b6aaf60a4bfde983c7e930819e5e7326d5cfa3cbffb155e3a9c724883a SHA512 d29c9e2041171f2574bf2ee9ff7442b80b261a03f9e82e4dd40aad0617730aca6bff17fcc728496bda4133f86a4894cf21d083dacb0d0df2dec11d23e4e1541b
+DIST certbot-0.20.0.tar.gz 1108139 BLAKE2B 6af07dd245912741592761bd11160c081e278e5f48b69747669aa6146d81cc7ad6f0d9c7b4bf31ad137d51bd378f670e5e5d7318efe7b3b5463d52515a5df257 SHA512 92c128bc955a576a1eb568d39b3a5568f9bd841acefaa455d716ce5036312d0ad67b3dcfcf960b15abdd39c1f34f82ffe2ebca0722628c5c804fc5472a6c0546
diff --git a/app-crypt/certbot/certbot-0.20.0.ebuild b/app-crypt/certbot/certbot-0.20.0.ebuild
new file mode 100644
index 000000000000..ce2ba763042c
--- /dev/null
+++ b/app-crypt/certbot/certbot-0.20.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+CDEPEND=">=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${CDEPEND}
+ ~app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.2[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? (
+ >=dev-python/astroid-1.3.5[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ipdb[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.4.2[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests -v ${PN} || die
+}
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index d0a136c58375..ce2ba763042c 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -42,7 +42,9 @@ DEPEND="
>=dev-python/astroid-1.3.5[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/ipdb[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
>=dev-python/pylint-1.4.2[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
)"