summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-07-05 17:09:01 +0800
committerYixun Lan <dlan@gentoo.org>2016-07-05 17:10:03 +0800
commit41709353b0082a035bd5ac773cc7b30eb9d51f68 (patch)
treea10abe4bbb1c1c4f54d395536130668b7e352e15
parentdev-ruby/rack-2.0.1-r0: add ~alpha keyword (diff)
downloadgentoo-41709353b0082a035bd5ac773cc7b30eb9d51f68.tar.gz
gentoo-41709353b0082a035bd5ac773cc7b30eb9d51f68.tar.bz2
gentoo-41709353b0082a035bd5ac773cc7b30eb9d51f68.zip
sys-process/criu: revert to ARCH=aarch64
upstream try to parse ARCH=arm64, but internally still using ARCH=aarch64 Package-Manager: portage-2.3.0_rc1
-rw-r--r--sys-process/criu/criu-2.3.ebuild2
-rw-r--r--sys-process/criu/files/2.3/criu-2.3-aarch64.patch22
2 files changed, 24 insertions, 0 deletions
diff --git a/sys-process/criu/criu-2.3.ebuild b/sys-process/criu/criu-2.3.ebuild
index d67ab0785488..faf66edb4a00 100644
--- a/sys-process/criu/criu-2.3.ebuild
+++ b/sys-process/criu/criu-2.3.ebuild
@@ -41,12 +41,14 @@ PATCHES=(
"${FILESDIR}"/${PV}/${P}-no-git.patch
"${FILESDIR}"/2.0/${PN}-2.0-automagic-libbsd.patch
"${FILESDIR}"/2.0/${PN}-2.0-sysroot.patch
+ "${FILESDIR}"/${PV}/${P}-aarch64.patch
)
criu_arch() {
# criu infers the arch from $(uname -m). We never want this to happen.
case ${ARCH} in
amd64) echo "x86";;
+ arm64) echo "aarch64";;
*) echo "${ARCH}";;
esac
}
diff --git a/sys-process/criu/files/2.3/criu-2.3-aarch64.patch b/sys-process/criu/files/2.3/criu-2.3-aarch64.patch
new file mode 100644
index 000000000000..e857b6a1aa2b
--- /dev/null
+++ b/sys-process/criu/files/2.3/criu-2.3-aarch64.patch
@@ -0,0 +1,22 @@
+diff --git a/Makefile b/Makefile
+index 0e2636b..ef8f78b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -25,7 +25,7 @@ export SRC_DIR
+
+ #
+ # Architecture specific options.
+-ifneq ($(filter-out x86 arm arm64 ppc64,$(ARCH)),)
++ifneq ($(filter-out x86 arm aarch64 ppc64,$(ARCH)),)
+ $(error "The architecture $(ARCH) isn't supported")
+ endif
+
+@@ -39,7 +39,7 @@ ifeq ($(ARCH),arm)
+ SRCARCH := arm
+ endif
+
+-ifeq ($(ARCH),arm64)
++ifeq ($(ARCH),aarch64)
+ ARCH := aarch64
+ SRCARCH := aarch64
+ VDSO := y