summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-04-11 21:30:59 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-04-11 21:30:59 +0000
commit42c6b013d4dfb7d2967f41fab1714647fd33103d (patch)
tree06ef6d31c492fdca850932960fbf034a59fc293f
parent2021-04-11 21:05:26 UTC (diff)
parentsys-libs/gpm: make CONFIG_INPUT_MOUSEDEV check non-fatal (diff)
downloadgentoo-42c6b013d4dfb7d2967f41fab1714647fd33103d.tar.gz
gentoo-42c6b013d4dfb7d2967f41fab1714647fd33103d.tar.bz2
gentoo-42c6b013d4dfb7d2967f41fab1714647fd33103d.zip
Merge updates from master
-rw-r--r--eclass/autotools.eclass126
-rw-r--r--eclass/flag-o-matic.eclass100
-rw-r--r--eclass/gnuconfig.eclass72
-rw-r--r--sys-auth/nss_ldap/files/nss_ldap-265-libdir.patch31
-rw-r--r--sys-auth/nss_ldap/nss_ldap-265-r9.ebuild (renamed from sys-auth/nss_ldap/nss_ldap-265-r8.ebuild)10
-rw-r--r--sys-libs/gpm/gpm-1.20.7-r3.ebuild2
6 files changed, 249 insertions, 92 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index 3e6906cb469a..46f2c9744a08 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -4,7 +4,7 @@
# @ECLASS: autotools.eclass
# @MAINTAINER:
# base-system@gentoo.org
-# @SUPPORTED_EAPIS: 0 1 2 3 4 5 6 7
+# @SUPPORTED_EAPIS: 5 6 7
# @BLURB: Regenerates auto* build scripts
# @DESCRIPTION:
# This eclass is for safely handling autotooled software packages that need to
@@ -19,19 +19,23 @@ if [[ ${__AUTOTOOLS_AUTO_DEPEND+set} == "set" ]] ; then
# eclass at that point, but that adds overhead, and it's trivial
# to re-order inherit in eclasses/ebuilds instead. #409611
if [[ ${__AUTOTOOLS_AUTO_DEPEND} != ${AUTOTOOLS_AUTO_DEPEND} ]] ; then
- die "AUTOTOOLS_AUTO_DEPEND changed value between inherits; please inherit autotools.eclass first! ${__AUTOTOOLS_AUTO_DEPEND} -> ${AUTOTOOLS_AUTO_DEPEND}"
+ die "AUTOTOOLS_AUTO_DEPEND changed value between inherits; please inherit ${ECLASS} first! ${__AUTOTOOLS_AUTO_DEPEND} -> ${AUTOTOOLS_AUTO_DEPEND}"
fi
fi
-if [[ -z ${_AUTOTOOLS_ECLASS} ]]; then
+if [[ -z ${_AUTOTOOLS_ECLASS} ]] ; then
_AUTOTOOLS_ECLASS=1
-case ${EAPI:-0} in
- 0|1|2|3|4|5|6|7) ;;
+case ${EAPI} in
+ 5|6)
+ # Needed for eqawarn
+ inherit eutils
+ ;;
+ 7) ;;
*) die "${ECLASS}: EAPI ${EAPI} not supported" ;;
esac
-inherit libtool
+inherit gnuconfig libtool
# @ECLASS-VARIABLE: WANT_AUTOCONF
# @PRE_INHERIT
@@ -74,21 +78,14 @@ _LATEST_AUTOMAKE=( 1.16.2-r1:1.16 )
_automake_atom="sys-devel/automake"
_autoconf_atom="sys-devel/autoconf"
-if [[ -n ${WANT_AUTOMAKE} ]]; then
+if [[ -n ${WANT_AUTOMAKE} ]] ; then
case ${WANT_AUTOMAKE} in
# Even if the package doesn't use automake, we still need to depend
# on it because we run aclocal to process m4 macros. This matches
# the autoreconf tool, so this requirement is correct, bug #401605.
none) ;;
- latest)
- # Use SLOT deps if we can. For EAPI=0, we get pretty close.
- if [[ ${EAPI:-0} != 0 ]] ; then
- _automake_atom="|| ( `printf '>=sys-devel/automake-%s:%s ' ${_LATEST_AUTOMAKE[@]/:/ }` )"
- else
- _automake_atom="|| ( `printf '>=sys-devel/automake-%s ' ${_LATEST_AUTOMAKE[@]/%:*}` )"
- fi
- ;;
- *) _automake_atom="=sys-devel/automake-${WANT_AUTOMAKE}*" ;;
+ latest) _automake_atom="|| ( `printf '>=sys-devel/automake-%s:%s ' ${_LATEST_AUTOMAKE[@]/:/ }` )" ;;
+ *) _automake_atom="=sys-devel/automake-${WANT_AUTOMAKE}*" ;;
esac
export WANT_AUTOMAKE
fi
@@ -114,9 +111,16 @@ if [[ -n ${WANT_LIBTOOL} ]] ; then
export WANT_LIBTOOL
fi
+# @ECLASS-VARIABLE: AUTOTOOLS_DEPEND
+# @INTERNAL
+# @DESCRIPTION:
+# Contains the combination of requested automake/autoconf/libtool
+# versions in *DEPEND format.
AUTOTOOLS_DEPEND="${_automake_atom}
${_autoconf_atom}
- ${_libtool_atom}"
+ ${_libtool_atom}
+ sys-apps/gawk
+"
RDEPEND=""
# @ECLASS-VARIABLE: AUTOTOOLS_AUTO_DEPEND
@@ -127,8 +131,8 @@ RDEPEND=""
# their own DEPEND string.
: ${AUTOTOOLS_AUTO_DEPEND:=yes}
if [[ ${AUTOTOOLS_AUTO_DEPEND} != "no" ]] ; then
- case ${EAPI:-0} in
- 0|1|2|3|4|5|6) DEPEND=${AUTOTOOLS_DEPEND} ;;
+ case ${EAPI} in
+ 5|6) DEPEND=${AUTOTOOLS_DEPEND} ;;
7) BDEPEND=${AUTOTOOLS_DEPEND} ;;
esac
fi
@@ -141,12 +145,14 @@ unset _automake_atom _autoconf_atom
# @DESCRIPTION:
# Additional options to pass to automake during
# eautoreconf call.
+: ${AM_OPTS:=}
# @ECLASS-VARIABLE: AT_NOEAUTOHEADER
# @DEFAULT_UNSET
# @DESCRIPTION:
# Don't run eautoheader command if set to 'yes'; only used to work around
# packages that don't want their headers being modified.
+: ${AT_NOEAUTOHEADER:=}
# @ECLASS-VARIABLE: AT_NOEAUTOMAKE
# @DEFAULT_UNSET
@@ -154,6 +160,7 @@ unset _automake_atom _autoconf_atom
# Don't run eautomake command if set to 'yes'; only used to workaround
# broken packages. Generally you should, instead, fix the package to
# not call AM_INIT_AUTOMAKE if it doesn't actually use automake.
+: ${AT_NOEAUTOMAKE:=}
# @ECLASS-VARIABLE: AT_NOELIBTOOLIZE
# @DEFAULT_UNSET
@@ -161,6 +168,7 @@ unset _automake_atom _autoconf_atom
# Don't run elibtoolize command if set to 'yes',
# useful when elibtoolize needs to be ran with
# particular options
+: ${AT_NOELIBTOOLIZE:=}
# @ECLASS-VARIABLE: AT_M4DIR
# @DEFAULT_UNSET
@@ -245,7 +253,7 @@ eautoreconf() {
done
${rerun_aclocal} && eaclocal
- if [[ ${WANT_AUTOCONF} = 2.1 ]] ; then
+ if [[ ${WANT_AUTOCONF} == "2.1" ]] ; then
eautoconf
else
eautoconf --force
@@ -265,6 +273,7 @@ eautoreconf() {
# @FUNCTION: _at_uses_pkg
# @USAGE: <macros>
# @INTERNAL
+# @DESCRIPTION:
# See if the specified macros are enabled.
_at_uses_pkg() {
if [[ -n $(autotools_check_macro "$@") ]] ; then
@@ -337,7 +346,7 @@ eaclocal() {
_elibtoolize() {
local LIBTOOLIZE=${LIBTOOLIZE:-$(type -P glibtoolize > /dev/null && echo glibtoolize || echo libtoolize)}
- if [[ $1 == "--auto-ltdl" ]] ; then
+ if [[ ${1} == "--auto-ltdl" ]] ; then
shift
_at_uses_libltdl && set -- "$@" --ltdl
fi
@@ -365,23 +374,26 @@ eautoconf() {
echo
die "No configure.{ac,in} present!"
fi
+
if [[ ${WANT_AUTOCONF} != "2.1" && -e configure.in ]] ; then
- eqawarn "This package has a configure.in file which has long been deprecated. Please"
- eqawarn "update it to use configure.ac instead as newer versions of autotools will die"
- eqawarn "when it finds this file. See https://bugs.gentoo.org/426262 for details."
+ case ${EAPI} in
+ 5|6|7)
+ eqawarn "This package has a configure.in file which has long been deprecated. Please"
+ eqawarn "update it to use configure.ac instead as newer versions of autotools will die"
+ eqawarn "when it finds this file. See https://bugs.gentoo.org/426262 for details."
+ ;;
+ *)
+ # Move configure file to the new location only on newer EAPIs to ensure
+ # checks are done rather than retroactively breaking ebuilds.
+ einfo "Moving configure.in to configure.ac (bug #426262)"
+ mv configure.{in,ac} || die
+ ;;
+ esac
fi
# Install config.guess and config.sub which are required by many macros
# in autoconf >=2.70.
- local _gnuconfig
- case ${EAPI:-0} in
- 0|1|2|3|4|5|6)
- _gnuconfig="${EPREFIX}/usr/share/gnuconfig"
- ;;
- *)
- _gnuconfig="${BROOT}/usr/share/gnuconfig"
- ;;
- esac
+ local _gnuconfig=$(gnuconfig_findnewest)
cp "${_gnuconfig}"/config.{guess,sub} . || die
autotools_run_tool --at-m4flags autoconf "$@"
@@ -409,7 +421,7 @@ eautomake() {
if [[ -z ${makefile_name} ]] ; then
_at_uses_automake || return 0
- elif [[ -z ${FROM_EAUTORECONF} && -f ${makefile_name%.am}.in ]]; then
+ elif [[ -z ${FROM_EAUTORECONF} && -f ${makefile_name%.am}.in ]] ; then
local used_automake
local installed_automake
@@ -417,7 +429,7 @@ eautomake() {
used_automake=$(head -n 1 < ${makefile_name%.am}.in | \
sed -e 's:.*by automake \(.*\) from .*:\1:')
- if [[ ${installed_automake} != ${used_automake} ]]; then
+ if [[ ${installed_automake} != ${used_automake} ]] ; then
ewarn "Automake used for the package (${used_automake}) differs from" \
"the installed version (${installed_automake})."
ewarn "Forcing a full rebuild of the autotools to workaround."
@@ -432,8 +444,8 @@ eautomake() {
# Older versions of automake do not support --force-missing. But we want
# to use this whenever possible to update random bundled files, bug #133489.
case $(_automake_version) in
- 1.4|1.4[.-]*) ;;
- *) extra_opts+=( --force-missing ) ;;
+ 1.4|1.4[.-]*) ;;
+ *) extra_opts+=( --force-missing ) ;;
esac
autotools_run_tool automake --add-missing --copy "${extra_opts[@]}" "$@"
@@ -455,8 +467,8 @@ eautopoint() {
config_rpath_update() {
local dst src
- case ${EAPI:-0} in
- 0|1|2|3|4|5|6)
+ case ${EAPI} in
+ 5|6)
src="${EPREFIX}/usr/share/gettext/config.rpath"
;;
*)
@@ -481,12 +493,12 @@ config_rpath_update() {
autotools_env_setup() {
# We do the "latest" → version switch here because it solves
# possible order problems, see bug #270010 as an example.
- if [[ ${WANT_AUTOMAKE} == "latest" ]]; then
+ if [[ ${WANT_AUTOMAKE} == "latest" ]] ; then
local pv
for pv in ${_LATEST_AUTOMAKE[@]/#*:} ; do
# Break on first hit to respect _LATEST_AUTOMAKE order.
local hv_args=""
- case ${EAPI:-0} in
+ case ${EAPI} in
5|6)
hv_args="--host-root"
;;
@@ -511,24 +523,24 @@ autotools_env_setup() {
autotools_run_tool() {
# Process our own internal flags first
local autofail=true m4flags=false missing_ok=false return_output=false
- while [[ -n $1 ]] ; do
- case $1 in
- --at-no-fail) autofail=false;;
- --at-m4flags) m4flags=true;;
- --at-missing) missing_ok=true;;
- --at-output) return_output=true;;
- # whatever is left goes to the actual tool
- *) break;;
+ while [[ -n ${1} ]] ; do
+ case ${1} in
+ --at-no-fail) autofail=false ;;
+ --at-m4flags) m4flags=true ;;
+ --at-missing) missing_ok=true ;;
+ --at-output) return_output=true ;;
+ # whatever is left goes to the actual tool
+ *) break ;;
esac
shift
done
- if [[ ${EBUILD_PHASE} != "unpack" && ${EBUILD_PHASE} != "prepare" ]]; then
- ewarn "QA Warning: running '$1' in ${EBUILD_PHASE} phase"
+ if [[ ${EBUILD_PHASE_FUNC} != "src_unpack" && ${EBUILD_PHASE_FUNC} != "src_prepare" ]] ; then
+ eqawarn "Running '${1}' in ${EBUILD_PHASE_FUNC} phase"
fi
if ${missing_ok} && ! type -P ${1} >/dev/null ; then
- einfo "Skipping '$*' because '$1' not installed"
+ einfo "Skipping '$*' because '${1}' not installed"
return 0
fi
@@ -557,19 +569,19 @@ autotools_run_tool() {
return
fi
- printf "***** $1 *****\n***** PWD: ${PWD}\n***** $*\n\n" > "${STDERR_TARGET}"
+ printf "***** ${1} *****\n***** PWD: ${PWD}\n***** $*\n\n" > "${STDERR_TARGET}"
- ebegin "Running $@"
+ ebegin "Running '$@'"
"$@" >> "${STDERR_TARGET}" 2>&1
if ! eend $? && ${autofail} ; then
echo
- eerror "Failed running '$1'!"
+ eerror "Failed running '${1}'!"
eerror
eerror "Include in your bug report the contents of:"
eerror
eerror " ${STDERR_TARGET}"
echo
- die "Failed running '$1'!"
+ die "Failed running '${1}'!"
fi
}
@@ -642,7 +654,7 @@ _autotools_m4dir_include() {
# We handle it below
-${flag}) ;;
*)
- [[ ! -d ${x} ]] && ewarn "autotools.eclass: '${x}' does not exist"
+ [[ ! -d ${x} ]] && ewarn "${ECLASS}: '${x}' does not exist"
include_opts+=" -${flag} ${x}"
;;
esac
diff --git a/eclass/flag-o-matic.eclass b/eclass/flag-o-matic.eclass
index 20ee39d98bad..ed1b6e746cef 100644
--- a/eclass/flag-o-matic.eclass
+++ b/eclass/flag-o-matic.eclass
@@ -1,27 +1,52 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: flag-o-matic.eclass
# @MAINTAINER:
# toolchain@gentoo.org
+# @SUPPORTED_EAPIS: 5 6 7
# @BLURB: common functions to manipulate and query toolchain flags
# @DESCRIPTION:
# This eclass contains a suite of functions to help developers sanely
# and safely manage toolchain flags in their builds.
+case ${EAPI:-0} in
+ 0|1|2|3|4) die "flag-o-matic.eclass: EAPI ${EAPI} is too old." ;;
+ 5|6|7) ;;
+ *) die "EAPI ${EAPI} is not supported by flag-o-matic.eclass." ;;
+esac
+
if [[ -z ${_FLAG_O_MATIC_ECLASS} ]]; then
_FLAG_O_MATIC_ECLASS=1
-inherit eutils toolchain-funcs multilib
+inherit toolchain-funcs
+
+[[ ${EAPI} == [567] ]] && inherit eutils
+# @FUNCTION: all-flag-vars
+# @DESCRIPTION:
# Return all the flag variables that our high level funcs operate on.
all-flag-vars() {
echo {ADA,C,CPP,CXX,CCAS,F,FC,LD}FLAGS
}
+# @FUNCTION: setup-allowed-flags
+# @INTERNAL
+# @DESCRIPTION:
# {C,CPP,CXX,CCAS,F,FC,LD}FLAGS that we allow in strip-flags
# Note: shell globs and character lists are allowed
setup-allowed-flags() {
+ [[ ${EAPI} == [567] ]] ||
+ die "Internal function ${FUNCNAME} is not available in EAPI ${EAPI}."
+ _setup-allowed-flags "$@"
+}
+
+# @FUNCTION: _setup-allowed-flags
+# @INTERNAL
+# @DESCRIPTION:
+# {C,CPP,CXX,CCAS,F,FC,LD}FLAGS that we allow in strip-flags
+# Note: shell globs and character lists are allowed
+_setup-allowed-flags() {
ALLOWED_FLAGS=(
-pipe -O '-O[12sg]' -mcpu -march -mtune
'-fstack-protector*' '-fsanitize*' '-fstack-check*' -fno-stack-check
@@ -87,7 +112,10 @@ setup-allowed-flags() {
)
}
-# inverted filters for hardened compiler. This is trying to unpick
+# @FUNCTION: _filter-hardened
+# @INTERNAL
+# @DESCRIPTION:
+# Inverted filters for hardened compiler. This is trying to unpick
# the hardened compiler defaults.
_filter-hardened() {
local f
@@ -121,6 +149,9 @@ _filter-hardened() {
done
}
+# @FUNCTION: _filter-var
+# @INTERNAL
+# @DESCRIPTION:
# Remove occurrences of strings from variable given in $1
# Strings removed are matched as globs, so for example
# '-O*' would remove -O1, -O2 etc.
@@ -313,6 +344,11 @@ replace-cpu-flags() {
return 0
}
+# @FUNCTION: _is_flagq
+# @USAGE: <variable> <flag>
+# @INTERNAL
+# @DESCRIPTION:
+# Returns shell true if <flag> is in a given <variable>, else returns shell false.
_is_flagq() {
local x var="$1[*]"
for x in ${!var} ; do
@@ -405,7 +441,7 @@ strip-flags() {
local x y var
local ALLOWED_FLAGS
- setup-allowed-flags
+ _setup-allowed-flags
set -f # disable pathname expansion
@@ -438,7 +474,25 @@ strip-flags() {
return 0
}
+# @FUNCTION: test-flag-PROG
+# @USAGE: <compiler> <flag>
+# @INTERNAL
+# @DESCRIPTION:
+# Returns shell true if <flag> is supported by given <compiler>,
+# else returns shell false.
test-flag-PROG() {
+ [[ ${EAPI} == [567] ]] ||
+ die "Internal function ${FUNCNAME} is not available in EAPI ${EAPI}."
+ _test-flag-PROG "$@"
+}
+
+# @FUNCTION: _test-flag-PROG
+# @USAGE: <compiler> <flag>
+# @INTERNAL
+# @DESCRIPTION:
+# Returns shell true if <flag> is supported by given <compiler>,
+# else returns shell false.
+_test-flag-PROG() {
local comp=$1
local lang=$2
shift 2
@@ -533,33 +587,51 @@ test-flag-PROG() {
# @USAGE: <flag>
# @DESCRIPTION:
# Returns shell true if <flag> is supported by the C compiler, else returns shell false.
-test-flag-CC() { test-flag-PROG "CC" c "$@"; }
+test-flag-CC() { _test-flag-PROG CC c "$@"; }
# @FUNCTION: test-flag-CXX
# @USAGE: <flag>
# @DESCRIPTION:
# Returns shell true if <flag> is supported by the C++ compiler, else returns shell false.
-test-flag-CXX() { test-flag-PROG "CXX" c++ "$@"; }
+test-flag-CXX() { _test-flag-PROG CXX c++ "$@"; }
# @FUNCTION: test-flag-F77
# @USAGE: <flag>
# @DESCRIPTION:
# Returns shell true if <flag> is supported by the Fortran 77 compiler, else returns shell false.
-test-flag-F77() { test-flag-PROG "F77" f77 "$@"; }
+test-flag-F77() { _test-flag-PROG F77 f77 "$@"; }
# @FUNCTION: test-flag-FC
# @USAGE: <flag>
# @DESCRIPTION:
# Returns shell true if <flag> is supported by the Fortran 90 compiler, else returns shell false.
-test-flag-FC() { test-flag-PROG "FC" f95 "$@"; }
+test-flag-FC() { _test-flag-PROG FC f95 "$@"; }
# @FUNCTION: test-flag-CCLD
# @USAGE: <flag>
# @DESCRIPTION:
# Returns shell true if <flag> is supported by the C compiler and linker, else returns shell false.
-test-flag-CCLD() { test-flag-PROG "CC" c+ld "$@"; }
+test-flag-CCLD() { _test-flag-PROG CC c+ld "$@"; }
+# @FUNCTION: test-flags-PROG
+# @USAGE: <compiler> <flag> [more flags...]
+# @INTERNAL
+# @DESCRIPTION:
+# Returns shell true if <flags> are supported by given <compiler>,
+# else returns shell false.
test-flags-PROG() {
+ [[ ${EAPI} == [567] ]] ||
+ die "Internal function ${FUNCNAME} is not available in EAPI ${EAPI}."
+ _test-flags-PROG "$@"
+}
+
+# @FUNCTION: _test-flags-PROG
+# @USAGE: <compiler> <flag> [more flags...]
+# @INTERNAL
+# @DESCRIPTION:
+# Returns shell true if <flags> are supported by given <compiler>,
+# else returns shell false.
+_test-flags-PROG() {
local comp=$1
local flags=()
local x
@@ -596,31 +668,31 @@ test-flags-PROG() {
# @USAGE: <flags>
# @DESCRIPTION:
# Returns shell true if <flags> are supported by the C compiler, else returns shell false.
-test-flags-CC() { test-flags-PROG "CC" "$@"; }
+test-flags-CC() { _test-flags-PROG CC "$@"; }
# @FUNCTION: test-flags-CXX
# @USAGE: <flags>
# @DESCRIPTION:
# Returns shell true if <flags> are supported by the C++ compiler, else returns shell false.
-test-flags-CXX() { test-flags-PROG "CXX" "$@"; }
+test-flags-CXX() { _test-flags-PROG CXX "$@"; }
# @FUNCTION: test-flags-F77
# @USAGE: <flags>
# @DESCRIPTION:
# Returns shell true if <flags> are supported by the Fortran 77 compiler, else returns shell false.
-test-flags-F77() { test-flags-PROG "F77" "$@"; }
+test-flags-F77() { _test-flags-PROG F77 "$@"; }
# @FUNCTION: test-flags-FC
# @USAGE: <flags>
# @DESCRIPTION:
# Returns shell true if <flags> are supported by the Fortran 90 compiler, else returns shell false.
-test-flags-FC() { test-flags-PROG "FC" "$@"; }
+test-flags-FC() { _test-flags-PROG FC "$@"; }
# @FUNCTION: test-flags-CCLD
# @USAGE: <flags>
# @DESCRIPTION:
# Returns shell true if <flags> are supported by the C compiler and default linker, else returns shell false.
-test-flags-CCLD() { test-flags-PROG "CCLD" "$@"; }
+test-flags-CCLD() { _test-flags-PROG CCLD "$@"; }
# @FUNCTION: test-flags
# @USAGE: <flags>
diff --git a/eclass/gnuconfig.eclass b/eclass/gnuconfig.eclass
index 3433837787c2..173df6fd25e9 100644
--- a/eclass/gnuconfig.eclass
+++ b/eclass/gnuconfig.eclass
@@ -1,25 +1,46 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-#
-# Author: Will Woods <wwoods@gentoo.org>
-#
+
+# @ECLASS: gnuconfig.eclass
+# @MAINTAINER:
+# Sam James <sam@gentoo.org>
+# @AUTHOR:
+# Will Woods <wwoods@gentoo.org>
+# @SUPPORTED_EAPIS: 5 6 7
+# @BLURB: Refresh bundled gnuconfig files (config.guess, config.sub)
+# @DESCRIPTION:
# This eclass is used to automatically update files that typically come with
# automake to the newest version available on the system. The most common use
# of this is to update config.guess and config.sub when configure dies from
# misguessing your canonical system name (CHOST). It can also be used to update
# other files that come with automake, e.g. depcomp, mkinstalldirs, etc.
#
-# usage: gnuconfig_update [file1 file2 ...]
+
+case ${EAPI:-0} in
+ 5|6|7)
+ ;;
+ *)
+ die "EAPI ${EAPI} is unsupported!"
+ ;;
+esac
+
+if [[ -z ${_GNUCONFIG_ECLASS} ]] ; then
+ _GNUCONFIG_CLASS=1
+
+BDEPEND="sys-devel/gnuconfig"
+
+[[ ${EAPI} == [56] ]] && DEPEND="${BDEPEND}"
+
+# @FUNCTION: gnuconfig_update
+# @USAGE: [file1 file2 ...]
+# @DESCRIPTION:
# if called without arguments, config.guess and config.sub will be updated.
# All files in the source tree ($S) with the given name(s) will be replaced
# with the newest available versions chosen from the list of locations in
# gnuconfig_findnewest(), below.
#
# gnuconfig_update should generally be called from src_unpack()
-
-
-DEPEND="sys-devel/gnuconfig"
-
+#
# Wrapper function for gnuconfig_do_update. If no arguments are given, update
# config.sub and config.guess (old default behavior), otherwise update the
# named files.
@@ -42,6 +63,9 @@ gnuconfig_update() {
return $?
}
+# @FUNCTION: gnuconfig_do_update
+# @INTERNAL
+# @DESCRIPTION:
# Copy the newest available version of specified files over any old ones in the
# source dir. This function shouldn't be called directly - use gnuconfig_update
#
@@ -75,16 +99,34 @@ gnuconfig_do_update() {
return 0
}
-# this searches the standard locations for the newest config.{sub|guess}, and
+# @FUNCTION: gnuconfig_findnewest
+# @INTERNAL
+# @DESCRIPTION:
+# This searches the standard locations for the newest config.{sub|guess}, and
# returns the directory where they can be found.
gnuconfig_findnewest() {
- local locations=(
- "${EPREFIX}"/usr/share/misc/config.sub
- "${EPREFIX}"/usr/share/gnuconfig/config.sub
- "${EPREFIX}"/usr/share/automake*/config.sub
- "${EPREFIX}"/usr/share/libtool/config.sub
+ local locations=()
+ local prefix
+
+ case ${EAPI} in
+ 5|6)
+ prefix="${EPREFIX}"
+ ;;
+ *)
+ prefix="${BROOT}"
+ ;;
+ esac
+
+ locations+=(
+ "${prefix}"/usr/share/misc/config.sub
+ "${prefix}"/usr/share/gnuconfig/config.sub
+ "${prefix}"/usr/share/automake*/config.sub
+ "${prefix}"/usr/share/libtool/config.sub
)
+
grep -s '^timestamp' "${locations[@]}" | \
sort -r -n -t\' -k2 | \
sed -n '1{s,/config.sub:.*$,,;p;q}'
}
+
+fi
diff --git a/sys-auth/nss_ldap/files/nss_ldap-265-libdir.patch b/sys-auth/nss_ldap/files/nss_ldap-265-libdir.patch
new file mode 100644
index 000000000000..d3609b604a23
--- /dev/null
+++ b/sys-auth/nss_ldap/files/nss_ldap-265-libdir.patch
@@ -0,0 +1,31 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -38,17 +38,13 @@
+ DEFS = @DEFS@
+ #INCLUDES = -I$(top_builddir) -I$(srcdir)
+
+-if GCC
+-MULTI_OS_DIRECTORY=$(shell $(CC) $(CFLAGS) -print-multi-os-directory)
+-else
+ MULTI_OS_DIRECTORY=.
+-endif
+
+ if GLIBC
+-LIBC_VERS = $(shell ls /lib/$(MULTI_OS_DIRECTORY)/libc-*.so | tail -n 1 | sed -e 's|.*libc-\(.*\)\.so|\1|')
++LIBC_VERS = $(shell ls @GENTOO_PORTAGE_EPREFIX@/lib/$(MULTI_OS_DIRECTORY)/libc-*.so | tail -n 1 | sed -e 's|.*libc-\(.*\)\.so|\1|')
+ NSS_LDAP_LIBC_VERSIONED = libnss_ldap-$(LIBC_VERS).so
+
+-NSS_VERS = $(shell ls /lib/$(MULTI_OS_DIRECTORY)/libnss_files.so.? | tail -n 1 | sed -e 's|.*libnss_files\.so\.\(.*\)|\1|')
++NSS_VERS = $(shell ls @GENTOO_PORTAGE_EPREFIX@/lib/$(MULTI_OS_DIRECTORY)/libnss_files.so.? | tail -n 1 | sed -e 's|.*libnss_files\.so\.\(.*\)|\1|')
+ NSS_LDAP_NSS_VERSIONED = libnss_ldap.so.$(NSS_VERS)
+ endif
+
+@@ -83,8 +79,6 @@
+ $(mkinstalldirs) $(DESTDIR)$(libdir)
+ $(INSTALL_PROGRAM) -o $(INST_UID) -g $(INST_GID) nss_ldap.so $(DESTDIR)$(libdir)/$(NSS_LDAP_LIBC_VERSIONED)
+ (cd $(DESTDIR)$(libdir); ln -sf $(NSS_LDAP_LIBC_VERSIONED) $(NSS_LDAP_NSS_VERSIONED))
+- $(mkinstalldirs) $(DESTDIR)/usr$(libdir)
+- (cd $(DESTDIR)/usr$(libdir); ln -sf ../..$(libdir)/$(NSS_LDAP_NSS_VERSIONED) .)
+ else
+ $(mkinstalldirs) $(DESTDIR)$(libdir)
+ if HPUX
diff --git a/sys-auth/nss_ldap/nss_ldap-265-r8.ebuild b/sys-auth/nss_ldap/nss_ldap-265-r9.ebuild
index e6ed3ba6fc38..749cdb870cf0 100644
--- a/sys-auth/nss_ldap/nss_ldap-265-r8.ebuild
+++ b/sys-auth/nss_ldap/nss_ldap-265-r9.ebuild
@@ -12,7 +12,7 @@ SRC_URI="http://www.padl.com/download/${P}.tar.gz"
SLOT="0"
LICENSE="LGPL-2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
-IUSE="debug kerberos ssl sasl"
+IUSE="debug kerberos ssl sasl split-usr"
DEPEND="
>=net-nds/openldap-2.4.38-r1[${MULTILIB_USEDEP}]
@@ -32,7 +32,7 @@ src_prepare() {
# eprefixify is safe on non-Prefix systems, so go unconditional
# Note: comment this out or make it conditional on 'use prefix'
# if needs rebasing. Don't remove.
- eapply "${FILESDIR}"/${P}-installdir.patch
+ eapply "${FILESDIR}"/${P}-libdir.patch
eprefixify Makefile.am
# bug 438692
@@ -121,8 +121,8 @@ multilib_src_install() {
}
multilib_src_install_all() {
- # Dumb /usr/lib* -> /lib* symlinks gone wrong
- rm -rf "${ED}"/usr/usr || die
+ use split-usr &&
+ dosym ../../$(get_libdir)/libnss_ldap.so.2 /usr/$(get_libdir)/libnss_ldap.so.2
insinto /etc
doins ldap.conf
@@ -138,7 +138,7 @@ multilib_src_install_all() {
CVSVersionInfo.txt README nsswitch.ldap certutil
docinto docs
- dodoc doc/*
+ dodoc -r doc/.
}
pkg_postinst() {
diff --git a/sys-libs/gpm/gpm-1.20.7-r3.ebuild b/sys-libs/gpm/gpm-1.20.7-r3.ebuild
index bb7b8679025a..22f9f5d1a4aa 100644
--- a/sys-libs/gpm/gpm-1.20.7-r3.ebuild
+++ b/sys-libs/gpm/gpm-1.20.7-r3.ebuild
@@ -27,7 +27,7 @@ BDEPEND="
sys-apps/texinfo
virtual/yacc"
-CONFIG_CHECK="INPUT_MOUSEDEV"
+CONFIG_CHECK="~INPUT_MOUSEDEV"
ERROR_INPUT_MOUSEDEV="CONFIG_INPUT_MOUSEDEV:\tis not set (required to expose mice for GPM)"
pkg_pretend() {