summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Turco <fturco@fastmail.fm>2017-08-17 18:50:46 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-02 11:17:03 +0200
commit43a25b2ec519c451a224020b42ce96a45bf782c6 (patch)
tree63164e046a87ccb802a6efe60027f15f01417f5e
parentsys-apps/portage: Use https for git repo (diff)
downloadgentoo-43a25b2ec519c451a224020b42ce96a45bf782c6.tar.gz
gentoo-43a25b2ec519c451a224020b42ce96a45bf782c6.tar.bz2
gentoo-43a25b2ec519c451a224020b42ce96a45bf782c6.zip
sys-fs/duperemove: fix sysmacros.h error w/ new sys-libs/glibc
Taken from https://github.com/markfasheh/duperemove/pull/169 Bug: https://bugs.gentoo.org/607376 Closes: https://github.com/gentoo/gentoo/pull/5464
-rw-r--r--sys-fs/duperemove/duperemove-0.11_beta4.ebuild2
-rw-r--r--sys-fs/duperemove/files/duperemove-0.11_beta4-sysmacros.patch10
2 files changed, 12 insertions, 0 deletions
diff --git a/sys-fs/duperemove/duperemove-0.11_beta4.ebuild b/sys-fs/duperemove/duperemove-0.11_beta4.ebuild
index d3ed853c233c..6b7691b19fa5 100644
--- a/sys-fs/duperemove/duperemove-0.11_beta4.ebuild
+++ b/sys-fs/duperemove/duperemove-0.11_beta4.ebuild
@@ -23,6 +23,8 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${P/_/.}
+PATCHES=( "${FILESDIR}/${P}-sysmacros.patch" )
+
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall"
}
diff --git a/sys-fs/duperemove/files/duperemove-0.11_beta4-sysmacros.patch b/sys-fs/duperemove/files/duperemove-0.11_beta4-sysmacros.patch
new file mode 100644
index 000000000000..6355f5e9146f
--- /dev/null
+++ b/sys-fs/duperemove/files/duperemove-0.11_beta4-sysmacros.patch
@@ -0,0 +1,10 @@
+--- a/dbfile.c 2016-09-27 22:28:49.000000000 +0200
++++ b/dbfile.c 2017-08-17 18:23:30.768591897 +0200
+@@ -8,6 +8,7 @@
+ #include <inttypes.h>
+ #include <stddef.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+
+ #include "csum.h"
+ #include "filerec.h"