summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-11-08 08:49:55 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2018-11-08 08:59:32 +0200
commit43b7346dcf8741e57371c5b0c30d56ea70ddc872 (patch)
tree1756bc5693fd648320488477caa3b550f9a14d5f
parentdev-ruby/parser: cleanup (diff)
downloadgentoo-43b7346dcf8741e57371c5b0c30d56ea70ddc872.tar.gz
gentoo-43b7346dcf8741e57371c5b0c30d56ea70ddc872.tar.bz2
gentoo-43b7346dcf8741e57371c5b0c30d56ea70ddc872.zip
app-crypt/xca: version bump
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--app-crypt/xca/Manifest1
-rw-r--r--app-crypt/xca/xca-2.1.2.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-crypt/xca/Manifest b/app-crypt/xca/Manifest
index 4db7c7221a9a..2e4ef77ece8b 100644
--- a/app-crypt/xca/Manifest
+++ b/app-crypt/xca/Manifest
@@ -1,3 +1,4 @@
DIST xca-1.4.1.tar.gz 959107 BLAKE2B 7437cdbaa5277998de200e9a5ad3a7d44aed9ae8af8fd926d7ed1917d49bec79562455ca2e82557149d748840f299ffd66edfc7f265be7d5bdcd6e4fe8dbaf9b SHA512 8294669c4887ba7a9060c3c2c06014b8a1807898569842ed61c066e8a864de014fba51a2ff867b579048083fdd4934cc7f97c92268de4944bf4aafea9c2e7b42
DIST xca-2.1.0.tar.gz 1055745 BLAKE2B c3ea2953be7cacb8c4c6fb6911f2e51806d40f294d8c9daef1d47da4f3e6ffa4933d199b8b92cab828286ececab2ea7195d5a46455e4d4703f0a67d0d7861db9 SHA512 ad46b290067b0a22bb6baeb0d065879bea74cd2c853f67c2be3d0c2bdaa5ca4ebef606c0f08bd0b130df4ec13418d470062b708ab479800eab7c18dffa46af03
DIST xca-2.1.1.tar.gz 1055613 BLAKE2B bb6d6b4742c7a799bf1a65e1ed2f8ab8b4d695e717e630600bc22f0e0d4a9ae95d5d98d3e85ccfbdd07eb08cf7dba6b94c702790e21fe4899fce8fc33e4f7154 SHA512 e7c3fdb515bb7a719a775b97efcabe71dc1ccc31a7ddd7cb1a9543fb16d131bce180917418091927334a4dd169daef919a4d9476a29ab4355688c961e3340dd3
+DIST xca-2.1.2.tar.gz 1086563 BLAKE2B d48727fffad16d840633af6e0ee38a279978a5b865eb6f391a3d852a0105817254ea0a4780875f2956e1f7e9931e6930c6ffbe82b117dbf8ad0058ec9d6f5c88 SHA512 1f104a22b83b802576b4820b7139971da50f9b3dd70aca8e1199e996bad4379b8681bb31b197b84a3dfa49cef4ae093f6622d15fac9667547ff47af43c1e5f07
diff --git a/app-crypt/xca/xca-2.1.2.ebuild b/app-crypt/xca/xca-2.1.2.ebuild
new file mode 100644
index 000000000000..2c29ff4404c1
--- /dev/null
+++ b/app-crypt/xca/xca-2.1.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit xdg-utils
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests etc"
+HOMEPAGE="https://hohnstaedt.de/xca/"
+SRC_URI="https://github.com/chris2511/${PN}/releases/download/RELEASE.${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="bindist doc libressl"
+
+RDEPEND="
+ dev-libs/libltdl:0=
+ dev-qt/qtgui:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwidgets:5
+ !libressl? ( dev-libs/openssl:0=[bindist=] )
+ libressl? ( dev-libs/libressl:0= )
+ doc? ( app-text/linuxdoc-tools )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-desktop.patch"
+)
+
+src_configure() {
+ econf \
+ --with-qt-version=5 \
+ $(use_enable doc) \
+ STRIP=true
+}
+
+src_compile() {
+ # enforce all to avoid the automatic silent rules
+ emake all
+}
+
+src_install() {
+ # non standard destdir
+ emake install destdir="${ED}"
+ einstalldocs
+
+ insinto /etc/xca
+ doins misc/*.txt
+
+ ewarn "Make a backup copy of your database!"
+ ewarn "This version completely changes the database format to SQL(ite)"
+ ewarn "Don't try to open it with older versions of XCA (< 1.4.0). They will corrupt the database."
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}