summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2017-06-11 07:12:58 +0200
committerDavide Pesavento <pesa@gentoo.org>2017-06-11 07:12:58 +0200
commit44b36faef1b2914877697d912eafc8458bbcd54c (patch)
tree8cecf810a084b6c880a73a910f8f2fbc23222b78
parentapp-backup/cdbkup: use make jobserver (diff)
downloadgentoo-44b36faef1b2914877697d912eafc8458bbcd54c.tar.gz
gentoo-44b36faef1b2914877697d912eafc8458bbcd54c.tar.bz2
gentoo-44b36faef1b2914877697d912eafc8458bbcd54c.zip
dev-python/PyQt4: remove old
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-python/PyQt4/Manifest1
-rw-r--r--dev-python/PyQt4/PyQt4-4.11.4-r1.ebuild190
2 files changed, 0 insertions, 191 deletions
diff --git a/dev-python/PyQt4/Manifest b/dev-python/PyQt4/Manifest
index 694dc284b62b..8d805255cba6 100644
--- a/dev-python/PyQt4/Manifest
+++ b/dev-python/PyQt4/Manifest
@@ -1,2 +1 @@
-DIST PyQt-x11-gpl-4.11.4.tar.gz 11317088 SHA256 fc1fe77495432ba3b0d74ff5cb164d375a97f5dddb728256330f615a7cdcf407 SHA512 58d0c5e30b0480c1b6ce1a3cc3ef0a1841bb15631830fb937d1f17f5d3d8cbe66a5e2adcfb2c3990fae38db66dd430668bd25413e254e72064a38c48f689f170 WHIRLPOOL cf635d6399bd04def2648eee65e038d720f06dddfac70f3df6f87deb7483e023ee1a4aa07285a5075adc19dc91bca4500b82f65b342e07a8845023cf98bb6233
DIST PyQt4_gpl_x11-4.12.tar.gz 11325395 SHA256 3c1d4b55314adb3e1132de8fc2a92eed216d37e58aceed41294dbca210ca88db SHA512 bc5ee53e6ab8d32e240bbbd85aec9ce18a398848c0ee73d874763156256f7942a4a452a26f34fe035fdbeba5fb1df060910688f8a1bc7f7f183543d3dd0fd731 WHIRLPOOL 001df301c9620873794c33f5294ae30ec9d4a32359d26a8607377fe2468dd33a313ef09e96d2491056cdc066edc5d80b4e80afa19976dfb2a7d291cd829e2791
diff --git a/dev-python/PyQt4/PyQt4-4.11.4-r1.ebuild b/dev-python/PyQt4/PyQt4-4.11.4-r1.ebuild
deleted file mode 100644
index 9e4875477050..000000000000
--- a/dev-python/PyQt4/PyQt4-4.11.4-r1.ebuild
+++ /dev/null
@@ -1,190 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit eutils multibuild python-r1 qmake-utils toolchain-funcs
-
-DESCRIPTION="Python bindings for the Qt framework"
-HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt/intro"
-
-MY_P=PyQt-x11-gpl-${PV/_pre/.dev}
-if [[ ${PV} == *_pre* ]]; then
- SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.xz"
-else
- SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-
-IUSE="X compat dbus debug declarative designer doc examples help kde multimedia
- opengl phonon script scripttools sql svg testlib webkit xmlpatterns"
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
- sql? ( X )
- testlib? ( X )
-"
-
-# Minimal supported version of Qt.
-QT_PV="4.8.5:4"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=dev-python/sip-4.16.6:=[${PYTHON_USEDEP}]
- >=dev-qt/qtcore-${QT_PV}
- X? ( >=dev-qt/qtgui-${QT_PV} )
- dbus? (
- dev-python/dbus-python[${PYTHON_USEDEP}]
- >=dev-qt/qtdbus-${QT_PV}
- )
- declarative? ( >=dev-qt/qtdeclarative-${QT_PV} )
- designer? ( >=dev-qt/designer-${QT_PV} )
- help? ( >=dev-qt/qthelp-${QT_PV} )
- multimedia? ( >=dev-qt/qtmultimedia-${QT_PV} )
- opengl? ( >=dev-qt/qtopengl-${QT_PV} )
- phonon? (
- kde? ( >=media-libs/phonon-4.7[qt4] )
- !kde? ( || ( >=dev-qt/qtphonon-${QT_PV} >=media-libs/phonon-4.7[qt4] ) )
- )
- script? ( >=dev-qt/qtscript-${QT_PV} )
- scripttools? ( >=dev-qt/qtgui-${QT_PV} )
- sql? ( >=dev-qt/qtsql-${QT_PV} )
- svg? ( >=dev-qt/qtsvg-${QT_PV} )
- testlib? ( >=dev-qt/qttest-${QT_PV} )
- webkit? ( >=dev-qt/qtwebkit-${QT_PV} )
- xmlpatterns? ( >=dev-qt/qtxmlpatterns-${QT_PV} )
-"
-DEPEND="${RDEPEND}
- dbus? ( virtual/pkgconfig )
-"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- # Support qreal on arm architecture (bug 322349).
- use arm && epatch "${FILESDIR}/${PN}-4.7.3-qreal_float_support.patch"
-
- # Allow building against KDE's phonon (bug 525354).
- epatch "${FILESDIR}/${PN}-4.11.2-phonon.patch"
-}
-
-pyqt_run() {
- echo "$@"
- "${PYTHON}" "$@"
-}
-
-pyqt_use_enable() {
- use "$1" || return
-
- echo --enable=${2:-Qt$(tr 'a-z' 'A-Z' <<< ${1:0:1})${1:1}}
-}
-
-src_configure() {
- configuration() {
- local myconf=(
- $(usex debug '--debug --trace' '')
- --verbose
- --confirm-license
- --qmake="$(qt4_get_bindir)"/qmake
- --bindir="${EPREFIX}/usr/bin"
- --destdir="$(python_get_sitedir)"
- --qsci-api
- --enable=QtCore
- --enable=QtNetwork
- --enable=QtXml
- $(pyqt_use_enable X QtGui)
- $(pyqt_use_enable dbus QtDBus)
- $(pyqt_use_enable declarative)
- $(pyqt_use_enable designer)
- $(usex designer '' --no-designer-plugin)
- $(pyqt_use_enable help)
- $(pyqt_use_enable multimedia)
- $(pyqt_use_enable opengl QtOpenGL)
- $(pyqt_use_enable phonon phonon)
- $(pyqt_use_enable script)
- $(pyqt_use_enable scripttools QtScriptTools)
- $(pyqt_use_enable sql)
- $(pyqt_use_enable svg)
- $(pyqt_use_enable testlib QtTest)
- $(pyqt_use_enable webkit QtWebKit)
- $(pyqt_use_enable xmlpatterns QtXmlPatterns)
- )
-
- if use compat; then
- local compat_build_dir=${BUILD_DIR%/}-compat
- cp -Rp "${S}" "${compat_build_dir}" || die
- pushd "${compat_build_dir}" >/dev/null || die
-
- local mycompatconf=(
- "${myconf[@]}"
- AR="$(tc-getAR) cqs"
- CC="$(tc-getCC)"
- CFLAGS="${CFLAGS}"
- CFLAGS_RELEASE=
- CXX="$(tc-getCXX)"
- CXXFLAGS="${CXXFLAGS}"
- CXXFLAGS_RELEASE=
- LINK="$(tc-getCXX)"
- LINK_SHLIB="$(tc-getCXX)"
- LFLAGS="${LDFLAGS}"
- LFLAGS_RELEASE=
- RANLIB=
- STRIP=
- )
- pyqt_run configure.py "${mycompatconf[@]}" || die
-
- popd >/dev/null || die
- fi
-
- myconf+=(
- $(usex dbus '' --no-python-dbus)
- )
- pyqt_run "${S}"/configure-ng.py "${myconf[@]}" || die
-
- eqmake4 -recursive ${PN}.pro
- }
- python_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- local tmp_root=${D%/}/tmp
- emake INSTALL_ROOT="${tmp_root}" install
-
- local uic_dir=${tmp_root}$(python_get_sitedir)/${PN}/uic
- if python_is_python3; then
- rm -r "${uic_dir}"/port_v2 || die
- else
- rm -r "${uic_dir}"/port_v3 || die
- fi
-
- python_doexe "${tmp_root}${EPREFIX}"/usr/bin/pyuic4
- rm "${tmp_root}${EPREFIX}"/usr/bin/pyuic4 || die
-
- multibuild_merge_root "${tmp_root}" "${D}"
-
- if use compat; then
- local compat_build_dir=${BUILD_DIR%/}-compat
- python_moduleinto ${PN}
- python_domodule "${compat_build_dir}"/pyqtconfig.py
- fi
-
- python_optimize
- }
- python_foreach_impl run_in_build_dir installation
-
- dodoc ChangeLog NEWS THANKS
- use doc && dodoc -r doc/html
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}