summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2017-08-16 13:44:10 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-22 11:07:02 +0200
commit450408c76677dce7785c35719fbea73d0f1c6367 (patch)
tree4ac030693c86ec19a43b51e89879298e8388dc7b
parentnet-dns/knot: enhance systemd service security (diff)
downloadgentoo-450408c76677dce7785c35719fbea73d0f1c6367.tar.gz
gentoo-450408c76677dce7785c35719fbea73d0f1c6367.tar.bz2
gentoo-450408c76677dce7785c35719fbea73d0f1c6367.zip
net-dns/knot: Add all app modules in USE flags
-rw-r--r--net-dns/knot/knot-2.5.3-r1.ebuild23
-rw-r--r--net-dns/knot/metadata.xml36
2 files changed, 54 insertions, 5 deletions
diff --git a/net-dns/knot/knot-2.5.3-r1.ebuild b/net-dns/knot/knot-2.5.3-r1.ebuild
index 5d116b1a44c4..1913ab2364d9 100644
--- a/net-dns/knot/knot-2.5.3-r1.ebuild
+++ b/net-dns/knot/knot-2.5.3-r1.ebuild
@@ -12,7 +12,19 @@ SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="dnstap doc caps +fastparser idn systemd"
+
+KNOT_MODULES=(
+ "+dnsproxy"
+ "dnstap"
+ "+noudp"
+ "+onlinesign"
+ "rosedb"
+ "+rrl"
+ "+stats"
+ "+synthrecord"
+ "+whoami"
+)
+IUSE="doc caps +fastparser idn systemd +utils ${KNOT_MODULES[@]}"
RDEPEND="
>=net-libs/gnutls-3.3:=
@@ -36,14 +48,21 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${P/_/-}"
src_configure() {
+ local my_conf=()
+ for u in "${KNOT_MODULES[@]#+}"; do
+ my_conf+=("$(use_with $u module-$u)")
+ done
+
econf \
--with-storage="${EPREFIX}/var/lib/${PN}" \
--with-rundir="${EPREFIX}/var/run/${PN}" \
$(use_enable fastparser) \
$(use_enable dnstap) \
$(use_enable doc documentation) \
+ $(use_enable utils utilities) \
+ --enable-systemd=$(usex systemd) \
$(use_with idn libidn) \
- --enable-systemd=$(usex systemd)
+ "${my_conf[@]}"
}
src_compile() {
diff --git a/net-dns/knot/metadata.xml b/net-dns/knot/metadata.xml
index b0de8ecf77e7..35d8e8065306 100644
--- a/net-dns/knot/metadata.xml
+++ b/net-dns/knot/metadata.xml
@@ -10,13 +10,43 @@
<name>Proxy Maintainers</name>
</maintainer>
<use>
+ <flag name="dnsproxy">
+ Enable the tiny DNS proxy module
+ </flag>
<flag name="dnstap">
Include support for the dnstap binary log format
- (http://dnstap.info/).
+ (http://dnstap.info/)
</flag>
<flag name="fastparser">
- Use a zone file parser that is faster, but requires more memory and
- CPU time to compile.
+ Use a zone file parser that is faster, but requires
+ more memory and CPU time to compile
+ </flag>
+ <flag name="noudp">
+ Enable the module which can send empty truncated
+ responses to UDP queries
+ </flag>
+ <flag name="onlinesign">
+ Enable the module that sign zones on the fly instead of
+ pre-signing zone
+ </flag>
+ <flag name="rosedb">
+ Enable the module that staticaly override certain
+ responses
+ </flag>
+ <flag name="rrl">
+ Enable the response rate limiting module
+ </flag>
+ <flag name="stats">
+ Enable the server statistics module
+ </flag>
+ <flag name="synthrecord">
+ Enable the automatic forward/reverse records module
+ </flag>
+ <flag name="utils">
+ Install Knot utilities, such as kdig, kzonecheck, ...
+ </flag>
+ <flag name="whoami">
+ Enable the whoami response module
</flag>
</use>
</pkgmetadata>