summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-06-29 09:16:21 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-06-29 09:16:21 +0000
commit4543e3f03bb4721d713d434b4c1646b925f1e8bb (patch)
tree68210c834ea33618da09035d4ae2ee4c48ecadb5
parent2022-06-29 08:46:39 UTC (diff)
parentapp-editors/nano: Warn in pkg_postrm about updating EDITOR (diff)
downloadgentoo-4543e3f03bb4721d713d434b4c1646b925f1e8bb.tar.gz
gentoo-4543e3f03bb4721d713d434b4c1646b925f1e8bb.tar.bz2
gentoo-4543e3f03bb4721d713d434b4c1646b925f1e8bb.zip
Merge updates from master
-rw-r--r--app-editors/nano/nano-6.3.ebuild9
-rw-r--r--app-text/paperwork/paperwork-2.1.0.ebuild7
-rw-r--r--app-text/paperwork/paperwork-2.1.1.ebuild5
-rw-r--r--dev-python/matplotlib/matplotlib-3.5.1-r2.ebuild (renamed from dev-python/matplotlib/matplotlib-3.5.1-r1.ebuild)3
-rw-r--r--dev-python/matplotlib/matplotlib-3.5.2-r3.ebuild (renamed from dev-python/matplotlib/matplotlib-3.5.2-r2.ebuild)3
-rw-r--r--mail-mta/exim/exim-4.96-r1.ebuild (renamed from mail-mta/exim/exim-4.96.ebuild)2
-rw-r--r--sys-process/htop/Manifest1
-rw-r--r--sys-process/htop/htop-3.2.1-r1.ebuild105
-rw-r--r--sys-process/htop/htop-9999.ebuild42
-rw-r--r--x11-wm/matwm2/matwm2-0.1.2_pre3-r2.ebuild (renamed from x11-wm/matwm2/matwm2-0.1.2_pre3-r1.ebuild)35
-rw-r--r--x11-wm/selectwm/files/selectwm-0.4.1-autotools.patch26
-rw-r--r--x11-wm/selectwm/files/selectwm-0.4.1-nostrip.patch15
-rw-r--r--x11-wm/selectwm/selectwm-0.4.1-r2.ebuild (renamed from x11-wm/selectwm/selectwm-0.4.1-r1.ebuild)25
13 files changed, 204 insertions, 74 deletions
diff --git a/app-editors/nano/nano-6.3.ebuild b/app-editors/nano/nano-6.3.ebuild
index 9bd57c68b191..ff0fcf25cd44 100644
--- a/app-editors/nano/nano-6.3.ebuild
+++ b/app-editors/nano/nano-6.3.ebuild
@@ -91,3 +91,12 @@ src_install() {
use split-usr && dosym ../../bin/nano /usr/bin/nano
}
+
+pkg_postrm() {
+ local e
+ e=$(unset EDITOR; . "${EROOT}"/etc/profile &>/dev/null; echo "${EDITOR}")
+ if [[ ${e##*/} == nano ]]; then
+ ewarn "The EDITOR variable is still set to ${e}."
+ ewarn "You can update it with \"eselect editor\"."
+ fi
+}
diff --git a/app-text/paperwork/paperwork-2.1.0.ebuild b/app-text/paperwork/paperwork-2.1.0.ebuild
index 4167c0385cff..344a70f29743 100644
--- a/app-text/paperwork/paperwork-2.1.0.ebuild
+++ b/app-text/paperwork/paperwork-2.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -34,9 +34,10 @@ python_install_all() {
distutils-r1_python_install_all
# This queries tesseract languages and will fail sandbox with
- # USE=opencl, bugs #793446 #830012
- addpredict /dev/nvidiactl
+ # USE=opencl, bugs #793446 #830012 #852134
+ addpredict /dev/dri/renderD128
addpredict /dev/kfd
+ addpredict /dev/nvidiactl
PYTHONPATH="src" "${EPYTHON}" src/paperwork_gtk/main.py install \
--icon_base_dir="${ED}"/usr/share/icons \
diff --git a/app-text/paperwork/paperwork-2.1.1.ebuild b/app-text/paperwork/paperwork-2.1.1.ebuild
index 27169a2d1a1f..5fb6e834f6a9 100644
--- a/app-text/paperwork/paperwork-2.1.1.ebuild
+++ b/app-text/paperwork/paperwork-2.1.1.ebuild
@@ -33,9 +33,10 @@ python_install_all() {
distutils-r1_python_install_all
# This queries tesseract languages and will fail sandbox with
- # USE=opencl, bugs #793446 #830012
- addpredict /dev/nvidiactl
+ # USE=opencl, bugs #793446 #830012 #852134
+ addpredict /dev/dri/renderD128
addpredict /dev/kfd
+ addpredict /dev/nvidiactl
PYTHONPATH="src" "${EPYTHON}" src/paperwork_gtk/main.py install \
--icon_base_dir="${ED}"/usr/share/icons \
diff --git a/dev-python/matplotlib/matplotlib-3.5.1-r1.ebuild b/dev-python/matplotlib/matplotlib-3.5.1-r2.ebuild
index 075c1245f88c..ce449939b282 100644
--- a/dev-python/matplotlib/matplotlib-3.5.1-r1.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.5.1-r2.ebuild
@@ -152,6 +152,9 @@ python_prepare_all() {
# from six import *
# EOF
+ # Affects installed _version.py, bug #854600
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
local PATCHES=(
"${FILESDIR}"/matplotlib-3.3.3-disable-lto.patch
"${FILESDIR}"/matplotlib-3.5.0-test.patch
diff --git a/dev-python/matplotlib/matplotlib-3.5.2-r2.ebuild b/dev-python/matplotlib/matplotlib-3.5.2-r3.ebuild
index 9f9c78422ea4..eb371d6af08c 100644
--- a/dev-python/matplotlib/matplotlib-3.5.2-r2.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.5.2-r3.ebuild
@@ -143,6 +143,9 @@ python_prepare_all() {
# from six import *
# EOF
+ # Affects installed _version.py, bug #854600
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
local PATCHES=(
"${FILESDIR}"/matplotlib-3.3.3-disable-lto.patch
"${FILESDIR}"/matplotlib-3.5.2-test.patch
diff --git a/mail-mta/exim/exim-4.96.ebuild b/mail-mta/exim/exim-4.96-r1.ebuild
index 58282c3fd043..1d04cbc97f35 100644
--- a/mail-mta/exim/exim-4.96.ebuild
+++ b/mail-mta/exim/exim-4.96-r1.ebuild
@@ -48,7 +48,7 @@ LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-solaris"
COMMON_DEPEND=">=sys-apps/sed-4.0.5
- dev-libs/libpcre:=
+ dev-libs/libpcre2:=
tdb? ( sys-libs/tdb:= )
!tdb? ( berkdb? ( >=sys-libs/db-3.2:= <sys-libs/db-6:= ) )
!tdb? ( !berkdb? ( sys-libs/gdbm:= ) )
diff --git a/sys-process/htop/Manifest b/sys-process/htop/Manifest
index bf26ca15fa8c..a84a0344d1f4 100644
--- a/sys-process/htop/Manifest
+++ b/sys-process/htop/Manifest
@@ -1,3 +1,4 @@
DIST htop-3.1.2.tar.gz 387656 BLAKE2B a9682b6f3475fbae6ab7fd57330271190ec32267c5a8f2aac845cd18c566eaa9beed642c1e67fbc9606f120df600c27ed2ef0480a29ef304875a99898c1f10e4 SHA512 7e08b820042e480ca61137ff24b468804b49b95c1bbedaf82029dd79d29c2c541c5211284ec075692203788bbb868a9d4326ffd24c68419e22eec13ae5012700
DIST htop-3.2.0.tar.gz 393712 BLAKE2B fff50fce1dd58d5738ca4a75a8b4078aa34e9544798c81bb18a2674823ab13a93ecec8c00d034704ecaab6a871efa2b021550dc1f0a03aa86f638c28e84f769e SHA512 174eaa7333fa60e40f67148560c53125e7aaf46a48e7f3ecfa2daa68553c94b3d076d03320afd479dcee07e739c0ff286a81b67cbc994782c33e798d3ed4605c
DIST htop-3.2.1.tar.gz 397632 BLAKE2B 301bc421b3ff8136a70603c523dd719d38703288114712a6e178c1a348b1bc9b9d578cdf3cf8fe99a9bcd2d5721cd2a10caeeeb4614b24c4f20a8e103c37d236 SHA512 d7b76e28ee870ac572ba1d9606dec6f9475346a00e599ca15838017c97683f1fc1be40417b9c1e76128cacc8a60ff9ba88c6b237be1835d309f98329b25644fc
+DIST htop-3.2.1.tar.xz 406048 BLAKE2B 7addefca7de8f0867220e6415f4585f7e6ecf655d6245e4a8e120552ac738544fde1c2d8e24ce1139209caad23994316e8be9611f6ed0253d60547158d17ff24 SHA512 f412c10ebdec4fb026fb93a79a9b0b84612ad5a0d28e37f06713e6c895f70e92cbd09a8737d04f3d51102295d7a419eb2c3ec3907b96f553fda8ff3d1a2142b6
diff --git a/sys-process/htop/htop-3.2.1-r1.ebuild b/sys-process/htop/htop-3.2.1-r1.ebuild
new file mode 100644
index 000000000000..76b7ce3cb327
--- /dev/null
+++ b/sys-process/htop/htop-3.2.1-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit linux-info optfeature python-any-r1 xdg
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="https://htop.dev/ https://github.com/htop-dev/htop"
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/htop-dev/htop.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/htop-dev/htop/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+fi
+
+S="${WORKDIR}/${P/_}"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+IUSE="caps debug delayacct hwloc lm-sensors llvm-libunwind openvz unicode unwind vserver"
+
+RDEPEND="
+ sys-libs/ncurses:=[unicode(+)?]
+ hwloc? ( sys-apps/hwloc:= )
+ unwind? (
+ !llvm-libunwind? ( sys-libs/libunwind:= )
+ llvm-libunwind? ( sys-libs/llvm-libunwind:= )
+ )
+ kernel_linux? (
+ caps? ( sys-libs/libcap )
+ delayacct? ( dev-libs/libnl:3 )
+ lm-sensors? ( sys-apps/lm-sensors )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog README )
+
+CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ if [[ ${CBUILD} != ${CHOST} ]] ; then
+ # bug #328971
+ export ac_cv_file__proc_{meminfo,stat}=yes
+ fi
+
+ local myeconfargs=(
+ --enable-unicode
+ $(use_enable debug)
+ $(use_enable hwloc)
+ $(use_enable !hwloc affinity)
+ $(use_enable openvz)
+ $(use_enable unicode)
+ $(use_enable unwind)
+ $(use_enable vserver)
+ )
+
+ if use kernel_linux ; then
+ myeconfargs+=(
+ $(use_enable caps capabilities)
+ $(use_enable delayacct)
+ $(use_enable lm-sensors sensors)
+ )
+ else
+ if use kernel_Darwin ; then
+ # Upstream default to checking but --enable-affinity
+ # overrides this. Simplest to just disable on Darwin
+ # given it works on BSD anyway.
+ myeconfargs+=( --disable-affinity )
+ fi
+
+ myeconfargs+=(
+ --disable-capabilities
+ --disable-delayacct
+ --disable-sensors
+ )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "Viewing processes accessing certain files" sys-process/lsof
+}
diff --git a/sys-process/htop/htop-9999.ebuild b/sys-process/htop/htop-9999.ebuild
index f8aa53177141..76b7ce3cb327 100644
--- a/sys-process/htop/htop-9999.ebuild
+++ b/sys-process/htop/htop-9999.ebuild
@@ -3,25 +3,26 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
-inherit autotools fcaps linux-info python-any-r1 xdg-utils
+inherit linux-info optfeature python-any-r1 xdg
DESCRIPTION="interactive process viewer"
HOMEPAGE="https://htop.dev/ https://github.com/htop-dev/htop"
if [[ ${PV} == *9999 ]] ; then
- inherit git-r3
EGIT_REPO_URI="https://github.com/htop-dev/htop.git"
+ inherit autotools git-r3
else
- SRC_URI="https://github.com/htop-dev/${PN}/archive/${PV/_}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/htop-dev/htop/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
fi
+S="${WORKDIR}/${P/_}"
+
LICENSE="BSD GPL-2+"
SLOT="0"
IUSE="caps debug delayacct hwloc lm-sensors llvm-libunwind openvz unicode unwind vserver"
-BDEPEND="virtual/pkgconfig"
RDEPEND="
sys-libs/ncurses:=[unicode(+)?]
hwloc? ( sys-apps/hwloc:= )
@@ -35,21 +36,15 @@ RDEPEND="
lm-sensors? ( sys-apps/lm-sensors )
)
"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig"
DOCS=( ChangeLog README )
CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
-S="${WORKDIR}/${P/_}"
-
pkg_setup() {
- if ! has_version sys-process/lsof ; then
- ewarn "To use lsof features in htop (what processes are accessing"
- ewarn "what files), you must have sys-process/lsof installed."
- fi
-
python-any-r1_pkg_setup
linux-info_pkg_setup
}
@@ -57,12 +52,15 @@ pkg_setup() {
src_prepare() {
default
- eautoreconf
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
}
src_configure() {
if [[ ${CBUILD} != ${CHOST} ]] ; then
- export ac_cv_file__proc_{meminfo,stat}=yes #328971
+ # bug #328971
+ export ac_cv_file__proc_{meminfo,stat}=yes
fi
local myeconfargs=(
@@ -97,17 +95,11 @@ src_configure() {
)
fi
- econf ${myeconfargs[@]}
+ econf "${myeconfargs[@]}"
}
pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-
- fcaps cap_sys_ptrace /usr/bin/${PN}
-}
+ xdg_pkg_postinst
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
+ optfeature "Viewing processes accessing certain files" sys-process/lsof
}
diff --git a/x11-wm/matwm2/matwm2-0.1.2_pre3-r1.ebuild b/x11-wm/matwm2/matwm2-0.1.2_pre3-r2.ebuild
index c6e017074c9d..468d8e602220 100644
--- a/x11-wm/matwm2/matwm2-0.1.2_pre3-r1.ebuild
+++ b/x11-wm/matwm2/matwm2-0.1.2_pre3-r2.ebuild
@@ -1,33 +1,31 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit toolchain-funcs
+EAPI=8
+
+inherit edo toolchain-funcs
MY_PV="${PV//_/}"
DESCRIPTION="Simple EWMH compatible window manager with titlebars and frames"
HOMEPAGE="https://github.com/segin/matwm2"
SRC_URI="https://github.com/segin/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}/${PN}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug xft xinerama"
-S="${WORKDIR}/${PN}-${MY_PV}/${PN}"
RDEPEND="
x11-libs/libXext
x11-libs/libX11
xft? ( x11-libs/libXft )
- xinerama? ( x11-libs/libXinerama )
-"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-PATCHES=( "${FILESDIR}/${P}-destdir-fix.patch" )
+PATCHES=( "${FILESDIR}"/${P}-destdir-fix.patch )
src_prepare() {
default
@@ -42,24 +40,25 @@ src_configure() {
--prefix="${EPREFIX}/usr"
--mandir="${EPREFIX}/usr/share/man"
--cc="$(tc-getCC)"
- $(usex debug "--enable-debug" "")
- $(usex xft "" "--disable-xft")
- $(usex xinerama "" "--disable-xinerama")
+ $(usev debug --enable-debug)
+ $(usev !xft --disable-xft)
+ $(usev !xinerama --disable-xinerama)
)
- ./configure "${myconfigureargs[@]}" || die
+ edo ./configure "${myconfigureargs[@]}"
}
src_install() {
default
- docompress -x "${EPREFIX}/usr/share/doc/${PF}"/default_matwmrc
+ docompress -x /usr/share/doc/${PF}/default_matwmrc
dodoc default_matwmrc
insinto /usr/share/xsessions
doins "${FILESDIR}"/${PN}.desktop
- echo ${PN} > "${T}"/${PN} || die
exeinto /etc/X11/Sessions
- doexe "${T}"/${PN}
+ newexe - matwm2 <<- _EOF_
+ matwm2
+ _EOF_
}
diff --git a/x11-wm/selectwm/files/selectwm-0.4.1-autotools.patch b/x11-wm/selectwm/files/selectwm-0.4.1-autotools.patch
new file mode 100644
index 000000000000..11dbcd3b94f0
--- /dev/null
+++ b/x11-wm/selectwm/files/selectwm-0.4.1-autotools.patch
@@ -0,0 +1,26 @@
+* Respect CFLAGS, don't strip binaries
+* Don't check for configure.in (EAPI 8)
+
+http://bugs.gentoo.org/252124
+
+--- a/configure.in
++++ b/configure.in
+@@ -1,6 +1,6 @@
+ dnl Process this file with autoconf to produce a configure script.
+
+-AC_INIT(configure.in)
++AC_INIT
+ AM_INIT_AUTOMAKE(selectwm, 0.4.1)
+ AM_CONFIG_HEADER(config.h)
+ AM_MAINTAINER_MODE
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -10,5 +10,6 @@
+ modify.c modify.h \
+ misc.h define.h
+
+-LIBS = @GTK_LIBS@
+-AM_CFLAGS = -s -O2 -Wall @GTK_CFLAGS@ -DLOCALEDIR=\"$(datadir)/locale\"
++selectwm_LDADD = @GTK_LIBS@
++selectwm_CFLAGS = @GTK_CFLAGS@
++selectwm_CPPFLAGS = -DLOCALEDIR=\"$(datadir)/locale\"
diff --git a/x11-wm/selectwm/files/selectwm-0.4.1-nostrip.patch b/x11-wm/selectwm/files/selectwm-0.4.1-nostrip.patch
deleted file mode 100644
index 4287ca2d2cbb..000000000000
--- a/x11-wm/selectwm/files/selectwm-0.4.1-nostrip.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Respect CFLAGS, don't strip binaries
-
-http://bugs.gentoo.org/show_bug.cgi?id=252124
-
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -10,5 +10,6 @@
- modify.c modify.h \
- misc.h define.h
-
--LIBS = @GTK_LIBS@
--AM_CFLAGS = -s -O2 -Wall @GTK_CFLAGS@ -DLOCALEDIR=\"$(datadir)/locale\"
-+selectwm_LDADD = @GTK_LIBS@
-+selectwm_CFLAGS = @GTK_CFLAGS@
-+selectwm_CPPFLAGS = -DLOCALEDIR=\"$(datadir)/locale\"
diff --git a/x11-wm/selectwm/selectwm-0.4.1-r1.ebuild b/x11-wm/selectwm/selectwm-0.4.1-r2.ebuild
index e06d7d38dc00..43301bdf930c 100644
--- a/x11-wm/selectwm/selectwm-0.4.1-r1.ebuild
+++ b/x11-wm/selectwm/selectwm-0.4.1-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit autotools
DESCRIPTION="window manager selector tool"
@@ -13,17 +14,16 @@ SLOT="2"
KEYWORDS="amd64 ppc sparc x86"
IUSE="nls"
-DOCS=( AUTHORS README sample.xinitrc )
-
-RDEPEND="x11-libs/gtk+:2
+RDEPEND="
+ x11-libs/gtk+:2
dev-libs/glib:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}/${P}-enable-deprecated-gtk.patch"
- "${FILESDIR}/${P}-glibc-2.10.patch"
- "${FILESDIR}/${P}-nostrip.patch"
+ "${FILESDIR}"/${P}-enable-deprecated-gtk.patch
+ "${FILESDIR}"/${P}-glibc-2.10.patch
+ "${FILESDIR}"/${P}-autotools.patch
)
src_prepare() {
@@ -36,3 +36,8 @@ src_configure() {
--program-suffix=2 \
$(use_enable nls)
}
+
+src_install() {
+ default
+ dodoc sample.xinitrc
+}