summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2018-10-31 17:57:56 -0400
committerRichard Freeman <rich0@gentoo.org>2018-10-31 17:59:09 -0400
commit458340fa0b8bedd8881716a79e2ae1a908ff55b8 (patch)
tree4aa51d03c1289537de63ac6674273de66f5cae9e
parentsys-apps/util-linux: Support multiple python versions in 9999 (diff)
downloadgentoo-458340fa0b8bedd8881716a79e2ae1a908ff55b8.tar.gz
gentoo-458340fa0b8bedd8881716a79e2ae1a908ff55b8.tar.bz2
gentoo-458340fa0b8bedd8881716a79e2ae1a908ff55b8.zip
media-radio/js8call: bump
Signed-off-by: Richard Freeman <rich0@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
-rw-r--r--media-radio/js8call/Manifest1
-rw-r--r--media-radio/js8call/files/0.8.0-makefile-removesymlink.patch15
-rw-r--r--media-radio/js8call/js8call-0.8.0.ebuild54
3 files changed, 70 insertions, 0 deletions
diff --git a/media-radio/js8call/Manifest b/media-radio/js8call/Manifest
index 6b0f72f92f0c..a8fffe110304 100644
--- a/media-radio/js8call/Manifest
+++ b/media-radio/js8call/Manifest
@@ -1 +1,2 @@
DIST js8call-0.7.5.tar.bz2 41230267 BLAKE2B 0d49f3d65ce7df501bdfee597ba8a7670dfb80217fec2f5d66859381cceaaf759e940c99b015246d58abe8549114ffe9ba3d67cebdee5122284fc2a221de02bf SHA512 e4e35a086a1443def71fe1bd9d057c3ec38f261b68818c841a90ef858d6c480b2cbb5f721ac26e1651836326b12059b2a01370a2c7c63925a40971d343e9f8e8
+DIST js8call-0.8.0.tar.bz2 41226056 BLAKE2B 68894f44c36bc1ede57e9596545a9dd1c3ae53ce0a24e3ea7086f5696ce4deeda2ef8e716ac2e02bfd71c69266a7e867898bfddc2616284a564c753af61e27a6 SHA512 5beb98c7f1d805e3c4dd06a584a5b5d0efc8336da527b6d3d4f53b480c366b8c9e4f902c8c6139bbb379d875538382d1c5a4549dd2a97f408656c7da6fec5796
diff --git a/media-radio/js8call/files/0.8.0-makefile-removesymlink.patch b/media-radio/js8call/files/0.8.0-makefile-removesymlink.patch
new file mode 100644
index 000000000000..0bb3349cbdfd
--- /dev/null
+++ b/media-radio/js8call/files/0.8.0-makefile-removesymlink.patch
@@ -0,0 +1,15 @@
+--- a/CMakeLists.txt 2018-10-31 17:52:18.252760284 -0400
++++ a/CMakeLists.txt 2018-10-31 17:52:54.507461091 -0400
+@@ -1272,12 +1272,6 @@
+ #COMPONENT runtime
+ )
+
+- execute_process(COMMAND ln -s /opt/js8call/bin/js8call ljs8call)
+-
+- install(FILES
+- ${CMAKE_BINARY_DIR}/ljs8call DESTINATION /usr/bin/ RENAME js8call
+- #COMPONENT runtime
+- )
+ endif (NOT WIN32 AND NOT APPLE)
+
+
diff --git a/media-radio/js8call/js8call-0.8.0.ebuild b/media-radio/js8call/js8call-0.8.0.ebuild
new file mode 100644
index 000000000000..9b2683cd0068
--- /dev/null
+++ b/media-radio/js8call/js8call-0.8.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils vcs-snapshot
+
+MY_P=${P/_/-}
+
+DESCRIPTION="Weak signal ham radio communication"
+HOMEPAGE="https://groups.io/g/js8call"
+SRC_URI="https://bitbucket.org/widefido/wsjtx/get/v${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+PATCHES="${FILESDIR}/${PV}-makefile-removesymlink.patch"
+
+RDEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtserialport:5
+ dev-qt/qtprintsupport:5
+ virtual/libusb:1
+ media-libs/portaudio
+ sci-libs/fftw:3.0[threads,fortran]
+ virtual/fortran
+ app-text/asciidoc
+ media-libs/hamlib
+ doc? ( dev-ruby/asciidoctor )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWSJT_GENERATE_DOCS="$(usex doc)"
+ -DWSJT_DOC_DESTINATION="/doc/${PF}"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ rm "${D}"/usr/bin/rigctl{,d}-local || die
+ rm "${D}"/usr/share/doc/JS8Call -R || die
+
+}