summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-12-04 15:16:25 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-12-04 15:35:46 +0100
commit4623a4672451aee1c624a33a0d71e42af93d6ddc (patch)
treee6e4f8d2d2e8d32b64ac507d3eb7ed59ac9bf708
parentdev-python/pathspec: bump to 0.8.1 (diff)
downloadgentoo-4623a4672451aee1c624a33a0d71e42af93d6ddc.tar.gz
gentoo-4623a4672451aee1c624a33a0d71e42af93d6ddc.tar.bz2
gentoo-4623a4672451aee1c624a33a0d71e42af93d6ddc.zip
dev-lua/luajson: move slotted lua version to r100
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/luajson/luajson-1.3.4-r100.ebuild37
-rw-r--r--profiles/package.mask2
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-lua/luajson/luajson-1.3.4-r100.ebuild b/dev-lua/luajson/luajson-1.3.4-r100.ebuild
new file mode 100644
index 000000000000..f06cd069d628
--- /dev/null
+++ b/dev-lua/luajson/luajson-1.3.4-r100.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+
+inherit lua
+
+DESCRIPTION="JSON Parser/Constructor for Lua"
+HOMEPAGE="https://www.eharning.us/wiki/luajson/"
+SRC_URI="https://github.com/harningt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="dev-lua/lpeg[${LUA_USEDEP}]"
+
+# Require lunitx, which is not in the tree yet
+RESTRICT="test"
+
+DOCS=( README.md docs/ReleaseNotes-${PV}.txt docs/LuaJSON.txt )
+
+# nothing to compile
+src_compile() { :; }
+
+lua_src_install() {
+ emake DESTDIR="${ED}" INSTALL_LMOD="$(lua_get_lmod_dir)" install
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+ einstalldocs
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index 7684461a31b3..6727b95079aa 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -533,7 +533,7 @@ gnome-base/orbit
=dev-lua/luaexpat-1.3.3-r101
>=dev-lua/luafilesystem-1.8.0-r100
>=dev-lua/lualdap-1.2.5-r100
->=dev-lua/luajson-1.3.4
+>=dev-lua/luajson-1.3.4-r100
>=dev-lua/luaossl-20200709-r100
>=dev-lua/luaposix-35.0-r100
>=dev-lua/luarocks-3.4.0-r100