summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-25 08:32:31 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-25 10:10:28 +0200
commit4959bb3e5ff6d51b1bb2ea89482086239eabfd5d (patch)
treec18de17c56d9098e5d0ecdf13cad94c4670aeb18
parentadd pypy support (diff)
downloadgentoo-4959bb3e5ff6d51b1bb2ea89482086239eabfd5d.tar.gz
gentoo-4959bb3e5ff6d51b1bb2ea89482086239eabfd5d.tar.bz2
gentoo-4959bb3e5ff6d51b1bb2ea89482086239eabfd5d.zip
dev-python/virtualenv: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/virtualenv/Manifest1
-rw-r--r--dev-python/virtualenv/virtualenv-13.1.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/virtualenv/Manifest b/dev-python/virtualenv/Manifest
index 8bda4e9c8d66..0141f87128f8 100644
--- a/dev-python/virtualenv/Manifest
+++ b/dev-python/virtualenv/Manifest
@@ -1,3 +1,4 @@
DIST virtualenv-12.0.5.tar.gz 1805752 SHA256 ebb7a01e7fb7a9b3586692f623da4e13d50351f3733d8bbc83aaecd654c5f955 SHA512 b5fd46aa8a34f42d3db46c48ac751e5c22d8fcddc83edd4230838549d549ddfd47e56ef784677d8d17471ed2bbde168e3db6d48ca6a9c2d2ae757caac5768a10 WHIRLPOOL 6a0e568a9954473c6ab2b4f4d814ddd42a4c92d6543b3ec005bbd42d9c25a775dc421c5e8491269fc77fba6c37e8dea9773c644eaa44128b9f2bf7f0db6bdea0
DIST virtualenv-13.1.0.tar.gz 1705046 SHA256 504e705d73251a7f248e0e88d9054a1b4baf5f276a237f8de0830fd0e1661d63 SHA512 9361b4a44e57c9e2d2138092b0f0b32f7d0209f383f5b0c5f001b2a4e5a886acdacee0317551f6e4722b7fc669604debdcaa50864285ff3326c34a2b9ecb13f4 WHIRLPOOL dc6ff2b2fca481686f56b7f719a417c6b8bd2f115284aa7cc2d6a3541434db107638be97aca51407f9bec819254972606bf57ec233909e86bbd9f7673e0e5936
DIST virtualenv-13.1.1.tar.gz 1704689 SHA256 8ccd344a7410aca75fd95a342e7e8f941e780d117b259d80ac6220d71bdb8c22 SHA512 dc8bd7dd34961c7e85cb3b4f31e160dfc15403e8c91c59fa7f92b0271bc4c09181c2db803fe6ecb4234bfd5f0b60bb8cd64f0a195d8dcfebc7bb34bd4bc7487f WHIRLPOOL 4132729160683c851952cd65c0c52a4f7f885fc26ff763e41cc5f313d1d50fb2a561668121d273a5455cc275561feb89d23fc28f285c37db268175c2b775cf00
+DIST virtualenv-13.1.2.tar.gz 1704701 SHA256 438a9933dac2e6ef2e4270fe82435f9c29f933f05e2c5840a7b45e342b6292f8 SHA512 e58f0b1d46174d61b0ef6703020806208f34291c5490fabf29d3b82a03ba89a7caeb377aac44549f6c0ffe2e445786e16dcd67593b7b8d3b1fae0d9e8c8ef124 WHIRLPOOL 03fe0181ebb2d4becb357a740cc3f743526a087e03c03f5e20abac6a54a2701865c89f9f6023ae996d3ca032b08d28e1048747dc8ea1740316f330180f0f5161
diff --git a/dev-python/virtualenv/virtualenv-13.1.2.ebuild b/dev-python/virtualenv/virtualenv-13.1.2.ebuild
new file mode 100644
index 000000000000..3413424fbf1e
--- /dev/null
+++ b/dev-python/virtualenv/virtualenv-13.1.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtual Python Environment builder"
+HOMEPAGE="http://www.virtualenv.org/ https://pypi.python.org/pypi/virtualenv https://github.com/pypa/virtualenv/"
+SRC_URI="https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/pip-7.1.2[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( docs/index.rst docs/changes.rst )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.2-no-versioned-script.patch
+ "${FILESDIR}"/${PN}-12.1.1-skip-broken-test.patch
+)
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${S}"/docs/_build/html/. )
+ distutils-r1_python_install_all
+}