summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@protonmail.com>2020-10-08 16:29:16 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-11-11 09:50:09 +0200
commit4a0994f1ddc0cd923e2dbd3e3437a6ce7fc44c62 (patch)
tree53b74263001f5d6f7e5449d0cb5491511f8ea860
parentsys-libs/librtas: drop old (diff)
downloadgentoo-4a0994f1ddc0cd923e2dbd3e3437a6ce7fc44c62.tar.gz
gentoo-4a0994f1ddc0cd923e2dbd3e3437a6ce7fc44c62.tar.bz2
gentoo-4a0994f1ddc0cd923e2dbd3e3437a6ce7fc44c62.zip
net-misc/gallery-dl: new package; 1.15.2 and 9999
Download image galleries and collections from several image hosting sites. Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Maciej Barć <xgqt@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/17850 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.15.2.ebuild46
-rw-r--r--net-misc/gallery-dl/gallery-dl-9999.ebuild46
-rw-r--r--net-misc/gallery-dl/metadata.xml19
4 files changed, 112 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
new file mode 100644
index 000000000000..578868670e1b
--- /dev/null
+++ b/net-misc/gallery-dl/Manifest
@@ -0,0 +1 @@
+DIST gallery-dl-1.15.2.tar.gz 323739 BLAKE2B 99a06331bd7dc6ec951749129ad0ac797d9ce2d9f98e75a29198fd47d0481c43b96922ea08149abfe990e8994a19b3170853618de9b51465264d100dba777f32 SHA512 7f31c0485d9de6eaf76e7b0772e66049f9aa8fd7d77d3ef6fd2803d7ec7dddbf3419051c9d8b3984eb86a8fbbf9a168cf8ec69a55082a38e2ca23cfc3574b1f4
diff --git a/net-misc/gallery-dl/gallery-dl-1.15.2.ebuild b/net-misc/gallery-dl/gallery-dl-1.15.2.ebuild
new file mode 100644
index 000000000000..1fc6f3ea8b7a
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.15.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7,8})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+# tests require network access
+RESTRICT="test"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/requests-2.11.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests setup.py
+
+src_compile() {
+ emake data/completion/gallery-dl
+ emake data/completion/_gallery-dl
+ emake man
+ distutils-r1_src_compile
+}
+
+pkg_postinst() {
+ elog "To get additional features, some optional runtime dependencies"
+ elog "may be installed:"
+ elog ""
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/youtube-dl
+}
diff --git a/net-misc/gallery-dl/gallery-dl-9999.ebuild b/net-misc/gallery-dl/gallery-dl-9999.ebuild
new file mode 100644
index 000000000000..1fc6f3ea8b7a
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7,8})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+# tests require network access
+RESTRICT="test"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/requests-2.11.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests setup.py
+
+src_compile() {
+ emake data/completion/gallery-dl
+ emake data/completion/_gallery-dl
+ emake man
+ distutils-r1_src_compile
+}
+
+pkg_postinst() {
+ elog "To get additional features, some optional runtime dependencies"
+ elog "may be installed:"
+ elog ""
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/youtube-dl
+}
diff --git a/net-misc/gallery-dl/metadata.xml b/net-misc/gallery-dl/metadata.xml
new file mode 100644
index 000000000000..955798794c34
--- /dev/null
+++ b/net-misc/gallery-dl/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@protonmail.com</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mikf/gallery-dl</remote-id>
+ </upstream>
+ <longdescription>
+ gallery-dl is a command-line program to download image-galleries and -collections from several image hosting sites.
+ It is a cross-platform tool with many configuration options and powerful filenaming capabilities.
+ </longdescription>
+</pkgmetadata>