summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-09-18 23:11:26 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-09-18 23:12:21 +0100
commit4af6607f04424cd164e0cd175429c15c4076a4e1 (patch)
tree34c0389d55f4340b2fb0a3d83cb9b3296b7a5ecc
parentapp-pda/libusbmuxd: restore v1.0.9 (diff)
downloadgentoo-4af6607f04424cd164e0cd175429c15c4076a4e1.tar.gz
gentoo-4af6607f04424cd164e0cd175429c15c4076a4e1.tar.bz2
gentoo-4af6607f04424cd164e0cd175429c15c4076a4e1.zip
dev-libs/capstone:guard tests building behind USE=test, bug #663006
Reported-by: Michał Górny Closes: https://bugs.gentoo.org/663006 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-libs/capstone/capstone-4.0.1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-libs/capstone/capstone-4.0.1.ebuild b/dev-libs/capstone/capstone-4.0.1.ebuild
index e4931c690d0d..77b9b960a583 100644
--- a/dev-libs/capstone/capstone-4.0.1.ebuild
+++ b/dev-libs/capstone/capstone-4.0.1.ebuild
@@ -16,7 +16,9 @@ LICENSE="BSD"
SLOT="0/4" # libcapstone.so.4
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="python"
+RESTRICT="!test? ( test )"
+
+IUSE="python test"
RDEPEND="python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}
python? ( dev-python/setuptools[${PYTHON_USEDEP}] )
@@ -63,6 +65,11 @@ src_configure() {
EOF
} >> config.mk || die
+ if ! use test; then
+ # Don't build tests if not requested: bug #663006
+ sed -i tests/Makefile -e 's@all: $(BINARY)@all:@' || die
+ fi
+
wrap_python ${FUNCNAME}
}