summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <jchelmertt3@gmail.com>2020-05-01 23:40:11 -0500
committerJoonas Niilola <juippis@gentoo.org>2020-05-05 14:50:46 +0300
commit4c4d3924825515bc717d967d54023996cfe1a5c0 (patch)
tree3c3140cbf73d5f194d486e9ae7ebe7b46623f691
parentdev-python/expects: Add python3_8 (diff)
downloadgentoo-4c4d3924825515bc717d967d54023996cfe1a5c0.tar.gz
gentoo-4c4d3924825515bc717d967d54023996cfe1a5c0.tar.bz2
gentoo-4c4d3924825515bc717d967d54023996cfe1a5c0.zip
dev-python/mamba: Add version 0.11.0 for python3_8
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: John Helmert III <jchelmertt3@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/15606 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-python/mamba/Manifest1
-rw-r--r--dev-python/mamba/mamba-0.11.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/mamba/Manifest b/dev-python/mamba/Manifest
index 0cf2cb7b0b6d..b785cfdad69d 100644
--- a/dev-python/mamba/Manifest
+++ b/dev-python/mamba/Manifest
@@ -1 +1,2 @@
+DIST mamba-0.11.0.tar.gz 33598 BLAKE2B c52ccbf1fca5dd6f27b4515fa6db65a8a28537e705d734bb126bdc9a4bd4afb5119aabc212f871508f91c21679e7e2215d0c7f13adfaabdf6ea49c942b7b3d64 SHA512 2faf941700800ba0432bfd170d6ff2278e5fc3ba4e85f486d33ed5f07e148284d400e2b02ac0f957a27d47b705fc52b042dc4311bdd175907e307e4dbfa95246
DIST mamba-0.8.6.gh.tar.gz 15428 BLAKE2B d1c13d2e7b5bd4b18c497e1b1df21c19dfdc19b235c796e8277e96a95b787df56466661b995bcd424e550a2f139e7ff8b5d75e72cabde3af1593edb36321f9f5 SHA512 1ac59c7df23ec5d2abe5123756c438c282be668f615a8737f35478ab314cde8ffde2b02ef78ead1946b9c467362b825f73e0ba7f441ab44a1fd116db9b7f2750
diff --git a/dev-python/mamba/mamba-0.11.0.ebuild b/dev-python/mamba/mamba-0.11.0.ebuild
new file mode 100644
index 000000000000..c0c67a7b7de3
--- /dev/null
+++ b/dev-python/mamba/mamba-0.11.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python test runner born under the banner of Behavior Driven Development"
+HOMEPAGE="https://nestorsalceda.github.io/mamba"
+SRC_URI="https://github.com/nestorsalceda/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ >=dev-python/doublex-expects-0.7.0_rc1[${PYTHON_USEDEP}]
+ >=dev-python/expects-0.8.0_rc2[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/clint-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-0.8.1[${PYTHON_USEDEP}]
+"
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}
+
+python_test() {
+ "${EPYTHON}" -m mamba.cli || die "Tests failed under ${EPYTHON}"
+}