summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-03-22 08:14:10 -0500
committerAaron Bauman <bman@gentoo.org>2018-03-26 16:19:45 -0400
commit4ca5affe87d9c4fca33efefc00f14bedfe3e29b1 (patch)
treeda079df86fd941e65d59c3935ec1e6d48fa2a8a4
parentapp-accessibility/epos: EAPI bump and patch updates (diff)
downloadgentoo-4ca5affe87d9c4fca33efefc00f14bedfe3e29b1.tar.gz
gentoo-4ca5affe87d9c4fca33efefc00f14bedfe3e29b1.tar.bz2
gentoo-4ca5affe87d9c4fca33efefc00f14bedfe3e29b1.zip
app-accessibility/flite: EAPI bump and patch updates
Bump EAPI to 6 and cleanup the patches a bit Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7588
-rw-r--r--app-accessibility/flite/files/flite-1.4-audio-interface.patch4
-rw-r--r--app-accessibility/flite/files/flite-1.4-ldflags.patch9
-rw-r--r--app-accessibility/flite/flite-1.4-r4.ebuild23
3 files changed, 20 insertions, 16 deletions
diff --git a/app-accessibility/flite/files/flite-1.4-audio-interface.patch b/app-accessibility/flite/files/flite-1.4-audio-interface.patch
index bc8d25b89bc3..d50428edd5af 100644
--- a/app-accessibility/flite/files/flite-1.4-audio-interface.patch
+++ b/app-accessibility/flite/files/flite-1.4-audio-interface.patch
@@ -1,5 +1,5 @@
---- configure.in 2009-08-15 06:46:38.000000000 +1000
-+++ configure.in 2011-08-30 00:53:26.000000000 +1000
+--- a/configure.in
++++ b/configure.in
@@ -304,7 +304,6 @@
[ --with-audio with specific audio support (none linux freebsd etc) ],
AUDIODRIVER=$with_audio )
diff --git a/app-accessibility/flite/files/flite-1.4-ldflags.patch b/app-accessibility/flite/files/flite-1.4-ldflags.patch
index f9295fb853b7..fd8f49059e76 100644
--- a/app-accessibility/flite/files/flite-1.4-ldflags.patch
+++ b/app-accessibility/flite/files/flite-1.4-ldflags.patch
@@ -1,6 +1,5 @@
-diff -Naur flite-1.4-release/config/common_make_rules flite-1.4-release.new/config/common_make_rules
---- flite-1.4-release/config/common_make_rules 2009-07-30 14:52:56.000000000 +0000
-+++ flite-1.4-release.new/config/common_make_rules 2011-03-26 20:22:59.000000000 +0000
+--- a/config/common_make_rules
++++ b/config/common_make_rules
@@ -68,7 +68,7 @@
FLITELIBS = $(BUILDDIR)/lib/libflite.a
@@ -19,8 +18,8 @@ diff -Naur flite-1.4-release/config/common_make_rules flite-1.4-release.new/conf
@ (cd $(LIBDIR) && ln -s `basename $@.${PROJECT_VERSION}` `basename $@.${PROJECT_SHLIB_VERSION}` )
@ (cd $(LIBDIR) && ln -s `basename $@.${PROJECT_SHLIB_VERSION}` `basename $@` )
@ rm -rf shared_os
---- flite-1.4-release/tools/Makefile~ 2009-08-22 20:19:01.000000000 +0100
-+++ flite-1.4-release.new/tools/Makefile 2013-01-20 20:06:34.259527220 +0000
+--- a/tools/Makefile
++++ b/tools/Makefile
@@ -62,9 +62,9 @@
LOCAL_CLEAN = $(BINDIR)/find_sts $(BINDIR)/flite_sort
diff --git a/app-accessibility/flite/flite-1.4-r4.ebuild b/app-accessibility/flite/flite-1.4-r4.ebuild
index 536b8f83eea6..54ce1000b6a8 100644
--- a/app-accessibility/flite/flite-1.4-r4.ebuild
+++ b/app-accessibility/flite/flite-1.4-r4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools eutils multilib-minimal
+EAPI=6
+inherit autotools multilib-minimal
DESCRIPTION="Flite text to speech engine"
HOMEPAGE="http://www.speech.cs.cmu.edu/flite/index.html"
@@ -18,6 +18,14 @@ RDEPEND="${DEPEND}"
S=${WORKDIR}/${P}-release
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4-tempfile.patch
+ "${FILESDIR}"/${PN}-1.4-fix-parallel-builds.patch
+ "${FILESDIR}"/${PN}-1.4-respect-destdir.patch
+ "${FILESDIR}"/${PN}-1.4-ldflags.patch
+ "${FILESDIR}"/${PN}-1.4-audio-interface.patch
+)
+
get_audio() {
if use alsa; then
echo alsa
@@ -29,11 +37,8 @@ get_audio() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-tempfile.patch
- epatch "${FILESDIR}"/${P}-fix-parallel-builds.patch
- epatch "${FILESDIR}"/${P}-respect-destdir.patch
- epatch "${FILESDIR}"/${P}-ldflags.patch
- epatch "${FILESDIR}"/${P}-audio-interface.patch
+ default
+
sed -i main/Makefile \
-e '/-rpath/s|$(LIBDIR)|$(INSTALLLIBDIR)|g' \
|| die
@@ -61,7 +66,7 @@ multilib_src_install_all() {
dodoc ACKNOWLEDGEMENTS README
if ! use static-libs; then
- rm -rf "${D}"/usr/lib*/*.a
+ find "${ED}" -name '*.a' ! -name '*.dll.a' -delete || die
fi
}