summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-07-05 09:16:32 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-07-05 09:16:32 +0000
commit4d9eba70de27b076068c651aa94d3f203db2184b (patch)
tree00c3eb7b14e18e5accc520e5a59b856b9e2aaf31
parent2022-07-05 09:01:41 UTC (diff)
parentdev-util/clion: drop 2022.1.1 (diff)
downloadgentoo-4d9eba70de27b076068c651aa94d3f203db2184b.tar.gz
gentoo-4d9eba70de27b076068c651aa94d3f203db2184b.tar.bz2
gentoo-4d9eba70de27b076068c651aa94d3f203db2184b.zip
Merge updates from master
-rw-r--r--app-text/jo/Manifest1
-rw-r--r--app-text/jo/jo-1.6.ebuild (renamed from app-text/jo/jo-99999.ebuild)18
-rw-r--r--app-text/jo/jo-9999.ebuild36
-rw-r--r--app-text/jo/metadata.xml15
-rw-r--r--dev-util/clion/Manifest2
-rw-r--r--dev-util/clion/clion-2022.1.3.ebuild (renamed from dev-util/clion/clion-2022.1.1-r1.ebuild)2
6 files changed, 64 insertions, 10 deletions
diff --git a/app-text/jo/Manifest b/app-text/jo/Manifest
index 51d13aea3032..d415981d9743 100644
--- a/app-text/jo/Manifest
+++ b/app-text/jo/Manifest
@@ -1 +1,2 @@
DIST jo-1.4.tar.gz 144596 BLAKE2B 0e0a0290d276b18fbfea0c770e134f29ea3f1eea9c7e5ccdd6c7d853dc0a8c70279fa464731f5b231d6d9d48816be4e5a6d93c7abc0e03408a86f0e1691d67a0 SHA512 c283b25e76fa06842c4f7d8ae8d94b207981d92a1bd4a064631e0646bdeedc06c1a00dddac405a455b27bda5eb34aaa7dc6d886ccf750741fd4d7312f692d169
+DIST jo-1.6.tar.gz 151941 BLAKE2B 13d7d68c33d7f89ebb4a5cdb448082bd4d245060ebf8c85149c39f2a184f03f1ac1c380833a742894c37c0815e3627569cfe29f202f9aa3dcec7fa089f99b918 SHA512 a2cb1327c8255e0f8d1b6e6056bbce081d7703192bdb974e908549b863d7db645531dbeff87629a6ed53626295ab7ca8a72816d104f9188846ef175c8a9acb07
diff --git a/app-text/jo/jo-99999.ebuild b/app-text/jo/jo-1.6.ebuild
index 098a68881de3..162d12aebd86 100644
--- a/app-text/jo/jo-99999.ebuild
+++ b/app-text/jo/jo-1.6.ebuild
@@ -1,16 +1,24 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit autotools bash-completion-r1 git-r3
+EAPI=8
+
+inherit autotools bash-completion-r1
DESCRIPTION="JSON output from a shell"
HOMEPAGE="https://github.com/jpmens/jo"
-EGIT_REPO_URI="https://github.com/jpmens/${PN}"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jpmens/${PN}"
+else
+ SRC_URI="https://github.com/jpmens/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
+
+BDEPEND="virtual/pkgconfig"
src_prepare() {
default
diff --git a/app-text/jo/jo-9999.ebuild b/app-text/jo/jo-9999.ebuild
new file mode 100644
index 000000000000..162d12aebd86
--- /dev/null
+++ b/app-text/jo/jo-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools bash-completion-r1
+
+DESCRIPTION="JSON output from a shell"
+HOMEPAGE="https://github.com/jpmens/jo"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jpmens/${PN}"
+else
+ SRC_URI="https://github.com/jpmens/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export bashcompdir=$(get_bashcompdir)
+ default
+}
+
+src_install() {
+ default
+ mv "${D}"$(get_bashcompdir)/jo{.bash,} || die
+}
diff --git a/app-text/jo/metadata.xml b/app-text/jo/metadata.xml
index 6aaa98d22ea0..602b4237d04e 100644
--- a/app-text/jo/metadata.xml
+++ b/app-text/jo/metadata.xml
@@ -1,8 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">jpmens/jo</remote-id>
- </upstream>
+ <maintainer type="person" proxied="yes">
+ <name>Thamognya Kodi</name>
+ <email>contact@thamognya.com</email>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jpmens/jo</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-util/clion/Manifest b/dev-util/clion/Manifest
index 8bcfe11875eb..92c2b61f684e 100644
--- a/dev-util/clion/Manifest
+++ b/dev-util/clion/Manifest
@@ -1 +1 @@
-DIST CLion-2022.1.1.tar.gz 785792506 BLAKE2B 9665bf3fe08aebb00b8bb1a26a0537c520444f66da679d01b9aab2230583abc0ecdf5b4510e7d6b39437ed6c9dc58939d5f9d1dab2568ea0c60438ad2c76e07d SHA512 bad80efeb9bcf88e31aa845605fb903dcc7deebe783100a40d0c5548c5f9ab3580804a2a924a511be007a94bc642df1c16bfd3477630719a0965ca075fdb72fb
+DIST CLion-2022.1.3.tar.gz 785987464 BLAKE2B 5b23d54f260a8e6023cce936ba50320c9c815d7024495d4a28a6fe9fa795d9944cce36fedd7b619ccf8188750708eb3bca887f9fc856d2d4defe096505742852 SHA512 5caabc409e9e22e59a26886cb5a5785cc0f2c193e7548a9757d11b4e2b7dad5af7545f3c71b83e3111deb0e0c90507eb5ee6020dcba40e413c0882f2743ac49d
diff --git a/dev-util/clion/clion-2022.1.1-r1.ebuild b/dev-util/clion/clion-2022.1.3.ebuild
index c6fcdf218e77..977084632a53 100644
--- a/dev-util/clion/clion-2022.1.1-r1.ebuild
+++ b/dev-util/clion/clion-2022.1.3.ebuild
@@ -37,6 +37,8 @@ RDEPEND="
net-print/cups
sys-apps/dbus
sys-devel/gdb
+ x11-libs/cairo
+ x11-libs/pango
sys-libs/zlib
x11-libs/libX11
x11-libs/libXcomposite