summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-12-05 18:07:56 -0500
committerMatt Turner <mattst88@gentoo.org>2019-12-05 18:20:38 -0500
commit4f19a6499275cb0d3abcee525057d84af24072d2 (patch)
tree4c058183996b1dc55f2fbdca885ed5e82103573d
parentmedia-libs/mesa: Drop old blocker (diff)
downloadgentoo-4f19a6499275cb0d3abcee525057d84af24072d2.tar.gz
gentoo-4f19a6499275cb0d3abcee525057d84af24072d2.tar.bz2
gentoo-4f19a6499275cb0d3abcee525057d84af24072d2.zip
media-libs/mesa: Drop IUSE=pax_kernel
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/mesa/mesa-9999.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 89ebb55245dd..db1fd34bf9ab 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -36,8 +36,8 @@ done
IUSE="${IUSE_VIDEO_CARDS}
+classic d3d9 debug +dri3 +egl +gallium +gbm gles1 +gles2 libglvnd +llvm
- lm-sensors opencl osmesa pax_kernel selinux test unwind vaapi valgrind
- vdpau vulkan vulkan-overlay wayland +X xa xvmc"
+ lm-sensors opencl osmesa selinux test unwind vaapi valgrind vdpau vulkan
+ vulkan-overlay wayland +X xa xvmc"
REQUIRED_USE="
d3d9? ( dri3 || ( video_cards_iris video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
@@ -458,11 +458,6 @@ multilib_src_configure() {
vulkan_enable video_cards_radeonsi amd
fi
- # x86 hardened pax_kernel needs glx-rts, bug 240956
- if [[ ${ABI} == x86 ]]; then
- emesonargs+=( $(meson_use pax_kernel glx-read-only-text) )
- fi
-
if use gallium; then
gallium_enable -- swrast
emesonargs+=( -Dosmesa=$(usex osmesa gallium none) )