summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-17 19:04:15 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-17 20:38:09 -0700
commit4f25a1928a5bacbd901602a7e366e0363d9d0363 (patch)
treec2f6b51a134a1bdce52d727629c55147d6553575
parentdev-util/icmake: remove old (diff)
downloadgentoo-4f25a1928a5bacbd901602a7e366e0363d9d0363.tar.gz
gentoo-4f25a1928a5bacbd901602a7e366e0363d9d0363.tar.bz2
gentoo-4f25a1928a5bacbd901602a7e366e0363d9d0363.zip
dev-libs/libebml: version bump to 1.3.10
Signed-off-by: Tim Harder <radhermit@gentoo.org>
-rw-r--r--dev-libs/libebml/Manifest1
-rw-r--r--dev-libs/libebml/libebml-1.3.10.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-libs/libebml/Manifest b/dev-libs/libebml/Manifest
index 811e5cc3d7e1..508972802b00 100644
--- a/dev-libs/libebml/Manifest
+++ b/dev-libs/libebml/Manifest
@@ -1 +1,2 @@
+DIST libebml-1.3.10.tar.xz 69488 BLAKE2B 0133ec041cd2f2aad9e8870d56c4ec8f3f3cbf745cbdbc2470f02f94152b8a236626d804bf8c42c00c6a49cc5e7d691394cffe0a888f26100ff67bd03a6ae2d7 SHA512 c7ba20664161e811a10847f888a833abaa2b7a4d43ddbef6ae927f391f5d1eff45bc703f13a52ccfc793521e3b22cbac2fd93550cd95119a4060153683b29c49
DIST libebml-1.3.9.tar.xz 69836 BLAKE2B d37bf9d74cb21a0c4cea3550bbd25f081e48085ba8d97d2f133e3f5da292527f0f31fc5aa3978c21f82262698877a76670b4b120e915573d339751234c4450c7 SHA512 a388fa8ff7acf9a0fb33faf9c00fc07f53794d86a4f894e04e2a690a24e781a7f380a0896e607e801a6f1f0b215407ee09a801e96d4b3e15f39ca71ec3a6d64e
diff --git a/dev-libs/libebml/libebml-1.3.10.ebuild b/dev-libs/libebml/libebml-1.3.10.ebuild
new file mode 100644
index 000000000000..dbb462d75acb
--- /dev/null
+++ b/dev-libs/libebml/libebml-1.3.10.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Extensible binary format library (kinda like XML)"
+HOMEPAGE="https://www.matroska.org/ https://github.com/Matroska-Org/libebml/"
+SRC_URI="https://dl.matroska.org/downloads/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/4" # subslot = soname major version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=YES )
+ cmake_src_configure
+}