summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-01-01 11:18:56 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-01-01 11:19:17 +1100
commit52e5028ee9b5cdfe2ff9ceb2ab7d9baf99b11041 (patch)
treeb089c15591aca0f3b467116a948d5bfcab87bc3b
parentHappy new year 2018! (diff)
downloadgentoo-52e5028ee9b5cdfe2ff9ceb2ab7d9baf99b11041.tar.gz
gentoo-52e5028ee9b5cdfe2ff9ceb2ab7d9baf99b11041.tar.bz2
gentoo-52e5028ee9b5cdfe2ff9ceb2ab7d9baf99b11041.zip
app-editors/focuswriter: version bump 1.6.8
Closes: https://bugs.gentoo.org/641238 Package-Manager: Portage-2.3.14, Repoman-2.3.6
-rw-r--r--app-editors/focuswriter/Manifest1
-rw-r--r--app-editors/focuswriter/focuswriter-1.6.8.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-editors/focuswriter/Manifest b/app-editors/focuswriter/Manifest
index 37fed117f72f..665af4100246 100644
--- a/app-editors/focuswriter/Manifest
+++ b/app-editors/focuswriter/Manifest
@@ -1 +1,2 @@
DIST focuswriter-1.6.7-src.tar.bz2 10196583 BLAKE2B 99c749271c785e69f07601575343669ed5be619e646be4ee38cc82242d353a84577842c1ff98f62b0adbbff1a733a0dce82593ac4ffa2eb61e611cea1b2657b5 SHA512 d33c66881b1065aa9812dae14a5fe2a2850ce1c50f4b38e028bcd3f5a4bb1fd489705b0272e3233f3db468b262daefbd906025126f792d04af41722cde2c7bf5
+DIST focuswriter-1.6.8-src.tar.bz2 10196595 BLAKE2B 1c726b948469960e1cc35dcf592acf48693035d2792449fdc336ac4bb03029d6d9eaac77c674347ac5e7a1a7ba7cd386de0d4034e7390dd80067b9522d85a08d SHA512 d10a559448f075110d9ba7fec487b9f125a4fcdce7dc1fcd2b21b94613a7d1126baa49623273bf0f56b1b7c2ef026a30c019653ba73e39b6fa78687c862e3402
diff --git a/app-editors/focuswriter/focuswriter-1.6.8.ebuild b/app-editors/focuswriter/focuswriter-1.6.8.ebuild
new file mode 100644
index 000000000000..67fc1801283b
--- /dev/null
+++ b/app-editors/focuswriter/focuswriter-1.6.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils qmake-utils xdg-utils
+
+DESCRIPTION="A fullscreen and distraction-free word processor"
+HOMEPAGE="https://gottcode.org/focuswriter/"
+SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# drop qtcore subslot when minimal Qt is 5.10
+RDEPEND="
+ app-text/hunspell:=
+ dev-qt/qtcore:5=
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsingleapplication[qt5,X]
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ dev-qt/qtconcurrent:5
+ virtual/pkgconfig
+"
+
+DOCS=( ChangeLog CREDITS NEWS README )
+
+PATCHES=( "${FILESDIR}/${PN}-1.6.0-unbundle-qtsingleapplication.patch" )
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}