summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-05-19 21:32:53 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2017-05-19 21:33:20 +0300
commit530e35e6362a411d4d9af686de063b8c890baede (patch)
tree44890835358df54845dc96f746b17f02e14f755b
parentdev-perl/MRO-Compat: Cleanup old re bug #613870 (diff)
downloadgentoo-530e35e6362a411d4d9af686de063b8c890baede.tar.gz
gentoo-530e35e6362a411d4d9af686de063b8c890baede.tar.bz2
gentoo-530e35e6362a411d4d9af686de063b8c890baede.zip
dev-libs/botan: version bump
Package-Manager: Portage-2.3.5, Repoman-2.3.1
-rw-r--r--dev-libs/botan/Manifest1
-rw-r--r--dev-libs/botan/botan-2.1.0.ebuild119
2 files changed, 120 insertions, 0 deletions
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
index 492902f842f5..fb6753f06adc 100644
--- a/dev-libs/botan/Manifest
+++ b/dev-libs/botan/Manifest
@@ -1,2 +1,3 @@
DIST Botan-1.10.15.tgz 2711022 SHA256 c0cc8ffd470fda4b257c3ef9faf5cf93751f4c283dfba878148acafedfab70fe SHA512 c3b93f44ad0de9758af11557833ee570aa0724c8b57c9a576b56ab439a7819e0f71a10857ad367b486716164dd4ff551cab2036ecbbbedd75db4b8dc93416bc8 WHIRLPOOL 834cad8b38787581d8d967b2fa6ffb6164e2bf8a124d993733a7d55202439ec543c18cb6cb03721c0e8eb67cbe2a486b8199b3b8784645e0033be298f36640b9
DIST Botan-2.0.1.tgz 4995413 SHA256 a138ed316d11450a8405451b9c9664b8e640a9b7ad84d3f3ad34e8071f364e0b SHA512 c5062ce92a6e6e333b4e6af095ed54d0c4ffacefc6ac87ec651dd1e0937793c9956b7c9c0d3acf49f059505526584168364e01c55ab72c953ad255e8396aed35 WHIRLPOOL 36cec762b05b761d77fc0421379e7c78172c67d1d8c9da4349df34f68d7d1a4fd5cca394ba4bd7c2e1a13a218a6a349b2216bfd7868e93549e37e5cf7ddc7dc1
+DIST Botan-2.1.0.tgz 5073684 SHA256 460f2d7205aed113f898df4947b1f66ccf8d080eec7dac229ef0b754c9ad6294 SHA512 af9ea35baf431500d380a360525e20e67dd17fdeaa442726019d544e9e423c301196cc17b09a3831f956ca9e62d7e99797f129b26fac10a653dd04e3ad1f4f4f WHIRLPOOL 75289db8f2a6bd075562acc1fd1a8297ad74369022941af7b08878dd94cc28494193a3937aae377c856d2957bf1ac3b564c0cd0ceae0701beab308c082c07fe6
diff --git a/dev-libs/botan/botan-2.1.0.ebuild b/dev-libs/botan/botan-2.1.0.ebuild
new file mode 100644
index 000000000000..65915b5a5e39
--- /dev/null
+++ b/dev-libs/botan/botan-2.1.0.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit multilib python-r1 toolchain-funcs
+
+MY_PN="Botan"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="A C++ crypto library"
+HOMEPAGE="http://botan.randombit.net/"
+SRC_URI="http://botan.randombit.net/releases/${MY_P}.tgz"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+SLOT="2/0"
+LICENSE="BSD"
+IUSE="bindist doc boost python bzip2 libressl lzma sqlite ssl static-libs zlib"
+REQUIRED_USE="python? ( boost ) boost? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
+ zlib? ( >=sys-libs/zlib-1.2.3 )
+ boost? ( ${PYTHON_DEPS} >=dev-libs/boost-1.48[python?,${PYTHON_USEDEP}] )
+ lzma? ( app-arch/xz-utils )
+ sqlite? ( dev-db/sqlite:3 )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0=[bindist=] )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}
+ dev-lang/python:*
+ doc? ( dev-python/sphinx )"
+
+pkg_pretend() {
+ # Botan 1.11 requires -std=c++11
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-major-version) -lt 4 ]] || \
+ ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 7 ]] ) \
+ && die "Sorry, but gcc 4.7 or higher is required."
+ fi
+}
+
+src_prepare() {
+ default
+ use doc || sed \
+ -e "/^install:/s/ docs//" \
+ -i src/build-data/makefile/gmake.in
+ use python && python_copy_sources
+}
+
+src_configure() {
+ local disable_modules=( proc_walk unix_procs )
+ use boost || disable_modules+=( "boost" )
+ use bindist && disable_modules+=( "ecdsa" )
+ use python || disable_modules+=( "ffi" )
+ elog "Disabling modules: ${disable_modules[@]}"
+
+ # Enable v9 instructions for sparc64
+ if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
+ CHOSTARCH="sparc32-v9"
+ else
+ CHOSTARCH="${CHOST%%-*}"
+ fi
+
+ local myos=
+ case ${CHOST} in
+ *-darwin*) myos=darwin ;;
+ *) myos=linux ;;
+ esac
+
+ local pythonvers=()
+ if use python; then
+ append() {
+ pythonvers+=( ${EPYTHON/python/} )
+ }
+ python_foreach_impl append
+ fi
+
+ ./configure.py \
+ --prefix="${EPREFIX}/usr" \
+ --destdir="${D}/${EPREFIX}/usr" \
+ --libdir=$(get_libdir) \
+ --docdir=share/doc \
+ --cc=gcc \
+ --os=${myos} \
+ --cpu=${CHOSTARCH} \
+ --with-endian="$(tc-endian)" \
+ --without-sphinx \
+ $(use_with doc sphinx) \
+ $(use_with bzip2) \
+ $(use_with lzma) \
+ $(use_with sqlite sqlite3) \
+ $(use_with ssl openssl) \
+ $(use_with zlib) \
+ $(use_with boost) \
+ --with-python-version=$(IFS=","; echo "${pythonvers[*]}" ) \
+ --disable-modules=$(IFS=","; echo "${disable_modules[*]}" ) \
+ || die "configure.py failed"
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX) -pthread" AR="$(tc-getAR) crs" LIB_OPT="-c ${CXXFLAGS}"
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}" ./botan-test || die "Validation tests failed"
+}
+
+src_install() {
+ emake install
+
+ if ! use static-libs; then
+ rm "${ED}usr/$(get_libdir)/libbotan"*.a || die 'remove of static libs failed'
+ fi
+
+ use python && python_foreach_impl python_optimize
+}