summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-03-30 17:10:37 +0100
committerMichał Górny <mgorny@gentoo.org>2019-03-30 18:42:59 +0100
commit54372d6d51f6f4b6ea431809439d55af0e81ec01 (patch)
treea05a2105b08c3693e495a1b8fcbb325af681e19d
parentdev-libs/vala-common: add 0.40.14 (diff)
downloadgentoo-54372d6d51f6f4b6ea431809439d55af0e81ec01.tar.gz
gentoo-54372d6d51f6f4b6ea431809439d55af0e81ec01.tar.bz2
gentoo-54372d6d51f6f4b6ea431809439d55af0e81ec01.zip
dev-python/cryptography: Use virtual/python-enum34
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cryptography/cryptography-2.2.2-r1.ebuild4
-rw-r--r--dev-python/cryptography/cryptography-2.3.1.ebuild4
-rw-r--r--dev-python/cryptography/cryptography-2.3.ebuild4
-rw-r--r--dev-python/cryptography/cryptography-2.4.2.ebuild4
-rw-r--r--dev-python/cryptography/cryptography-2.5.ebuild2
5 files changed, 9 insertions, 9 deletions
diff --git a/dev-python/cryptography/cryptography-2.2.2-r1.ebuild b/dev-python/cryptography/cryptography-2.2.2-r1.ebuild
index 449719f769ca..a9ee41ff6db9 100644
--- a/dev-python/cryptography/cryptography-2.2.2-r1.ebuild
+++ b/dev-python/cryptography/cryptography-2.2.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -33,11 +33,11 @@ RDEPEND="
)
libressl? ( dev-libs/libressl:0= )
$(python_gen_cond_dep '>=dev-python/cffi-1.7:=[${PYTHON_USEDEP}]' 'python*')
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 pypy{,3})
>=dev-python/idna-2.1[${PYTHON_USEDEP}]
>=dev-python/asn1crypto-0.21.0[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
virtual/python-ipaddress[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
diff --git a/dev-python/cryptography/cryptography-2.3.1.ebuild b/dev-python/cryptography/cryptography-2.3.1.ebuild
index 1a58e5692ef8..0a3fea875041 100644
--- a/dev-python/cryptography/cryptography-2.3.1.ebuild
+++ b/dev-python/cryptography/cryptography-2.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -32,11 +32,11 @@ RDEPEND="
)
)
libressl? ( dev-libs/libressl:0= )
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 pypy{,3})
>=dev-python/idna-2.1[${PYTHON_USEDEP}]
>=dev-python/asn1crypto-0.21.0[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
virtual/python-ipaddress[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
diff --git a/dev-python/cryptography/cryptography-2.3.ebuild b/dev-python/cryptography/cryptography-2.3.ebuild
index ec123a175ee9..d7f68b52d822 100644
--- a/dev-python/cryptography/cryptography-2.3.ebuild
+++ b/dev-python/cryptography/cryptography-2.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -32,11 +32,11 @@ RDEPEND="
)
)
libressl? ( dev-libs/libressl:0= )
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 pypy{,3})
>=dev-python/idna-2.1[${PYTHON_USEDEP}]
>=dev-python/asn1crypto-0.21.0[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
virtual/python-ipaddress[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
diff --git a/dev-python/cryptography/cryptography-2.4.2.ebuild b/dev-python/cryptography/cryptography-2.4.2.ebuild
index 4af6a76f62db..d7f68b52d822 100644
--- a/dev-python/cryptography/cryptography-2.4.2.ebuild
+++ b/dev-python/cryptography/cryptography-2.4.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -32,11 +32,11 @@ RDEPEND="
)
)
libressl? ( dev-libs/libressl:0= )
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 pypy{,3})
>=dev-python/idna-2.1[${PYTHON_USEDEP}]
>=dev-python/asn1crypto-0.21.0[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
virtual/python-ipaddress[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
diff --git a/dev-python/cryptography/cryptography-2.5.ebuild b/dev-python/cryptography/cryptography-2.5.ebuild
index c6cccef62a59..d75305f32e0e 100644
--- a/dev-python/cryptography/cryptography-2.5.ebuild
+++ b/dev-python/cryptography/cryptography-2.5.ebuild
@@ -32,11 +32,11 @@ RDEPEND="
)
)
libressl? ( dev-libs/libressl:0= )
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 pypy{,3})
idna? ( >=dev-python/idna-2.1[${PYTHON_USEDEP}] )
>=dev-python/asn1crypto-0.21.0[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
virtual/python-ipaddress[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}