summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-31 08:36:39 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-31 08:38:01 +0200
commit545ae8944fe940a934a9d75f325309cca2b26963 (patch)
tree1c5cf41742cd9c6f308d45880ad922ae7e1c6cc5
parentdev-ruby/plist: cleanup (diff)
downloadgentoo-545ae8944fe940a934a9d75f325309cca2b26963.tar.gz
gentoo-545ae8944fe940a934a9d75f325309cca2b26963.tar.bz2
gentoo-545ae8944fe940a934a9d75f325309cca2b26963.zip
dev-python/jupyter_console: Fix installing entry points
Closes: https://bugs.gentoo.org/734786 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyter_console/jupyter_console-6.1.0-r1.ebuild (renamed from dev-python/jupyter_console/jupyter_console-6.1.0.ebuild)6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/jupyter_console/jupyter_console-6.1.0.ebuild b/dev-python/jupyter_console/jupyter_console-6.1.0-r1.ebuild
index 1ef4cd71b97a..a17d12565383 100644
--- a/dev-python/jupyter_console/jupyter_console-6.1.0.ebuild
+++ b/dev-python/jupyter_console/jupyter_console-6.1.0-r1.ebuild
@@ -37,6 +37,12 @@ PATCHES=(
"${FILESDIR}"/${P}-py39.patch
)
+src_prepare() {
+ # use setuptools unconditionally
+ sed -i -e 's:distutils\.core:setuptools:' setup.py || die
+ distutils-r1_src_prepare
+}
+
python_test() {
script -eqc "nosetests -v" || die
}