summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-11-23 21:57:21 -0800
committerMatt Turner <mattst88@gentoo.org>2017-11-23 22:06:12 -0800
commit54bdbb5491d762cd844b652569912230a7b8baaf (patch)
tree70388f16e5e1ff44daae02788fd3a590cff191b1
parentapp-misc/ddccontrol: Drop dead video_cards_fglrx (diff)
downloadgentoo-54bdbb5491d762cd844b652569912230a7b8baaf.tar.gz
gentoo-54bdbb5491d762cd844b652569912230a7b8baaf.tar.bz2
gentoo-54bdbb5491d762cd844b652569912230a7b8baaf.zip
media-libs/cogl: Drop dead video_cards_fglrx
-rw-r--r--media-libs/cogl/cogl-1.22.2.ebuild6
-rw-r--r--media-libs/cogl/files/cogl-1.22.0-fglrx.patch10
2 files changed, 1 insertions, 15 deletions
diff --git a/media-libs/cogl/cogl-1.22.2.ebuild b/media-libs/cogl/cogl-1.22.2.ebuild
index 0419b0b73888..97738b3c5969 100644
--- a/media-libs/cogl/cogl-1.22.2.ebuild
+++ b/media-libs/cogl/cogl-1.22.2.ebuild
@@ -12,7 +12,7 @@ LICENSE="MIT BSD"
SLOT="1.0/20" # subslot = .so version
# doc and profile disable for now due to bugs #484750 and #483332
-IUSE="debug examples gles2 gstreamer +introspection +kms +opengl +pango test video_cards_fglrx wayland" # doc profile
+IUSE="debug examples gles2 gstreamer +introspection +kms +opengl +pango test wayland" # doc profile
REQUIRED_USE="
wayland? ( gles2 )
|| ( gles2 opengl )
@@ -61,10 +61,6 @@ DEPEND="${COMMON_DEPEND}
RESTRICT="test"
src_prepare() {
- # Let cogl work with fglrx driver, bug #567168
- # https://bugzilla.gnome.org/show_bug.cgi?id=756306
- use video_cards_fglrx && eapply "${FILESDIR}"/${PN}-1.22.0-fglrx.patch
-
# Do not build examples
sed -e "s/^\(SUBDIRS +=.*\)examples\(.*\)$/\1\2/" \
-i Makefile.am Makefile.in || die
diff --git a/media-libs/cogl/files/cogl-1.22.0-fglrx.patch b/media-libs/cogl/files/cogl-1.22.0-fglrx.patch
deleted file mode 100644
index dac1419a58bc..000000000000
--- a/media-libs/cogl/files/cogl-1.22.0-fglrx.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/cogl/driver/gl/gl/cogl-driver-gl.c 2015-09-02 18:39:02.000000000 +0200
-+++ b/cogl/driver/gl/gl/cogl-driver-gl.c 2015-10-18 10:37:14.052350142 +0200
-@@ -419,7 +419,7 @@
- if (COGL_CHECK_GL_VERSION (ctx->glsl_major, ctx->glsl_minor, 1, 2))
- /* We want to use version 120 if it is available so that the
- * gl_PointCoord can be used. */
-- ctx->glsl_version_to_use = 120;
-+ ctx->glsl_version_to_use = 150;
- else
- ctx->glsl_version_to_use = 110;