summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-02-26 12:05:03 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-02-26 12:05:03 +0100
commit558ee546f2af179b5b3a36480789435a82afe96f (patch)
tree2f6b9e04f18e35037d96f75b12710a9fc55c8aed
parentsys-apps/gawk: Bump to version 4.2.1 (diff)
downloadgentoo-558ee546f2af179b5b3a36480789435a82afe96f.tar.gz
gentoo-558ee546f2af179b5b3a36480789435a82afe96f.tar.bz2
gentoo-558ee546f2af179b5b3a36480789435a82afe96f.zip
sys-apps/habitat: Version bump to 0.54.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--sys-apps/habitat/Manifest2
-rw-r--r--sys-apps/habitat/habitat-0.54.0.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/habitat/Manifest b/sys-apps/habitat/Manifest
index 1a07d1c4fa71..55f2102694da 100644
--- a/sys-apps/habitat/Manifest
+++ b/sys-apps/habitat/Manifest
@@ -1,2 +1,4 @@
DIST habitat-0.28.0.tar.gz 25147061 BLAKE2B 0412565e3816e451945b0eae73eff0039dbd881bd86d3ed1e6f0aeef90555100f9baafcf551ed48ef2188b4ddbf768735006129afe5b66fcf53e638701b93fcc SHA512 eccdced6655e46b894aa3ef29cbac7100e18b4c44c7c2c7a25d5bb31ba732f908122630a7dd35c6347fa805180b471ce7dac786113d2f9b6d35a967994913b9f
+DIST habitat-0.54.0.tar.gz 35324897 BLAKE2B 554a2097c019e61cd6f1facdd0195abbca5e94834819283ddc2d742d196b6768e1da03a8a94f462a17d3c5c751fdddc1499f59a698f73fce170387055a07cbc6 SHA512 4b34de34e6d7b20ab641222636720357c903228aeb6833462ecc3367c6844d9f377d101b3187996e3cf3c179aa7b0c71a83921b4d18d1002fe30e3b25e31a35d
DIST habitat-cargo-0.28.0.tar.xz 84559904 BLAKE2B ed4e62e5aee3a6b336c617d7d912db8e6b58ed28f5cc747765075926659841a84d8380ef6273c0a83017f08cf8c5dcd57928de033b71e17213f7dd5f7b0ad381 SHA512 d6f798e21bfa8124820f505231423b0ef72d068a38e8a88f0d196cfcf9e5d7a2142499f809a8525ec2f5ce664e7598d5c0979efcd2511e860b8f884ac4f6fd4b
+DIST habitat-cargo-0.54.0.tar.xz 247811208 BLAKE2B 28d79018ff9f1209881908b335a1c77f60c39799fbd02e37ffde6bccc37c46aafe1cb05914c9b373150a0a917fa5b1538a94a8a75127172cf9d15cca5ba90520 SHA512 603e45b6e61b24b5420e57ef1d06bf15a67681525ae7a4210f07d14a072cf116947d28cc754e415f1e35fc6e03ede70cd47706ddf4857b76ac17aa420bf95d07
diff --git a/sys-apps/habitat/habitat-0.54.0.ebuild b/sys-apps/habitat/habitat-0.54.0.ebuild
new file mode 100644
index 000000000000..407816389d25
--- /dev/null
+++ b/sys-apps/habitat/habitat-0.54.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Application automation framework"
+HOMEPAGE="https://github.com/habitat-sh/habitat https://habitat.sh"
+SRC_URI="https://github.com/habitat-sh/habitat/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~mrueg/files/${PN}-cargo-${PV}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-util/cargo
+ >=virtual/rust-1.23
+ >=net-libs/zeromq-3.2
+ virtual/pkgconfig"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ # move cache dir where cargo expects it
+ mv ../.cargo "${HOME}" || die
+}
+
+src_install() {
+ dodoc README.md CHANGELOG.md
+ dobin target/debug/hab{,-butterfly,-sup}
+}
+
+src_test() {
+ emake unit-all
+}