summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-07-30 21:27:37 +0200
committerJeroen Roovers <jer@gentoo.org>2016-07-30 21:27:58 +0200
commit5604fa98bd62965b33f1ff0f242be18393fee5b6 (patch)
treeef7c65a2b4bf470f01e71d496ca738f2628bcffc
parentwww-client/chromium: beta channel bump (53.0.2785.34) (diff)
downloadgentoo-5604fa98bd62965b33f1ff0f242be18393fee5b6.tar.gz
gentoo-5604fa98bd62965b33f1ff0f242be18393fee5b6.tar.bz2
gentoo-5604fa98bd62965b33f1ff0f242be18393fee5b6.zip
net-analyzer/tcptrace: Pull in Debian patch to replace private pcap_offline_read() call (bug #590076).
Package-Manager: portage-2.3.0
-rw-r--r--net-analyzer/tcptrace/Manifest1
-rw-r--r--net-analyzer/tcptrace/tcptrace-6.6.7_p4_p1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-analyzer/tcptrace/Manifest b/net-analyzer/tcptrace/Manifest
index 4a7145ea7c6a..9c4916d1dd9f 100644
--- a/net-analyzer/tcptrace/Manifest
+++ b/net-analyzer/tcptrace/Manifest
@@ -1 +1,2 @@
DIST tcptrace-6.6.7.tar.gz 3773308 SHA256 63380a4051933ca08979476a9dfc6f959308bc9f60d45255202e388eb56910bd SHA512 3638770c342aea6c71aa556e758ed22e1fd44730f6c652cf82d3861eb1c31b186952c660071bd1df45020b80eaf9dd090a4ff58c979cc907eb8154dcb7b9b432 WHIRLPOOL b7eb2373b9a26789c47bb05e1e45047164648ff6f5cb3b57ba552d205443ca1fba7df9dd983a68f712a3e7398e776d97b328463f2497e7e39ba2b7db789c14b0
+DIST tcptrace_6.6.7-4.1.diff.gz 29161 SHA256 8d146edf2763badd92813404240c996613e256f1300c801f0dad02b842bf3ed4 SHA512 2f6dfeb8e15faa0151bdbb18194587e51de040f63117eb1b469a826091d5c1e5eb41a306bdc94e89ce993d0d04ec31324e5f7eea0a1a52852e07ee80006b2087 WHIRLPOOL 56af4f8ca7f5efbe5fd57acc2e7a881c315b245f5a10e4e4ce7eee9101554e53694e576129a8a997b4bbf89c2a0a92a2eab2f7efeca401808399524979cd2b17
diff --git a/net-analyzer/tcptrace/tcptrace-6.6.7_p4_p1.ebuild b/net-analyzer/tcptrace/tcptrace-6.6.7_p4_p1.ebuild
new file mode 100644
index 000000000000..3493016463a1
--- /dev/null
+++ b/net-analyzer/tcptrace/tcptrace-6.6.7_p4_p1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils flag-o-matic versionator
+
+TT_DEB_MAJOR=$(get_version_component_range 4)
+TT_DEB_MAJOR=${TT_DEB_MAJOR/p}
+TT_DEB_MINOR=$(get_version_component_range 5)
+TT_DEB_MINOR=${TT_DEB_MINOR/p}
+TT_VER=$(get_version_component_range 1-3)
+
+DESCRIPTION="A Tool for analyzing network packet dumps"
+HOMEPAGE="http://www.tcptrace.org/"
+SRC_URI="
+ http://www.tcptrace.org/download/${PN}-${TT_VER}.tar.gz
+ http://www.tcptrace.org/download/old/6.6/${PN}-${TT_VER}.tar.gz
+ mirror://debian/pool/main/t/${PN}/${PN}_${TT_VER}-${TT_DEB_MAJOR}.${TT_DEB_MINOR}.diff.gz
+"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ net-libs/libpcap
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+S=${WORKDIR}/${PN}-${TT_VER}
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-${TT_VER}-cross-compile.patch
+ eapply "${WORKDIR}"/${PN}_${TT_VER}-${TT_DEB_MAJOR}.${TT_DEB_MINOR}.diff
+
+ eapply_user
+
+ append-cppflags -D_DEFAULT_SOURCE
+
+ eautoreconf
+}
+
+src_compile() {
+ emake CCOPT="${CFLAGS}"
+}
+
+src_install() {
+ dobin tcptrace xpl2gpl
+
+ newman tcptrace.man tcptrace.1
+ dodoc CHANGES COPYRIGHT FAQ README* THANKS WWW
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN}; then
+ elog "Note: tcptrace outputs its graphs in the xpl (xplot)"
+ elog "format. Since xplot is unavailable, you will have to"
+ elog "use the included xpl2gpl utility to convert it to"
+ elog "the gnuplot format."
+ fi
+}