summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-03-10 09:28:42 +0100
committerPatrice Clement <monsieurp@gentoo.org>2020-03-10 12:28:09 +0100
commit563cb1affb5efaaadcf536c675362acbb6652b74 (patch)
treed21c637c0e02ef38498e93ae3941882ca6529f7b
parentdev-python/protobuf-python: ia64 stable wrt bug #712016 (diff)
downloadgentoo-563cb1affb5efaaadcf536c675362acbb6652b74.tar.gz
gentoo-563cb1affb5efaaadcf536c675362acbb6652b74.tar.bz2
gentoo-563cb1affb5efaaadcf536c675362acbb6652b74.zip
app-admin/entr: version bump.
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--app-admin/entr/Manifest1
-rw-r--r--app-admin/entr/entr-4.4.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/entr/Manifest b/app-admin/entr/Manifest
index fad485132f03..5073b182851d 100644
--- a/app-admin/entr/Manifest
+++ b/app-admin/entr/Manifest
@@ -1 +1,2 @@
DIST entr-4.3.tar.gz 23756 BLAKE2B 0272b0185932d7c388818df0cc615e991c9545473a823c478ad9f0b6a23c97c0f4b2727b109a7bb18e2b0792f18d94d188d4a5d3fc90c479628ea078b1288f96 SHA512 f65dfc3f106e25ec4ff39eaec94222d8a547eb35390c654f6a741f92541c1b86d7d303a795308fcbfced44ac8eca6ad67e70393802ac9d46153e037dc1eab902
+DIST entr-4.4.tar.gz 24125 BLAKE2B c77b4a862c0b4a2861d7e2784fbaa3f60899a9934314a5cf3abb01d70df946e3786957cbaa9ed58cea7171390d115157f0d9a48093f6e7a8c05bcabf34da9792 SHA512 355bc19cfee9a9b5a460b136d8db014a1d129b6e4c95d905c1c4557cf7d845a076d260798ae8b84221563c049a9bd6d81974f00eea681abaf2eac2f2f5e6d087
diff --git a/app-admin/entr/entr-4.4.ebuild b/app-admin/entr/entr-4.4.ebuild
new file mode 100644
index 000000000000..b86dea0ffd94
--- /dev/null
+++ b/app-admin/entr/entr-4.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Run arbitrary commands when files change"
+HOMEPAGE="http://entrproject.org"
+SRC_URI="http://entrproject.org/code/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ sh configure || die
+ sed -i -e 's#\(^PREFIX \).*#\1\?= /usr#' Makefile.bsd || die
+}
+
+src_compile() {
+ export CC=$(tc-getCC)
+ default
+}
+
+src_test() {
+ export CC=$(tc-getCC)
+ default
+}