summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-11-10 22:21:59 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-11-10 22:22:22 +0000
commit56470165472b6d99db739c36b1ceef77b080706c (patch)
treeb3751f98d856afc2f1b8fbe7f616f07db37ea2d3
parentwww-client/chromium: amd64 stable, bug #753848 (diff)
downloadgentoo-56470165472b6d99db739c36b1ceef77b080706c.tar.gz
gentoo-56470165472b6d99db739c36b1ceef77b080706c.tar.bz2
gentoo-56470165472b6d99db739c36b1ceef77b080706c.zip
dev-libs/libffi: drop no-op pkg_setup()
Due to a bug in handling empty ${ROOT} pkg_setup() was a no-op. It's not a big problem as it used to check for libffi presence outside package manager (usually due to old gcc bundlibg libffi). The check should should be redundant on modern toolchain. Reported-by: Pacho Ramos Closes: https://bugs.gentoo.org/753821 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-libs/libffi/libffi-3.3-r2.ebuild16
1 files changed, 1 insertions, 15 deletions
diff --git a/dev-libs/libffi/libffi-3.3-r2.ebuild b/dev-libs/libffi/libffi-3.3-r2.ebuild
index 19e01b0832dd..0b379dac2a43 100644
--- a/dev-libs/libffi/libffi-3.3-r2.ebuild
+++ b/dev-libs/libffi/libffi-3.3-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit multilib multilib-minimal toolchain-funcs
+inherit multilib multilib-minimal
MY_PV=${PV/_rc/-rc}
MY_P=${PN}-${MY_PV}
@@ -38,20 +38,6 @@ S=${WORKDIR}/${MY_P}
ECONF_SOURCE=${S}
-pkg_setup() {
- # Check for orphaned libffi, see https://bugs.gentoo.org/354903 for example
- if [[ ${ROOT} == "/" && ${EPREFIX} == "" ]] && ! has_version ${CATEGORY}/${PN}; then
- local base="${T}"/conftest
- echo 'int main() { }' > "${base}".c
- $(tc-getCC) -o "${base}" "${base}".c -lffi >&/dev/null
- if [ $? -eq 0 ]; then
- eerror "The linker reported linking against -lffi to be working while it shouldn't have."
- eerror "This is wrong and you should find and delete the old copy of libffi before continuing."
- die "The system is in inconsistent state with unknown libffi installed."
- fi
- fi
-}
-
multilib_src_configure() {
use userland_BSD && export HOST="${CHOST}"
# --includedir= path maintains a few properties: