summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilfried Holzke <gentoo@holzke.net>2020-11-14 21:54:32 +0100
committerCraig Andrews <candrews@gentoo.org>2020-11-14 16:02:38 -0500
commit56baaf39ac73c4dada3f1a0e394d0b26f2d6cd2c (patch)
tree7a135cec248a1c519f1d1d5b41f0655025385444
parentdev-python/cfn-python-lint: Add missing mock dep (diff)
downloadgentoo-56baaf39ac73c4dada3f1a0e394d0b26f2d6cd2c.tar.gz
gentoo-56baaf39ac73c4dada3f1a0e394d0b26f2d6cd2c.tar.bz2
gentoo-56baaf39ac73c4dada3f1a0e394d0b26f2d6cd2c.zip
dev-libs/rocm-opencl-runtime: Version bump to 3.9.0
Signed-off-by: Wilfried Holzke <gentoo@holzke.net> Package-Manager: Portage-3.0.8, Repoman-3.0.2 Closes: https://github.com/gentoo/gentoo/pull/18261 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--dev-libs/rocm-opencl-runtime/Manifest1
-rw-r--r--dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.9.0-add-rocclr-include-directories.patch12
-rw-r--r--dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-3.9.0.ebuild69
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-libs/rocm-opencl-runtime/Manifest b/dev-libs/rocm-opencl-runtime/Manifest
index f211cc17aaa4..b18e4bbe1c05 100644
--- a/dev-libs/rocm-opencl-runtime/Manifest
+++ b/dev-libs/rocm-opencl-runtime/Manifest
@@ -1 +1,2 @@
DIST rocm-opencl-runtime-3.8.0.tar.gz 1004339 BLAKE2B 966a5bd1d4d188004b15fe4263f2c18f6dad6a07f4bc264a5afa010f6035fbf73288966cd624e6e31e1ba584ba322d93343e3482177e6480c4a57a4150546f5a SHA512 bb4e3568e32bf6acc3c4812d7db169396a01bf90d079dc420ffb7df4bd4146d39938e76e9b386548fe64276bbf938a545c898de599113f20cc73ae98268c3d6a
+DIST rocm-opencl-runtime-3.9.0.tar.gz 1004372 BLAKE2B f5485dfbc615826214e1071485636e94bc83d12d4412da912455cb0ddd39ede3429a749a16428cb3c10775e652ffbe31a63ad00b3ea38a7fa43a120776a12bfe SHA512 e8149e99a7116a2c2af0d04dde55290c35dd5c6c26d95da8c8a04fcfccdb23f6617ab8348f9fc201b6d9fde7202de4ede480d7ac547ae2471c6ae10897e1795e
diff --git a/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.9.0-add-rocclr-include-directories.patch b/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.9.0-add-rocclr-include-directories.patch
new file mode 100644
index 000000000000..e9341675d890
--- /dev/null
+++ b/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.9.0-add-rocclr-include-directories.patch
@@ -0,0 +1,12 @@
+--- a/amdocl/CMakeLists.txt 2020-08-23 10:11:28.227839351 +0200
++++ b/amdocl/CMakeLists.txt 2020-08-23 10:44:34.929831772 +0200
+@@ -23,6 +23,9 @@
+ include_directories(${CMAKE_SOURCE_DIR}/khronos)
+ include_directories(${CMAKE_SOURCE_DIR}/khronos/headers)
+ include_directories(${CMAKE_SOURCE_DIR}/khronos/headers/opencl2.2)
++include_directories(/usr/include/rocclr)
++include_directories(/usr/include/rocclr/compiler/lib/include/)
++include_directories(/usr/include/rocclr/elf/)
+
+ if((CMAKE_CXX_COMPILER_ID STREQUAL "GNU") OR
+ (CMAKE_${COMPILER}_COMPILER_ID MATCHES "Clang"))
diff --git a/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-3.9.0.ebuild b/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-3.9.0.ebuild
new file mode 100644
index 000000000000..cd1f935e955a
--- /dev/null
+++ b/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-3.9.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime/archive/roc-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/ROCm-OpenCL-Runtime-rocm-${PV}"
+fi
+
+DESCRIPTION="Radeon Open Compute OpenCL Compatible Runtime"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND=">=dev-libs/rocr-runtime-${PV}
+ >=dev-libs/rocclr-${PV}
+ >=dev-libs/rocm-comgr-${PV}
+ >=dev-libs/rocm-device-libs-${PV}
+ >=virtual/opencl-3
+ media-libs/mesa"
+DEPEND="${RDEPEND}
+ dev-lang/ocaml
+ dev-ml/findlib"
+BDEPEND=">=dev-util/rocm-cmake-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.7.0-change-install-location.patch"
+ "${FILESDIR}/${PN}-3.5.0-do-not-install-libopencl.patch"
+ "${FILESDIR}/${PN}-3.9.0-add-rocclr-include-directories.patch"
+ "${FILESDIR}/${PN}-3.7.0-amdocl64icd.patch"
+)
+
+src_prepare() {
+ # Remove "clinfo" - use "dev-util/clinfo" instead
+ [ -d tools/clinfo ] && rm -rf tools/clinfo || die
+
+ # Wrong position of a '"' results in a list of strings instead of a single string and the build fails...
+ sed -e "s:set(CMAKE_SHARED_LINKER_FLAGS \${CMAKE_SHARED_LINKER_FLAGS} \":set(CMAKE_SHARED_LINKER_FLAGS \"\${CMAKE_SHARED_LINKER_FLAGS} :" -i "${S}/amdocl/CMakeLists.txt"
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Reported upstream: https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime/issues/120
+ append-cflags -fcommon
+
+ local mycmakeargs=(
+ -DUSE_COMGR_LIBRARY=yes
+ -DROCclr_DIR="${EPREFIX}/usr/include/rocclr"
+ -DLIBROCclr_STATIC_DIR="${EPREFIX}/usr/lib/cmake/rocclr"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cd "${BUILD_DIR}" || die
+ insinto /etc/OpenCL/vendors
+ doins amdocl64.icd
+ insinto /usr/lib64
+ doins lib/libamdocl64.so
+}