summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-03-26 22:19:46 -0500
committerAaron Bauman <bman@gentoo.org>2018-03-27 18:59:01 -0400
commit5776368a2b6ee81ee9ecec994ab5016564e6c735 (patch)
tree7f280917679c9ca481d7a89be71d92bbbaf9ea6a
parentdev-db/4store: replace dead SRC_URI and HOMEPAGE (diff)
downloadgentoo-5776368a2b6ee81ee9ecec994ab5016564e6c735.tar.gz
gentoo-5776368a2b6ee81ee9ecec994ab5016564e6c735.tar.bz2
gentoo-5776368a2b6ee81ee9ecec994ab5016564e6c735.zip
sys-apps/flashrom: EAPI bump and point to new source repo
svn repo no longer works. also the pkg-config sed is no longer required as of flashrom-0.9.9 Closes: https://bugs.gentoo.org/598028 Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7634
-rw-r--r--sys-apps/flashrom/flashrom-9999.ebuild16
1 files changed, 5 insertions, 11 deletions
diff --git a/sys-apps/flashrom/flashrom-9999.ebuild b/sys-apps/flashrom/flashrom-9999.ebuild
index 5e764d19fc7d..c49046ce83b9 100644
--- a/sys-apps/flashrom/flashrom-9999.ebuild
+++ b/sys-apps/flashrom/flashrom-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
- ESVN_REPO_URI="https://code.coreboot.org/svn/flashrom/trunk"
- inherit subversion
+ EGIT_REPO_URI="https://review.coreboot.org/flashrom.git"
+ inherit git-r3
else
SRC_URI="https://download.flashrom.org/releases/${P}.tar.bz2"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
@@ -64,12 +64,6 @@ flashrom_enable() {
for u ; do _flashrom_enable "${u}" ; done
}
-src_prepare() {
- sed -i \
- -e 's:pkg-config:$(PKG_CONFIG):' \
- Makefile || die
-}
-
src_compile() {
# Help keep things in sync.
local sprogs=$(echo $(