summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-09 17:45:58 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-09 17:45:58 -0500
commit57997a2645131d45528a35596603343b14192dfc (patch)
treec989cfcfc9229664732aff3b51362a7190833ac2
parentdev-tex/ellipsis: bump EAPI and stuff (diff)
downloadgentoo-57997a2645131d45528a35596603343b14192dfc.tar.gz
gentoo-57997a2645131d45528a35596603343b14192dfc.tar.bz2
gentoo-57997a2645131d45528a35596603343b14192dfc.zip
dev-tex/latex-calendar: bump EAPI and stuff
Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--dev-tex/latex-calendar/latex-calendar-3.1.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/dev-tex/latex-calendar/latex-calendar-3.1.ebuild b/dev-tex/latex-calendar/latex-calendar-3.1.ebuild
index b5bb6f0e1891..0877b3512838 100644
--- a/dev-tex/latex-calendar/latex-calendar-3.1.ebuild
+++ b/dev-tex/latex-calendar/latex-calendar-3.1.ebuild
@@ -1,18 +1,20 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit latex-package
MY_P="calendar"
+
DESCRIPTION="LaTeX package used to create Calendars. Very flexible and robust"
-HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/calendar/"
+HOMEPAGE="https://www.ctan.org/tex-archive/macros/latex/contrib/calendar/"
SRC_URI="mirror://gentoo/${P}.tar.gz"
+KEYWORDS="amd64 ppc sparc x86"
+
LICENSE="LaTeX-Calendar"
SLOT="0"
-KEYWORDS="amd64 ppc sparc x86"
IUSE=""
S=${WORKDIR}/${MY_P}
@@ -20,13 +22,15 @@ S=${WORKDIR}/${MY_P}
src_compile() {
debug-print function $FUNCNAME $*
echo "Extracting from allcal.ins"
- ( yes | latex allcal.ins ) >/dev/null 2>&1
+ ( yes | latex allcal.ins ) >/dev/null 2>&1 || die "extracting failed"
}
src_install() {
- texi2dvi -q -c --language=latex calguide.tex &> /dev/null
+ texi2dvi -q -c --language=latex calguide.tex &> /dev/null || die "conversion failed"
+
latex-package_src_doinstall styles fonts bin dvi
+
dodoc README MANIFEST CATALOG
- insinto /usr/share/doc/${P}/samples
- doins bigdemo.tgz *.cfg *.tex *.cld
+ docinto samples
+ dodoc bigdemo.tgz *.cfg *.tex *.cld
}