summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-21 09:40:41 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-21 10:08:15 +0200
commit5a0d4858f589cf1e883737270043de9ae216e723 (patch)
tree55ee21204473a5c7f8dbd87f39b4bb6a8401b6db
parentdev-python/discogs-client: Enable py3.{7,8} (diff)
downloadgentoo-5a0d4858f589cf1e883737270043de9ae216e723.tar.gz
gentoo-5a0d4858f589cf1e883737270043de9ae216e723.tar.bz2
gentoo-5a0d4858f589cf1e883737270043de9ae216e723.zip
dev-python/discogs-client: Bump to 2.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/discogs-client/Manifest1
-rw-r--r--dev-python/discogs-client/discogs-client-2.2.2.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/discogs-client/Manifest b/dev-python/discogs-client/Manifest
index 95b4f68be814..924febac274d 100644
--- a/dev-python/discogs-client/Manifest
+++ b/dev-python/discogs-client/Manifest
@@ -1 +1,2 @@
DIST discogs-client-2.2.1.tar.gz 24645 BLAKE2B 310b2a23a58f58c0d258599ad88a8e44202a38850af72ead293bd5ac21a92521ee53cfd6d8340d4c122145b4f3797f905a7f5273c6b0e5e23e8aff43fdf09c85 SHA512 fa339b14d5655a36fdf252fd94c729ecb97e195c1f7eb2e5207355dc5f4fd89d0b738218ffbac71acab4f143870bdba5cf5ea02dff70166014f14c30481ae1e5
+DIST discogs-client-2.2.2.tar.gz 25005 BLAKE2B 1e87ce7a1cfd2d72a3dbbc0544a4e6a91d451c9d65c0712f261297e6bf4a46663bfe73d59781c9159902666cb10c0d1594a37ee6493623f794e0f4ec6ec6cfb0 SHA512 cf08526f739216efa9ef628f28650c8074cd6ddb21e0ab5431a8c8864c1f2707f612b065baf6b2f907b7fa7cdf2cfe5905cbefddb02c6f8f1c7796b0631a2ba7
diff --git a/dev-python/discogs-client/discogs-client-2.2.2.ebuild b/dev-python/discogs-client/discogs-client-2.2.2.ebuild
new file mode 100644
index 000000000000..ce9a90a9447b
--- /dev/null
+++ b/dev-python/discogs-client/discogs-client-2.2.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Official Python API client for Discogs"
+HOMEPAGE="https://github.com/discogs/discogs_client https://pypi.org/project/discogs-client/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/oauth2[${PYTHON_USEDEP}]
+ dev-python/oauthlib[${PYTHON_USEDEP}]
+ "
+
+distutils_enable_tests unittest