summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-05-15 15:05:15 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-05-15 15:05:15 +0200
commit5af87322eb911c1c1d286e36df1bc2372cbbd3f6 (patch)
treedb274b1b3edaeaceb963bd60729f1ee2539733b0
parentapp-editors/notepadqq: Bump to version 1.4.8. Removed old. (diff)
downloadgentoo-5af87322eb911c1c1d286e36df1bc2372cbbd3f6.tar.gz
gentoo-5af87322eb911c1c1d286e36df1bc2372cbbd3f6.tar.bz2
gentoo-5af87322eb911c1c1d286e36df1bc2372cbbd3f6.zip
app-emulation/containerd: Add snapshot for docker 18.05.0
Package-Manager: Portage-2.3.36, Repoman-2.3.9
-rw-r--r--app-emulation/containerd/Manifest1
-rw-r--r--app-emulation/containerd/containerd-1.0.3_p20180223.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-emulation/containerd/Manifest b/app-emulation/containerd/Manifest
index f37c9bc2815f..39c3905c7b6a 100644
--- a/app-emulation/containerd/Manifest
+++ b/app-emulation/containerd/Manifest
@@ -1,3 +1,4 @@
DIST containerd-1.0.1.tar.gz 3766659 BLAKE2B 36c96a9e3cba22578daff31e46d9a876095e9de7e20e1e84a41076d9936f30a5681e41187a90f9a01884fd02086fa3c9a6ee29c8261401988a1cfa2026952431 SHA512 351c0e298ba6a9a14df2f367df23049a8a833eb18238e3d41cf0066feb2e0b8f2aa7b25fb4484a1b5c95bccf5cba3a8076a5bcfe25602b5368e7cf2a20872160
DIST containerd-1.0.3.tar.gz 3776722 BLAKE2B 31e9f2e56b23d09341e4cdd546198233517893e1596c9aefd084044f04b1e1831219343142eef09159a5698720fa307e3ec1dbb86304e071a9d8e1f8f8436519 SHA512 31aa462f357a77434033ae4bff2e453ce849cbd91e4981383be3c7cdea77ea1f57081c4f8121d15c151145defc2003348fe23b26a11568b38780fa2fb9cf114c
+DIST containerd-1.0.3_p20180223.tar.gz 5029605 BLAKE2B bd3f74ad70c7de9a73397e401e49459d1724376434265dddddd51cf09ccd940ecf63dacf0dc7270175d99e473c224ab238c0c29b0e03d41ddf9295ef37b90586 SHA512 a4999c1eb16c40178e3ee63f4001d4826d2dc6f353f768fbfdc6b7e0962d0f4431014fdedc712f36aee1e05554fecf1917ac48c1e25818b6c80a423ed7edddd9
DIST containerd-1.1.0.tar.gz 5095823 BLAKE2B 1eca83add164ed79abc58bfe424da9f34b54d247ad147ec0f4ae20154cabefe147fe9b03ce2eab04c88c240f00995eec5b0f24c0e064640738517b81e3e7aa3d SHA512 34e687c6ef270370160465ee9b8fe6b59780543907917b668db7867da67fd47c8465f57ba4268387f776d0f392f8dad533c206d6577bab36480aff4392775d42
diff --git a/app-emulation/containerd/containerd-1.0.3_p20180223.ebuild b/app-emulation/containerd/containerd-1.0.3_p20180223.ebuild
new file mode 100644
index 000000000000..9a8002153e05
--- /dev/null
+++ b/app-emulation/containerd/containerd-1.0.3_p20180223.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/containerd/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_rc/-rc.}"
+ EGIT_COMMIT="v${MY_PV}"
+ CONTAINERD_COMMIT="4ac4fd0b6a268fe6f38b2b2e32e40daa7e424fac"
+ SRC_URI="https://${EGO_PN}/archive/${CONTAINERD_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+btrfs hardened"
+
+DEPEND="btrfs? ( sys-fs/btrfs-progs )"
+RDEPEND="|| ( >=app-emulation/docker-runc-1.0.0_rc4
+ >=app-emulation/runc-1.0.0_rc4 )
+ sys-libs/libseccomp"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ if [[ ${PV} != *9999* ]]; then
+ sed -i -e "s/git describe --match.*$/echo ${PV})/"\
+ -e "s/git rev-parse HEAD.*$/echo $CONTAINERD_COMMIT)/"\
+ -e "s/-s -w//" \
+ Makefile || die
+ fi
+}
+
+src_compile() {
+ local options=( $(usex btrfs "" "no_btrfs") )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake BUILDTAGS="${options[@]}"
+}
+
+src_install() {
+ dobin bin/containerd{-shim,-stress,} bin/ctr
+}