summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2017-08-20 13:24:05 +0100
committerIan Whyman <thev00d00@gentoo.org>2017-08-20 13:24:05 +0100
commit5ba4a469022dd7f5a0ddb9cc7cb39f05e21db3cc (patch)
tree35ef5560b10add786bc48d147dd8c3b1f01df013
parentdev-haskell/hexpat: bump up to 0.20.13 (diff)
downloadgentoo-5ba4a469022dd7f5a0ddb9cc7cb39f05e21db3cc.tar.gz
gentoo-5ba4a469022dd7f5a0ddb9cc7cb39f05e21db3cc.tar.bz2
gentoo-5ba4a469022dd7f5a0ddb9cc7cb39f05e21db3cc.zip
net-libs/libupnp: Version bump
Slot manually as they have removed it upstream Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--net-libs/libupnp/Manifest1
-rw-r--r--net-libs/libupnp/libupnp-1.8.2.ebuild70
-rw-r--r--net-libs/libupnp/metadata.xml4
3 files changed, 74 insertions, 1 deletions
diff --git a/net-libs/libupnp/Manifest b/net-libs/libupnp/Manifest
index 1de712d79f1c..7f605e1fa02f 100644
--- a/net-libs/libupnp/Manifest
+++ b/net-libs/libupnp/Manifest
@@ -1,3 +1,4 @@
DIST libupnp-1.6.21.tar.bz2 1245353 SHA256 af3f3c0846a1d75baeadae4aa5a2bda427567e2a1fb4559bf73ccff0a4f9a39b SHA512 65a2989497b941dfa1f7ac09fe44267de4a5231af25a304f0f6e754c7cbb578bdcb3c500188b5ebfbff9f579099db7501817d45e1724ef8e384d6d918bcdcdeb WHIRLPOOL b4869189054ac00d57394e0919ad2f672af64f2c2b0ecc676c2b3fc4a3c22caa25ac38b57bbb5cf1ef12a5857b4cdfd450c6bd5955a5eacaf8bdf95a058c9dab
DIST libupnp-1.6.22.tar.bz2 1242211 SHA256 0bdfacb7fa8d99b78343b550800ff193264f92c66ef67852f87f042fd1a1ebbc SHA512 abf7265155fb819e971e27dd25fd3f8143c04d6373b1b4a2769de9fadbbd3a012758acda866511a443f7e159b66068d9f7f99072c509a8fa06bcfe1275bdd9af WHIRLPOOL e3bfd207adff942d1a60337fb5ff00d2e4a4d52073724fb19415f14aa2def746706d863360779b00d842756ea6d809d5cf2f3cde910a3863398cbcfe49957bec
DIST libupnp-1.8.1.tar.gz 1363979 SHA256 0569e6afd979baa4e533312cb682394cea5b2638b8b412623e28943103593ea0 SHA512 7dd90f0c0332e7171d96a37a50223e18d5325ac1dd8dbe04fadac4655ad7c4d8443c52f904aaa35d3f12d2abd9ee2690ba990d0a93b15cbebb4d3de35d25ffe4 WHIRLPOOL 184e8844fab6a7a04d902d77c9b28141cdb15e4026b1b45105aabcf7616c2f6bbffa81fe14a1e6ddcd3f6494d9505f8f2cf190bf00fa341ca7192668e46e732d
+DIST libupnp-1.8.2.tar.gz 1379953 SHA256 438ad86bfd933cb1e9be1c41bf3bd69f049daba11d71bbb5d715336e00106cb4 SHA512 026f2568a1ffa56a3a0ebc823b126dceabb7e821acb6db52fbca02c4c02febd5508cb644cd2ac51f65397c3248a22340b3673069951e97dcdd22d4cc321d4511 WHIRLPOOL f1c1c18300ff597cf57837def8f35289aca7a85fa0e86d8307e3859c8eb55a011bf3c37b372aaebb73c79f95283d0f6964a555ba1353ab28f6c706bbf30fd8ad
diff --git a/net-libs/libupnp/libupnp-1.8.2.ebuild b/net-libs/libupnp/libupnp-1.8.2.ebuild
new file mode 100644
index 000000000000..4e724b79fc2f
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.8.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic autotools vcs-snapshot
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="https://github.com/mrjimenez/pupnp/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="1.8"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="blocking-tcp debug doc ipv6 +reuseaddr samples static-libs"
+
+DOCS="NEWS README.md ChangeLog"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.19-docs-install.patch
+ "${FILESDIR}"/${PN}-1.6.21-cflags.patch
+)
+
+src_prepare() {
+ default
+
+ # fix tests
+ chmod +x ixml/test/test_document.sh || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use x86-fbsd && append-flags -O1
+ # w/o docdir to avoid sandbox violations
+ econf $(use_enable debug) \
+ $(use_enable blocking-tcp blocking-tcp-connections) \
+ $(use_enable ipv6) \
+ $(use_enable reuseaddr) \
+ $(use_enable static-libs static) \
+ $(use_enable samples) \
+ $(use_with doc documentation "${EPREFIX}/usr/share/doc/${PF}")
+}
+
+src_install () {
+ default
+
+ use static-libs || prune_libtool_files
+
+ # Slot samples
+ if $(use samples); then
+ for bin in combo ctrlpt device ; do
+ newbin "upnp/sample/.libs/tv_$bin" "tv_$bin-${SLOT}"
+ done
+ fi
+
+ # Slot includes
+ cd "${D}/usr/include" || die
+ mv upnp "upnp-${SLOT}" || die
+
+ # Slot pkgconfig
+ cd "${D}/usr/$(get_libdir)/pkgconfig" || die
+ mv libupnp.pc "libupnp-${SLOT}.pc" || die
+ sed -i "s#/upnp#/upnp-${SLOT}#" "libupnp-${SLOT}.pc" || die
+
+ # Slot symlinks
+ cd "${D}/usr/$(get_libdir)" || die
+ mv libupnp.so "libupnp-${SLOT}.so" || die
+ mv libixml.so "libixml-${SLOT}.so" || die
+}
diff --git a/net-libs/libupnp/metadata.xml b/net-libs/libupnp/metadata.xml
index 4c6479b76fb7..53c42dd90258 100644
--- a/net-libs/libupnp/metadata.xml
+++ b/net-libs/libupnp/metadata.xml
@@ -14,6 +14,8 @@
<remote-id type="github">mrjimenez/pupnp</remote-id>
</upstream>
<use>
- <flag name="reuseaddr">Allow clean restarts by binding the socket with SO_REUSEADDR.</flag>
+ <flag name="reuseaddr">Allow clean restarts by binding the socket with SO_REUSEADDR.</flag>
+ <flag name="blocking-tcp">Do not use async socket calls.</flag>
+ <flag name="samples">Install sample applications.</flag>
</use>
</pkgmetadata>