summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-07-13 15:06:50 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-07-13 15:07:09 -0400
commit5cb31a34447ba8c29a6dbf4061b702bb904493f2 (patch)
treea8ec7775c908afee50120a3b2b6f5baea30b3b65
parentsys-cluster/drbd-utils: bug #548800, support IPv6 addresses in init. (diff)
downloadgentoo-5cb31a34447ba8c29a6dbf4061b702bb904493f2.tar.gz
gentoo-5cb31a34447ba8c29a6dbf4061b702bb904493f2.tar.bz2
gentoo-5cb31a34447ba8c29a6dbf4061b702bb904493f2.zip
net-analyzer/ike-scan: add libressl support
Package-Manager: portage-2.2.28
-rw-r--r--net-analyzer/ike-scan/ike-scan-1.9-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-analyzer/ike-scan/ike-scan-1.9-r2.ebuild b/net-analyzer/ike-scan/ike-scan-1.9-r2.ebuild
new file mode 100644
index 000000000000..143c316977c5
--- /dev/null
+++ b/net-analyzer/ike-scan/ike-scan-1.9-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A utility for finding, fingerprinting and testing IKE VPN servers"
+HOMEPAGE="http://www.nta-monitor.com/ike-scan/"
+SRC_URI="http://www.nta-monitor.com/ike-scan/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="libressl ssl"
+
+DEPEND="ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+)"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Fix buffer overflow, bug #277556
+ sed \
+ -e "/MAXLINE/s:255:511:g" \
+ -i ike-scan.h || die
+}
+
+src_configure() {
+ # --disable-lookup prevents ike-scan from phoning home
+ # for more information, please see bug 157507
+ econf $(use_with ssl openssl) --disable-lookup
+}
+
+src_install() {
+ default
+ dodoc udp-backoff-fingerprinting-paper.txt
+}