summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-12 09:56:40 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-12 09:56:54 +0200
commit5ceffb7d9b71aac7eed92ca0ee9db3a457165827 (patch)
tree85686970d8e2f55d452efefbe1f97aab6b178dbc
parentmedia-video/x264-encoder: remove old. (diff)
downloadgentoo-5ceffb7d9b71aac7eed92ca0ee9db3a457165827.tar.gz
gentoo-5ceffb7d9b71aac7eed92ca0ee9db3a457165827.tar.bz2
gentoo-5ceffb7d9b71aac7eed92ca0ee9db3a457165827.zip
dev-ml/cmdliner: bump to 0.9.8
Package-Manager: portage-2.2.23
-rw-r--r--dev-ml/cmdliner/Manifest1
-rw-r--r--dev-ml/cmdliner/cmdliner-0.9.8.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/cmdliner/Manifest b/dev-ml/cmdliner/Manifest
index 1dc6fe4b6bdb..9ca91d58954d 100644
--- a/dev-ml/cmdliner/Manifest
+++ b/dev-ml/cmdliner/Manifest
@@ -1 +1,2 @@
DIST cmdliner-0.9.7.tbz 50343 SHA256 9c19893cffb5d3c3469ee0cce85e3eeeba17d309b33b9ace31aba06f68f0bf7a SHA512 ea1ee186f6072dc836e23a7fcc0756d016c61d4d34ef2416842d1e6e73707b2bbd6aaccd8f57472560dbeab75d3d26159ad8276813882726a11e4530dc6f45e6 WHIRLPOOL 79acdf4807cc5befad01fa1f22a214bc2c6a66dbba4b2b2c041ba72c0b2982d7ca61c632766bfe498987f61d6636a818fae1c96df1bf02e87073c9247b6babf0
+DIST cmdliner-0.9.8.tbz 53249 SHA256 7dfaafdd88ec9d96abf8ded4c0ea7111948194400220a56e4bb44a1edfa4bd41 SHA512 6c71c360eaba7f7127e422a71a00a830a086f1d6750897bea0ebc1cc10f8fdaf9e9532d354abd84dbc6c5fcc1878f19d3f424fd9335e7226b625b63b51c89cab WHIRLPOOL 25739c09f78cc8ade6d0e5805f48eb14a6c42f0891832747caef44fc6135c81feaa0055b2874256bde2270753106c60accd50c24771333c2cb16913d9bd38c3d
diff --git a/dev-ml/cmdliner/cmdliner-0.9.8.ebuild b/dev-ml/cmdliner/cmdliner-0.9.8.ebuild
new file mode 100644
index 000000000000..87faba390088
--- /dev/null
+++ b/dev-ml/cmdliner/cmdliner-0.9.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Declarative definition of command line interfaces for OCaml"
+HOMEPAGE="http://erratique.ch/software/cmdliner"
+SRC_URI="http://erratique.ch/software/${PN}/releases/${P}.tbz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-4:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ocaml pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ || die
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ local nativelibs=""
+ use ocamlopt && nativelibs="$(echo _build/src/cmdliner.cm{x,xa,xs} _build/src/cmdliner.a)"
+ ocamlfind install cmdliner _build/pkg/META \
+ _build/src/cmdliner.mli _build/src/cmdliner.cm{a,i} ${nativelibs} || die
+ dodoc README.md TODO.md CHANGES.md
+ use doc && dohtml -r doc/
+}