summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2018-06-25 07:02:08 -0500
committerBen Kohler <bkohler@gentoo.org>2018-06-25 07:02:08 -0500
commit5d6f476bc91ef4dd8d8d9561ab41ab8a55744398 (patch)
tree948f50d0b6d2c9bd5381d616b6d35fa4b39a8784
parentx11-misc/xbatt: Migrate to eapi7-ver eclass (diff)
downloadgentoo-5d6f476bc91ef4dd8d8d9561ab41ab8a55744398.tar.gz
gentoo-5d6f476bc91ef4dd8d8d9561ab41ab8a55744398.tar.bz2
gentoo-5d6f476bc91ef4dd8d8d9561ab41ab8a55744398.zip
app-admin/ps_mem: new package
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--app-admin/ps_mem/Manifest1
-rw-r--r--app-admin/ps_mem/metadata.xml8
-rw-r--r--app-admin/ps_mem/ps_mem-3.12.ebuild29
3 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/ps_mem/Manifest b/app-admin/ps_mem/Manifest
new file mode 100644
index 000000000000..dc7acbdeb15b
--- /dev/null
+++ b/app-admin/ps_mem/Manifest
@@ -0,0 +1 @@
+DIST v3.12.tar.gz 18074 BLAKE2B 98861120b09b3a25b29b5b461d50d8e6a8a684fe76685a7b032f769896dba4b8fa6cd1b1de2644488bf8b4568b960f2949eac2a72a6225cd19682a9c08803baa SHA512 aeba7573b651ffbe6bb263ecc257716cc91219aac232694a628b0e5b1e45235149d7dcf68f6b9ee669bd005adf68693cd09f32e378934690270b0b72c38abea4
diff --git a/app-admin/ps_mem/metadata.xml b/app-admin/ps_mem/metadata.xml
new file mode 100644
index 000000000000..435234188908
--- /dev/null
+++ b/app-admin/ps_mem/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>bkohler@gentoo.org</email>
+ <name>Ben Kohler</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-admin/ps_mem/ps_mem-3.12.ebuild b/app-admin/ps_mem/ps_mem-3.12.ebuild
new file mode 100644
index 000000000000..42ed5888590d
--- /dev/null
+++ b/app-admin/ps_mem/ps_mem-3.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="A utility to report core memory usage per program"
+HOMEPAGE="https://github.com/pixelb/${PN}"
+SRC_URI="https://github.com/pixelb/${PN}/archive/v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${PYTHON_DEPS}"
+
+python_install() {
+ distutils-r1_python_install --install-scripts="/usr/sbin"
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman ${PN}.1
+}