summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-07-28 11:04:48 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-07-28 11:04:48 +0200
commit5de546935180d9193a077d671153ccf5881adeb5 (patch)
treeafbae58bc7d3719269f9bad26bb1d556ea0d4ff7
parentsys-apps/gptfdisk: Bump to version 1.0.3 (diff)
downloadgentoo-5de546935180d9193a077d671153ccf5881adeb5.tar.gz
gentoo-5de546935180d9193a077d671153ccf5881adeb5.tar.bz2
gentoo-5de546935180d9193a077d671153ccf5881adeb5.zip
x11-plugins/enigmail: Bump to version 1.9.8.1
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--x11-plugins/enigmail/Manifest1
-rw-r--r--x11-plugins/enigmail/enigmail-1.9.8.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-plugins/enigmail/Manifest b/x11-plugins/enigmail/Manifest
index 98f91534ea8f..2f5963ebfb7a 100644
--- a/x11-plugins/enigmail/Manifest
+++ b/x11-plugins/enigmail/Manifest
@@ -1,2 +1,3 @@
DIST enigmail-1.9.6.1.tar.gz 1745021 SHA256 3874331e981aed864443d3c965d856e003fd84f73e5a89fd5004ced9dc29b96f SHA512 e6ab69734a39a4953e0167e07b06f0d5c83fb42956515392319a1cd9d665ca274f6a12b4141e2dfa373ef074f0526f3d7330a48d29d600fc38f724d26518ff84 WHIRLPOOL e89b0e5857564cc2f7ebf3ab46b110c6bbb1b16e7c0e045750119fd02e693b9bd9667c2932e7a65f9c8fb2c7c835ed048f6df2613d12b25d961894f47f67cf48
DIST enigmail-1.9.7.tar.gz 1745184 SHA256 176adbafee2f84ef6cd1cdbf53131a2a6a23d0cb26550357617c24a8ae5bd934 SHA512 f6f96f6267f1c9df0ca86fefcf7e0e2b10076f1cdb7d446b2a53710b780c14097ef05ba7f35b83e33aca9f2fca1ca4398c7524c1f5ce6cba39b6733db33eed31 WHIRLPOOL 8816b3404e6b6b3fa4ba3d01f97ba9841b3eb7b1d46d09570b756431b2810f35be26a54ab98769ec051cc0859c761090004ed10886150ec98082db10ba4642f5
+DIST enigmail-1.9.8.1.tar.gz 1776673 SHA256 4bcf2da00d96a67921b24dbec9f43930cba41112a2cd241b0952eb573c648a4d SHA512 af280040e96eb69529e723e52e65621e42743c974b0ed42598e73458004f0a59688da7257d2b556e95a56c4cad3ac48f527d4d9a7a54c9c92eaff132257e0cfd WHIRLPOOL 077c61b996c2ec45ecc3a037b61d167acda2ebdbde6536e2f2f2e180a064c9e540e09b48417454aa48f02af5f4c58c88f4ba456e6c5f113cfe474f2b82798ac0
diff --git a/x11-plugins/enigmail/enigmail-1.9.8.1.ebuild b/x11-plugins/enigmail/enigmail-1.9.8.1.ebuild
new file mode 100644
index 000000000000..ff5e7f5079a3
--- /dev/null
+++ b/x11-plugins/enigmail/enigmail-1.9.8.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1
+
+DESCRIPTION="Mozilla extension to provide GPG support in mail clients"
+HOMEPAGE="http://www.enigmail.net/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+SLOT="0"
+LICENSE="MPL-2.0 GPL-3"
+IUSE=""
+SRC_URI="http://www.enigmail.net/download/source/${P}.tar.gz"
+
+RDEPEND="|| (
+ ( >=app-crypt/gnupg-2.0
+ || (
+ app-crypt/pinentry[gtk(-)]
+ app-crypt/pinentry[qt4(-)]
+ app-crypt/pinentry[qt5(-)]
+ )
+ )
+ =app-crypt/gnupg-1.4*
+ )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ app-arch/zip
+ dev-lang/perl
+ "
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake ipc public ui package lang
+ emake xpi
+
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r build/dist/{chrome,components,defaults,modules,wrappers,chrome.manifest,install.rdf}
+}
+
+pkg_postinst() {
+ local peimpl=$(eselect --brief --colour=no pinentry show)
+ case "${peimpl}" in
+ *gtk*|*qt*) ;;
+ *) ewarn "The pinentry front-end currently selected is not one supported by thunderbird."
+ ewarn "You may be prompted for your password in an inaccessible shell!!"
+ ewarn "Please use 'eselect pinentry' to select either the gtk or qt front-end"
+ ;;
+ esac
+}