summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-07-09 02:28:07 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-07-09 02:33:16 +0200
commit5e5e3d0670568e4ad8d047a773195483287559bb (patch)
tree743e06bbacec910b64eab827bfc52322acd0c33f
parentsys-boot/grub: bump to 2.04 (diff)
downloadgentoo-5e5e3d0670568e4ad8d047a773195483287559bb.tar.gz
gentoo-5e5e3d0670568e4ad8d047a773195483287559bb.tar.bz2
gentoo-5e5e3d0670568e4ad8d047a773195483287559bb.zip
net-libs/zeromq: bump to v4.3.2
Bug: https://bugs.gentoo.org/689426 Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--net-libs/zeromq/Manifest1
-rw-r--r--net-libs/zeromq/zeromq-4.3.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/net-libs/zeromq/Manifest b/net-libs/zeromq/Manifest
index ce8609ce892a..9bf693247066 100644
--- a/net-libs/zeromq/Manifest
+++ b/net-libs/zeromq/Manifest
@@ -1,3 +1,4 @@
DIST zeromq-2.2.0.tar.gz 1899104 BLAKE2B 1c02629e33151db11c529d538ce519dae7f3426ee13f8a2b840960779cd7514f7cc3257983704f2c392a00ad62f4a955bc33fcbdadb8bada3858753a1790ab41 SHA512 fb3cf421b2dc48c31956b3e3ee4ab6ebc743deec3bf626c2238a1996c8c51be87260bd6aa662793a1f0c34dcda9b3146763777bb162dfad6fec4ca7acc403b2e
DIST zeromq-3.2.5.tar.gz 2082960 BLAKE2B 88fe3b3206f0e59acb3cf370964c9e40df2dceb5e40aef85ae8cd8fedef4c655fd2698a7f81431e34550b5156814a75c0b1a738393e7c44acbfefe96acc4c4bc SHA512 3682204e5a47824d149968e62fbf9768134370e4f7debbbf8f2bfa24bdd0a781e50c4a9b4231af8a0c4bab61839169100525a91472448ef180a9672342e10a3f
DIST zeromq-4.3.1.tar.gz 1490122 BLAKE2B 95d0a1359e85a3868ae0b1cd4f711d9715ddc07d21fbb7799c6beaa269aa77fb68e087898033f8a515be974a799c1ee2f2afba1f50b1bc806255750b95990367 SHA512 b80388a3703993425cdd73054139a8e2895aedb9992ea68d6eadb4ea39b9af576ea14f306dfb432e4c24535feb6b293f82fac5679b655d258f0f921f2b71e772
+DIST zeromq-4.3.2.tar.gz 1697442 BLAKE2B 70a1f6da357987c32483050fcf86cb81a1fb0b65a527f6900f54eea8958c6aa6024af04067114663824d42305f507cba67e03c7aaab7e23e4f6332d4368613eb SHA512 b6251641e884181db9e6b0b705cced7ea4038d404bdae812ff47bdd0eed12510b6af6846b85cb96898e253ccbac71eca7fe588673300ddb9c3109c973250c8e4
diff --git a/net-libs/zeromq/zeromq-4.3.2.ebuild b/net-libs/zeromq/zeromq-4.3.2.ebuild
new file mode 100644
index 000000000000..199b9b2c57c2
--- /dev/null
+++ b/net-libs/zeromq/zeromq-4.3.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+DESCRIPTION="A brokerless kernel"
+HOMEPAGE="http://www.zeromq.org/"
+SRC_URI="https://github.com/zeromq/libzmq/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/5"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc drafts pgm +sodium static-libs test unwind elibc_Darwin"
+
+RDEPEND="
+ !elibc_Darwin? ( unwind? ( sys-libs/libunwind ) )
+ sodium? ( dev-libs/libsodium:= )
+ pgm? ( =net-libs/openpgm-5.2.122 )"
+DEPEND="${RDEPEND}
+ !elibc_Darwin? ( sys-apps/util-linux )
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ )
+ pgm? ( virtual/pkgconfig )"
+
+src_prepare() {
+ sed \
+ -e '/libzmq_werror=/s:yes:no:g' \
+ -i configure.ac || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable drafts)
+ $(use_enable static-libs static)
+ $(use_enable unwind libunwind)
+ $(use_with sodium libsodium)
+ $(use_with pgm)
+ $(use_with doc docs)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # Restricting to one job because multiple tests are using the same port.
+ # Upstream knows the problem and says it doesn't support parallel test
+ # execution, see ${S}/INSTALL.
+ emake -j1 check
+}
+
+src_install() {
+ default
+ find "${ED%/}"/usr/lib* -name '*.la' -delete || die
+}