summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-12-04 15:21:37 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-12-04 15:35:48 +0100
commit5f69ee78e788320e67503bb2e7ef0cc6fbc7621c (patch)
tree9c7cfd78008b569e34d575a9b9216a8c007adb3b
parentdev-lua/luajson: drop old version (diff)
downloadgentoo-5f69ee78e788320e67503bb2e7ef0cc6fbc7621c.tar.gz
gentoo-5f69ee78e788320e67503bb2e7ef0cc6fbc7621c.tar.bz2
gentoo-5f69ee78e788320e67503bb2e7ef0cc6fbc7621c.zip
dev-lua/luajson: fix prefix
Closes: https://bugs.gentoo.org/501166 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/luajson/luajson-1.3.3-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-lua/luajson/luajson-1.3.3-r1.ebuild b/dev-lua/luajson/luajson-1.3.3-r1.ebuild
new file mode 100644
index 000000000000..48f67efbcaae
--- /dev/null
+++ b/dev-lua/luajson/luajson-1.3.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="JSON Parser/Constructor for Lua"
+HOMEPAGE="https://www.eharning.us/wiki/luajson/"
+SRC_URI="https://github.com/harningt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~mips ppc ppc64 sparc x86"
+IUSE="test"
+
+RDEPEND="|| ( >=dev-lang/lua-5.1:0 dev-lang/luajit:2 )
+ dev-lua/lpeg"
+DEPEND="test? ( dev-lua/luafilesystem )"
+
+# lunit not in the tree yet
+RESTRICT="test"
+
+# nothing to compile
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ dodoc README docs/ReleaseNotes-${PV}.txt docs/LuaJSON.txt
+}