summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-03-25 12:12:38 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-03-25 12:12:54 +1100
commit5fd133dd5b792bfb732bec9f3e2f83208689360c (patch)
tree66e05582526f070508abb1a78515ad8dc4a896d6
parentkde-apps/krfb: backport patch from upstream solving frame update issue (diff)
downloadgentoo-5fd133dd5b792bfb732bec9f3e2f83208689360c.tar.gz
gentoo-5fd133dd5b792bfb732bec9f3e2f83208689360c.tar.bz2
gentoo-5fd133dd5b792bfb732bec9f3e2f83208689360c.zip
kde-apps/kdepim-runtime: backport patch from upstream solving build failure
Gentoo-bug: 613394 Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--kde-apps/kdepim-runtime/files/kdepim-runtime-16.12.3-include.patch24
-rw-r--r--kde-apps/kdepim-runtime/kdepim-runtime-16.12.3-r1.ebuild2
2 files changed, 26 insertions, 0 deletions
diff --git a/kde-apps/kdepim-runtime/files/kdepim-runtime-16.12.3-include.patch b/kde-apps/kdepim-runtime/files/kdepim-runtime-16.12.3-include.patch
new file mode 100644
index 000000000000..abde97f9f614
--- /dev/null
+++ b/kde-apps/kdepim-runtime/files/kdepim-runtime-16.12.3-include.patch
@@ -0,0 +1,24 @@
+From bccc569b2c049e6eb1c43b45ba0e25bb39868913 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Sandro=20Knau=C3=9F?= <sknauss@kde.org>
+Date: Wed, 25 Jan 2017 23:35:22 +0100
+Subject: [PATCH] import QImage directly instead of usage via KContacts
+
+---
+ resources/openxchange/oxa/contactutils.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/resources/openxchange/oxa/contactutils.cpp b/resources/openxchange/oxa/contactutils.cpp
+index dea8188..06bb34b 100644
+--- a/resources/openxchange/oxa/contactutils.cpp
++++ b/resources/openxchange/oxa/contactutils.cpp
+@@ -28,6 +28,7 @@
+ #include <Akonadi/Contact/ContactGroupExpandJob>
+
+ #include <QtCore/QBuffer>
++#include <QtGui/QImage>
+ #include <QtXml/QDomElement>
+
+ using namespace OXA;
+--
+2.10.2
+
diff --git a/kde-apps/kdepim-runtime/kdepim-runtime-16.12.3-r1.ebuild b/kde-apps/kdepim-runtime/kdepim-runtime-16.12.3-r1.ebuild
index ea9c898e7f34..38c169b9c9ba 100644
--- a/kde-apps/kdepim-runtime/kdepim-runtime-16.12.3-r1.ebuild
+++ b/kde-apps/kdepim-runtime/kdepim-runtime-16.12.3-r1.ebuild
@@ -72,6 +72,8 @@ RDEPEND="${CDEPEND}
RESTRICT+=" test"
+PATCHES=( "${FILESDIR}/${P}-include.patch" )
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package google KF5GAPI)