summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Korepanov <kaikaikai@yandex.ru>2017-12-09 17:09:40 +0000
committerAnthony G. Basile <blueness@gentoo.org>2017-12-09 21:25:45 -0500
commit61045949abc0ec1e9691eac416825201bc649d8a (patch)
treed279fea6a514e7b024b148c6a6f3b4e5df7ba5a4
parentdev-cpp/websocketpp: keyword ~arm64 (diff)
downloadgentoo-61045949abc0ec1e9691eac416825201bc649d8a.tar.gz
gentoo-61045949abc0ec1e9691eac416825201bc649d8a.tar.bz2
gentoo-61045949abc0ec1e9691eac416825201bc649d8a.zip
net-vpn/i2pd: make compiler version check right
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--net-vpn/i2pd/i2pd-2.15.0.ebuild18
-rw-r--r--net-vpn/i2pd/i2pd-2.16.0.ebuild18
-rw-r--r--net-vpn/i2pd/i2pd-2.17.0.ebuild18
3 files changed, 39 insertions, 15 deletions
diff --git a/net-vpn/i2pd/i2pd-2.15.0.ebuild b/net-vpn/i2pd/i2pd-2.15.0.ebuild
index a5cedbfaa37f..2c29b4139a6e 100644
--- a/net-vpn/i2pd/i2pd-2.15.0.ebuild
+++ b/net-vpn/i2pd/i2pd-2.15.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils systemd user cmake-utils
+inherit eutils systemd user cmake-utils versionator toolchain-funcs
DESCRIPTION="A C++ daemon for accessing the I2P anonymous network"
HOMEPAGE="https://github.com/PurpleI2P/i2pd"
@@ -26,10 +26,9 @@ DEPEND="${RDEPEND}
libressl? ( dev-libs/libressl:0[static-libs]
>=dev-libs/boost-1.65 )
sys-libs/zlib[static-libs]
- upnp? ( net-libs/miniupnpc[static-libs] ) )
- websocket? ( dev-cpp/websocketpp )
- i2p-hardening? ( >=sys-devel/gcc-4.7 )
- || ( >=sys-devel/gcc-4.7 >=sys-devel/clang-3.3 )"
+ upnp? ( net-libs/miniupnpc[static-libs] )
+ )
+ websocket? ( dev-cpp/websocketpp )"
I2PD_USER=i2pd
I2PD_GROUP=i2pd
@@ -40,6 +39,15 @@ DOCS=( README.md contrib/i2pd.conf contrib/tunnels.conf )
PATCHES=( "${FILESDIR}/${PN}-2.14.0-fix_installed_components.patch" )
+pkg_pretend() {
+ if tc-is-gcc && ! version_is_at_least "4.7" "$(gcc-version)"; then
+ die "At least gcc 4.7 is required"
+ fi
+ if use i2p-hardening && ! tc-is-gcc; then
+ die "i2p-hardening requires gcc"
+ fi
+}
+
src_configure() {
mycmakeargs=(
-DWITH_AESNI=$(usex cpu_flags_x86_aes ON OFF)
diff --git a/net-vpn/i2pd/i2pd-2.16.0.ebuild b/net-vpn/i2pd/i2pd-2.16.0.ebuild
index a5cedbfaa37f..2c29b4139a6e 100644
--- a/net-vpn/i2pd/i2pd-2.16.0.ebuild
+++ b/net-vpn/i2pd/i2pd-2.16.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils systemd user cmake-utils
+inherit eutils systemd user cmake-utils versionator toolchain-funcs
DESCRIPTION="A C++ daemon for accessing the I2P anonymous network"
HOMEPAGE="https://github.com/PurpleI2P/i2pd"
@@ -26,10 +26,9 @@ DEPEND="${RDEPEND}
libressl? ( dev-libs/libressl:0[static-libs]
>=dev-libs/boost-1.65 )
sys-libs/zlib[static-libs]
- upnp? ( net-libs/miniupnpc[static-libs] ) )
- websocket? ( dev-cpp/websocketpp )
- i2p-hardening? ( >=sys-devel/gcc-4.7 )
- || ( >=sys-devel/gcc-4.7 >=sys-devel/clang-3.3 )"
+ upnp? ( net-libs/miniupnpc[static-libs] )
+ )
+ websocket? ( dev-cpp/websocketpp )"
I2PD_USER=i2pd
I2PD_GROUP=i2pd
@@ -40,6 +39,15 @@ DOCS=( README.md contrib/i2pd.conf contrib/tunnels.conf )
PATCHES=( "${FILESDIR}/${PN}-2.14.0-fix_installed_components.patch" )
+pkg_pretend() {
+ if tc-is-gcc && ! version_is_at_least "4.7" "$(gcc-version)"; then
+ die "At least gcc 4.7 is required"
+ fi
+ if use i2p-hardening && ! tc-is-gcc; then
+ die "i2p-hardening requires gcc"
+ fi
+}
+
src_configure() {
mycmakeargs=(
-DWITH_AESNI=$(usex cpu_flags_x86_aes ON OFF)
diff --git a/net-vpn/i2pd/i2pd-2.17.0.ebuild b/net-vpn/i2pd/i2pd-2.17.0.ebuild
index a5cedbfaa37f..2c29b4139a6e 100644
--- a/net-vpn/i2pd/i2pd-2.17.0.ebuild
+++ b/net-vpn/i2pd/i2pd-2.17.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils systemd user cmake-utils
+inherit eutils systemd user cmake-utils versionator toolchain-funcs
DESCRIPTION="A C++ daemon for accessing the I2P anonymous network"
HOMEPAGE="https://github.com/PurpleI2P/i2pd"
@@ -26,10 +26,9 @@ DEPEND="${RDEPEND}
libressl? ( dev-libs/libressl:0[static-libs]
>=dev-libs/boost-1.65 )
sys-libs/zlib[static-libs]
- upnp? ( net-libs/miniupnpc[static-libs] ) )
- websocket? ( dev-cpp/websocketpp )
- i2p-hardening? ( >=sys-devel/gcc-4.7 )
- || ( >=sys-devel/gcc-4.7 >=sys-devel/clang-3.3 )"
+ upnp? ( net-libs/miniupnpc[static-libs] )
+ )
+ websocket? ( dev-cpp/websocketpp )"
I2PD_USER=i2pd
I2PD_GROUP=i2pd
@@ -40,6 +39,15 @@ DOCS=( README.md contrib/i2pd.conf contrib/tunnels.conf )
PATCHES=( "${FILESDIR}/${PN}-2.14.0-fix_installed_components.patch" )
+pkg_pretend() {
+ if tc-is-gcc && ! version_is_at_least "4.7" "$(gcc-version)"; then
+ die "At least gcc 4.7 is required"
+ fi
+ if use i2p-hardening && ! tc-is-gcc; then
+ die "i2p-hardening requires gcc"
+ fi
+}
+
src_configure() {
mycmakeargs=(
-DWITH_AESNI=$(usex cpu_flags_x86_aes ON OFF)