summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-13 19:56:02 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-13 19:59:22 -0500
commit615570f30d1d97a41f19994dbe1d5f67fcdae9d0 (patch)
treedcbeb0df040464b11411754aa83d280586704dad
parentmedia-sound/pulseeffects: 4.5.9 stable amd64 (diff)
downloadgentoo-615570f30d1d97a41f19994dbe1d5f67fcdae9d0.tar.gz
gentoo-615570f30d1d97a41f19994dbe1d5f67fcdae9d0.tar.bz2
gentoo-615570f30d1d97a41f19994dbe1d5f67fcdae9d0.zip
app-admin/augeas: 1.12.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/augeas/Manifest1
-rw-r--r--app-admin/augeas/augeas-1.12.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-admin/augeas/Manifest b/app-admin/augeas/Manifest
index 3cb9ad7a3fe3..dc5285fc8e54 100644
--- a/app-admin/augeas/Manifest
+++ b/app-admin/augeas/Manifest
@@ -1,2 +1,3 @@
DIST augeas-1.10.1.tar.gz 2289207 BLAKE2B 6e3cf750c4d3faf7dc472ec7bfe3c46f5babca294d2bd5169cca419c2f93e21bdd656bbc44b30ab66c00fb793df1aa045f60c1260963901773c334b9019eff0b SHA512 382e8ef6a5bd3d12d7d2e0d2987f39c04ff7df3f07cd68aa732bf266b89d5d59a85be63921a7ff70f9219dbc6bb8547f80528242caa9417e08a008d1721cb1d2
DIST augeas-1.11.0.tar.gz 2393675 BLAKE2B e7c50715fee892b47843f9be4ec9e88937c0ce10544b3e212d9c32a6151bbc36550d711ebec9db2a691e91cc6a2cd93696d807b440ab57a678ca6680426a4b03 SHA512 1b67bb7fcd9b560d3fe4a5c753d5e778db73caaab6e50367afd123eec107b65b73096913ac7d5170e85f5b63ff3522b2a6932b130e207ab22560dfc6e267b8a1
+DIST augeas-1.12.0.tar.gz 2429279 BLAKE2B cd90203fec1a81b114d95bb50e168b852923136f34c83974d3427cbedd4eb0d335d3952057507b38ded5c7011be2b56725565ea106cb32a0ca43b7c81250b29e SHA512 4f61d4abbf338e915dfae212560d39792674bc757f05f500afa80c6170abc214ffb99cab2cf5bbd1c2338d11a6909e5fc3ff7112a2246fca69f7b39ac283da40
diff --git a/app-admin/augeas/augeas-1.12.0.ebuild b/app-admin/augeas/augeas-1.12.0.ebuild
new file mode 100644
index 000000000000..b40ea12be532
--- /dev/null
+++ b/app-admin/augeas/augeas-1.12.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A library for changing configuration files"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="http://download.augeas.net/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs test"
+
+RDEPEND="
+ dev-libs/libxml2
+ sys-libs/readline:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=app-doc/NaturalDocs-1.40
+ test? ( dev-lang/ruby )"
+
+PATCHES=(
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # selinux needs to implemented
+ econf \
+ --without-selinux \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ addpredict /usr/share/NaturalDocs/Config/Languages.txt
+ addpredict /usr/share/NaturalDocs/Config/Topics.txt
+ default
+}
+
+src_install() {
+ default
+ use static-libs || find "${D}" -name '*.la' -delete || die
+}