summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-07-06 22:22:04 +0100
committerJames Le Cuirot <chewi@gentoo.org>2021-07-06 22:22:04 +0100
commit62556ce989e0770378874e01d5986aa545d77e9e (patch)
treeef5793d466ec80aa268ec5e13a21b436e39689e3
parentmedia-sound/openmpt123: Bump to 0.5.10, drop old 0.5.9 (diff)
downloadgentoo-62556ce989e0770378874e01d5986aa545d77e9e.tar.gz
gentoo-62556ce989e0770378874e01d5986aa545d77e9e.tar.bz2
gentoo-62556ce989e0770378874e01d5986aa545d77e9e.zip
media-tv/dtv-scan-tables: Bump to 20210430 snapshot
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--media-tv/dtv-scan-tables/Manifest1
-rw-r--r--media-tv/dtv-scan-tables/dtv-scan-tables-0_p20210430.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/media-tv/dtv-scan-tables/Manifest b/media-tv/dtv-scan-tables/Manifest
index f2344e5f8348..5da33c88c82e 100644
--- a/media-tv/dtv-scan-tables/Manifest
+++ b/media-tv/dtv-scan-tables/Manifest
@@ -1,2 +1,3 @@
DIST dtv-scan-tables-2017-10-03-c1986d5148d8.tar.bz2 168709 BLAKE2B fb4a7ad5b6892a7e7eed1d57ebb49b1f4493076f6f744953d2d5c51c0e1cf7fdaf864ad050c578c2697f5b11d72c245b96ee369522cb58d38a1a2cef035099a7 SHA512 e2b0cf8f52b536be6a532b4a2896421a8150fdc19613e92c92d0c8275fcfd306cb091db32fa26f97bbec0a51ef4ba61b5f98e8c974280a3f6dd36b67a3bf4aad
DIST dtv-scan-tables-2019-09-22-f07bde777d4d.tar.bz2 270211 BLAKE2B 76d5250a8eb7e9ce5c83eb9486ea1b398f3565ed027863057f143ae15c196fa01489f17fa71082ac878f49dac653da8967673872cb3e298f99cd59376c82ee39 SHA512 806fadcfc767d09dc9b474af089c2fa68ccafd91e110b74dc47f3a2ea90ebb74f80633831a20a51578fce3fbd4556a23c6bca9f7139be7c3de8eff79d2ee321c
+DIST dtv-scan-tables-2021-04-30-4181e93a30ab.tar.bz2 272870 BLAKE2B b9672235ad2ed826205278ffd06ed793126f743fe2b0b8af4369c1cb24825662e579f9246a287df1d61efad7985e2e18d59097d359fe84626149464bfc253bc5 SHA512 c15c07937cabefad731f4b3f8b6e9f993e500f7c59b17ef5e5c46f9bb86f9cbdf748f7d875c363c641ed9f3333a03b5033cc7d0272e96323d36be944ea35379d
diff --git a/media-tv/dtv-scan-tables/dtv-scan-tables-0_p20210430.ebuild b/media-tv/dtv-scan-tables/dtv-scan-tables-0_p20210430.ebuild
new file mode 100644
index 000000000000..55e947d46ecc
--- /dev/null
+++ b/media-tv/dtv-scan-tables/dtv-scan-tables-0_p20210430.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV#9999} != ${PV} ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.linuxtv.org/dtv-scan-tables.git"
+else
+ COMMIT="4181e93a30ab"
+ SRC_URI="https://linuxtv.org/downloads/dtv-scan-tables/dtv-scan-tables-${PV:3:4}-${PV:7:2}-${PV:9:2}-${COMMIT}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+ S="${WORKDIR}/usr/share/dvb"
+fi
+
+DESCRIPTION="Digital TV scan tables in v3 and v5 format"
+HOMEPAGE="https://linuxtv.org/"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+
+BDEPEND=">=media-tv/v4l-utils-1.4[dvb(+)]"
+
+DOCS=( README )
+
+src_compile() {
+ emake dvbv3 dvbv5
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install install_v3
+ einstalldocs
+}