summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-19 11:51:10 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-19 11:54:27 +0200
commit62aba058c3b97f1cf87bb8fff15d4c1fa76a2836 (patch)
tree0897c8dd426e8ab20154657c5c417694c87dd4ea
parentdev-vcs/repo: Remove old (diff)
downloadgentoo-62aba058c3b97f1cf87bb8fff15d4c1fa76a2836.tar.gz
gentoo-62aba058c3b97f1cf87bb8fff15d4c1fa76a2836.tar.bz2
gentoo-62aba058c3b97f1cf87bb8fff15d4c1fa76a2836.zip
dev-vcs/subversion: Remove Python bindings and scripts
Closes: https://bugs.gentoo.org/725850 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-vcs/subversion/metadata.xml1
-rw-r--r--dev-vcs/subversion/subversion-1.13.0-r2.ebuild (renamed from dev-vcs/subversion/subversion-1.13.0-r1.ebuild)108
-rw-r--r--dev-vcs/subversion/subversion-1.14.0-r1.ebuild (renamed from dev-vcs/subversion/subversion-1.14.0.ebuild)106
3 files changed, 11 insertions, 204 deletions
diff --git a/dev-vcs/subversion/metadata.xml b/dev-vcs/subversion/metadata.xml
index b2b200e9148b..90882d9cd881 100644
--- a/dev-vcs/subversion/metadata.xml
+++ b/dev-vcs/subversion/metadata.xml
@@ -10,7 +10,6 @@
<name>Mikle Kolyada</name>
</maintainer>
<use>
- <flag name="ctypes-python">Build and install Ctypes Python bindings</flag>
<flag name="dso">Enable runtime module search</flag>
<flag name="extras">Install extra scripts (examples, tools, hooks)</flag>
<flag name="http">Enable http support using <pkg>net-libs/serf</pkg></flag>
diff --git a/dev-vcs/subversion/subversion-1.13.0-r1.ebuild b/dev-vcs/subversion/subversion-1.13.0-r2.ebuild
index a0276cada505..4d9e70f3d1a9 100644
--- a/dev-vcs/subversion/subversion-1.13.0-r1.ebuild
+++ b/dev-vcs/subversion/subversion-1.13.0-r2.ebuild
@@ -9,7 +9,7 @@ DISTUTILS_OPTIONAL=1
WANT_AUTOMAKE="none"
GENTOO_DEPEND_ON_PERL="no"
-inherit autotools bash-completion-r1 db-use depend.apache distutils-r1 flag-o-matic java-pkg-opt-2 libtool ltprune multilib perl-module ruby-single toolchain-funcs xdg-utils
+inherit autotools bash-completion-r1 db-use depend.apache flag-o-matic java-pkg-opt-2 libtool ltprune multilib perl-module python-any-r1 ruby-single toolchain-funcs xdg-utils
MY_P="${P/_/-}"
DESCRIPTION="Advanced version control system"
@@ -22,7 +22,7 @@ LICENSE="Subversion GPL-2"
SLOT="0"
[[ "${PV}" = *_rc* ]] || \
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="apache2 berkdb ctypes-python debug doc +dso extras gnome-keyring +http java kwallet nls perl python ruby sasl test vim-syntax"
+IUSE="apache2 berkdb debug doc +dso extras gnome-keyring +http java kwallet nls perl ruby sasl test vim-syntax"
RESTRICT="!test? ( test )"
COMMON_DEPEND="
@@ -36,7 +36,6 @@ COMMON_DEPEND="
sys-apps/file
sys-libs/zlib
berkdb? ( >=sys-libs/db-4.0.14:= )
- ctypes-python? ( ${PYTHON_DEPS} )
gnome-keyring? (
dev-libs/glib:2
app-crypt/libsecret
@@ -53,7 +52,6 @@ COMMON_DEPEND="
sys-apps/dbus
)
perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
ruby? ( ${RUBY_DEPS} )
sasl? ( dev-libs/cyrus-sasl )"
RDEPEND="${COMMON_DEPEND}
@@ -64,7 +62,6 @@ RDEPEND="${COMMON_DEPEND}
# Note: ctypesgen doesn't need PYTHON_USEDEP, it's used once
DEPEND="${COMMON_DEPEND}
!!<sys-apps/sandbox-1.6
- ctypes-python? ( dev-python/ctypesgen )
doc? ( app-doc/doxygen )
gnome-keyring? ( virtual/pkgconfig )
http? ( virtual/pkgconfig )
@@ -75,17 +72,11 @@ DEPEND="${COMMON_DEPEND}
)
nls? ( sys-devel/gettext )
perl? ( dev-lang/swig )
- python? ( dev-lang/swig )
ruby? ( dev-lang/swig )
test? ( ${PYTHON_DEPS} )"
REQUIRED_USE="
- ctypes-python? ( ${PYTHON_REQUIRED_USE} )
- python? ( ${PYTHON_REQUIRED_USE} )
- test? (
- ${PYTHON_REQUIRED_USE}
- !dso
- )"
+ test? ( !dso )"
want_apache
@@ -176,12 +167,6 @@ src_prepare() {
sed -e 's/\(libsvn_swig_py\)-\(1\.la\)/\1-$(EPYTHON)-\2/g' \
-i build-outputs.mk || die "sed failed"
- if use python ; then
- # XXX: make python_copy_sources accept path
- S=${S}/subversion/bindings/swig/python python_copy_sources
- rm -r "${S}"/subversion/bindings/swig/python || die
- fi
-
xdg_environment_reset
}
@@ -191,7 +176,7 @@ src_configure() {
$(use_with apache2 apache-libexecdir)
$(use_with apache2 apxs "${EPREFIX}"/usr/bin/apxs)
$(use_with berkdb berkeley-db "db.h:${EPREFIX}/usr/include/db${SVN_BDB_VERSION}::db-${SVN_BDB_VERSION}")
- $(use_with ctypes-python ctypesgen "${EPREFIX}/usr")
+ --without-ctypesgen
$(use_enable dso runtime-module-search)
$(use_with gnome-keyring)
$(use_enable java javahl)
@@ -209,7 +194,7 @@ src_configure() {
--enable-svnxx
)
- if use python || use perl || use ruby; then
+ if use perl || use ruby; then
myconf+=( --with-swig )
else
myconf+=( --without-swig )
@@ -253,56 +238,22 @@ src_configure() {
#myconf+=( --disable-disallowing-of-undefined-references )
# for build-time scripts
- if use ctypes-python || use python || use test; then
+ if use test; then
python_setup
fi
- if use python && [[ ${CHOST} == *-darwin* ]] ; then
- export ac_cv_python_link="$(tc-getCC) "'$(PYTHON_CFLAGS) -bundle -undefined dynamic_lookup $(PYTHON_LIBS)'
- export ac_cv_python_libs='$(PYTHON_CFLAGS) -bundle -undefined dynamic_lookup $(PYTHON_LIBS)'
- export ac_cv_python_compile="$(tc-getCC)"
- fi
-
# Remove when >=dev-libs/libutf8proc-2.5.0 is stable
# https://bugs.gentoo.org/721300
append-cppflags -I"${EPREFIX}"/usr/include/libutf8proc
- # allow overriding Python include directory
ac_cv_path_RUBY=$(usex ruby "${EPREFIX}/usr/bin/ruby${RB_VER}" "none") \
ac_cv_path_RDOC=$(usex ruby "${EPREFIX}/usr/bin/rdoc${RB_VER}" "none") \
- ac_cv_python_includes='-I$(PYTHON_INCLUDEDIR)' \
econf "${myconf[@]}"
}
src_compile() {
emake local-all
- if use ctypes-python ; then
- # pre-generate .py files
- use ctypes-python && emake ctypes-python
-
- pushd subversion/bindings/ctypes-python >/dev/null || die
- distutils-r1_src_compile
- popd >/dev/null || die
- fi
-
- if use python ; then
- swig_py_compile() {
- local p=subversion/bindings/swig/python
- rm -f ${p} || die
- ln -s "${BUILD_DIR}" ${p} || die
-
- python_export PYTHON_INCLUDEDIR
- emake swig-py \
- swig_pydir="$(python_get_sitedir)/libsvn" \
- swig_pydir_extra="$(python_get_sitedir)/svn"
- }
-
- # this will give us proper BUILD_DIR for symlinking
- BUILD_DIR=python \
- python_foreach_impl swig_py_compile
- fi
-
if use perl ; then
emake swig-pl
fi
@@ -331,26 +282,6 @@ src_compile() {
src_test() {
if has_version ~${CATEGORY}/${P} ; then
default
-
- if use ctypes-python ; then
- python_test() {
- "${PYTHON}" subversion/bindings/ctypes-python/test/run_all.py \
- || die "ctypes-python tests fail with ${EPYTHON}"
- }
-
- distutils-r1_src_test
- fi
-
- if use python ; then
- swig_py_test() {
- pushd "${BUILD_DIR}" >/dev/null || die
- "${PYTHON}" tests/run_all.py || die "swig-py tests fail with ${EPYTHON}"
- popd >/dev/null || die
- }
-
- BUILD_DIR=subversion/bindings/swig/python \
- python_foreach_impl swig_py_test
- fi
else
ewarn "The test suite shows errors when there is an older version of"
ewarn "${CATEGORY}/${PN} installed. Please install =${CATEGORY}/${P}*"
@@ -362,29 +293,6 @@ src_test() {
src_install() {
emake -j1 DESTDIR="${D}" local-install
- if use ctypes-python ; then
- pushd subversion/bindings/ctypes-python >/dev/null || die
- distutils-r1_src_install
- popd >/dev/null || die
- fi
-
- if use python ; then
- swig_py_install() {
- local p=subversion/bindings/swig/python
- rm -f ${p} || die
- ln -s "${BUILD_DIR}" ${p} || die
-
- emake \
- DESTDIR="${D}" \
- swig_pydir="$(python_get_sitedir)/libsvn" \
- swig_pydir_extra="$(python_get_sitedir)/svn" \
- install-swig-py
- }
-
- BUILD_DIR=python \
- python_foreach_impl swig_py_install
- fi
-
if use perl ; then
emake DESTDIR="${D}" INSTALLDIRS="vendor" install-swig-pl
perl_delete_localpod
@@ -453,10 +361,6 @@ src_install() {
rm -fr tools/client-side/svnmucc
rm -fr tools/server-side/{svn-populate-node-origins-index,svnauthz-validate}*
rm -fr tools/{buildbot,dev,diff,po}
-
- insinto /usr/share/${PN}
- find tools -name '*.py' -exec sed -i -e '1s:python:&2:' {} + || die
- doins -r tools
fi
if use doc ; then
diff --git a/dev-vcs/subversion/subversion-1.14.0.ebuild b/dev-vcs/subversion/subversion-1.14.0-r1.ebuild
index 7e77db66d8d0..99ace72543d6 100644
--- a/dev-vcs/subversion/subversion-1.14.0.ebuild
+++ b/dev-vcs/subversion/subversion-1.14.0-r1.ebuild
@@ -9,7 +9,7 @@ DISTUTILS_OPTIONAL=1
WANT_AUTOMAKE="none"
GENTOO_DEPEND_ON_PERL="no"
-inherit autotools bash-completion-r1 db-use depend.apache distutils-r1 flag-o-matic java-pkg-opt-2 libtool perl-module ruby-single toolchain-funcs xdg-utils
+inherit autotools bash-completion-r1 db-use depend.apache flag-o-matic java-pkg-opt-2 libtool perl-module python-any-r1 ruby-single toolchain-funcs xdg-utils
MY_P="${P/_/-}"
DESCRIPTION="Advanced version control system"
@@ -22,7 +22,7 @@ LICENSE="Subversion GPL-2"
SLOT="0"
[[ "${PV}" = *_rc* ]] || \
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="apache2 berkdb ctypes-python debug doc extras gnome-keyring java kwallet nls perl python ruby sasl test"
+IUSE="apache2 berkdb debug doc extras gnome-keyring java kwallet nls perl ruby sasl test"
RESTRICT="!test? ( test )"
COMMON_DEPEND="
@@ -37,7 +37,6 @@ COMMON_DEPEND="
sys-apps/file
sys-libs/zlib
berkdb? ( >=sys-libs/db-4.0.14:= )
- ctypes-python? ( ${PYTHON_DEPS} )
gnome-keyring? (
dev-libs/glib:2
app-crypt/libsecret
@@ -53,7 +52,6 @@ COMMON_DEPEND="
sys-apps/dbus
)
perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
ruby? ( ${RUBY_DEPS} )
sasl? ( dev-libs/cyrus-sasl )
"
@@ -75,7 +73,6 @@ RDEPEND="${COMMON_DEPEND}
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
!!<sys-apps/sandbox-1.6
- ctypes-python? ( dev-python/ctypesgen )
doc? ( app-doc/doxygen )
gnome-keyring? ( virtual/pkgconfig )
java? ( >=virtual/jdk-1.8 )
@@ -85,17 +82,10 @@ DEPEND="${COMMON_DEPEND}
)
nls? ( sys-devel/gettext )
perl? ( dev-lang/swig )
- python? ( dev-lang/swig )
ruby? ( dev-lang/swig )
test? ( ${PYTHON_DEPS} )
"
-REQUIRED_USE="
- ctypes-python? ( ${PYTHON_REQUIRED_USE} )
- python? ( ${PYTHON_REQUIRED_USE} )
- test? ( ${PYTHON_REQUIRED_USE} )
-"
-
want_apache
pkg_setup() {
@@ -178,12 +168,6 @@ src_prepare() {
sed -e 's/\(libsvn_swig_py\)-\(1\.la\)/\1-$(EPYTHON)-\2/g' \
-i build-outputs.mk || die "sed failed"
- if use python ; then
- # XXX: make python_copy_sources accept path
- S=${S}/subversion/bindings/swig/python python_copy_sources
- rm -r "${S}"/subversion/bindings/swig/python || die
- fi
-
xdg_environment_reset
}
@@ -193,7 +177,7 @@ src_configure() {
$(use_with apache2 apache-libexecdir)
$(use_with apache2 apxs "${EPREFIX}"/usr/bin/apxs)
$(use_with berkdb berkeley-db "db.h:${EPREFIX}/usr/include/db${SVN_BDB_VERSION}::db-${SVN_BDB_VERSION}")
- $(use_with ctypes-python ctypesgen "${EPREFIX}/usr")
+ --without-ctypesgen
--disable-runtime-module-search
$(use_with gnome-keyring)
$(use_enable java javahl)
@@ -211,7 +195,7 @@ src_configure() {
--enable-svnxx
)
- if use python || use perl || use ruby; then
+ if use perl || use ruby; then
myconf+=( --with-swig )
else
myconf+=( --without-swig )
@@ -255,16 +239,10 @@ src_configure() {
#myconf+=( --disable-disallowing-of-undefined-references )
# for build-time scripts
- if use ctypes-python || use python || use test; then
+ if use test; then
python_setup
fi
- if use python && [[ ${CHOST} == *-darwin* ]] ; then
- export ac_cv_python_link="$(tc-getCC) "'$(PYTHON_CFLAGS) -bundle -undefined dynamic_lookup $(PYTHON_LIBS)'
- export ac_cv_python_libs='$(PYTHON_CFLAGS) -bundle -undefined dynamic_lookup $(PYTHON_LIBS)'
- export ac_cv_python_compile="$(tc-getCC)"
- fi
-
# Remove when >=dev-libs/libutf8proc-2.5.0 is stable
# https://bugs.gentoo.org/721300
append-cppflags -I"${EPREFIX}"/usr/include/libutf8proc
@@ -272,39 +250,12 @@ src_configure() {
# allow overriding Python include directory
ac_cv_path_RUBY=$(usex ruby "${EPREFIX}/usr/bin/ruby${RB_VER}" "none") \
ac_cv_path_RDOC=$(usex ruby "${EPREFIX}/usr/bin/rdoc${RB_VER}" "none") \
- ac_cv_python_includes='-I$(PYTHON_INCLUDEDIR)' \
econf "${myconf[@]}"
}
src_compile() {
emake local-all
- if use ctypes-python ; then
- # pre-generate .py files
- use ctypes-python && emake ctypes-python
-
- pushd subversion/bindings/ctypes-python >/dev/null || die
- distutils-r1_src_compile
- popd >/dev/null || die
- fi
-
- if use python ; then
- swig_py_compile() {
- local p=subversion/bindings/swig/python
- rm -f ${p} || die
- ln -s "${BUILD_DIR}" ${p} || die
-
- python_export PYTHON_INCLUDEDIR
- emake swig-py \
- swig_pydir="$(python_get_sitedir)/libsvn" \
- swig_pydir_extra="$(python_get_sitedir)/svn"
- }
-
- # this will give us proper BUILD_DIR for symlinking
- BUILD_DIR=python \
- python_foreach_impl swig_py_compile
- fi
-
if use perl ; then
emake swig-pl
fi
@@ -333,26 +284,6 @@ src_compile() {
src_test() {
if has_version ~${CATEGORY}/${P} ; then
default
-
- if use ctypes-python ; then
- python_test() {
- "${PYTHON}" subversion/bindings/ctypes-python/test/run_all.py \
- || die "ctypes-python tests fail with ${EPYTHON}"
- }
-
- distutils-r1_src_test
- fi
-
- if use python ; then
- swig_py_test() {
- pushd "${BUILD_DIR}" >/dev/null || die
- "${PYTHON}" tests/run_all.py || die "swig-py tests fail with ${EPYTHON}"
- popd >/dev/null || die
- }
-
- BUILD_DIR=subversion/bindings/swig/python \
- python_foreach_impl swig_py_test
- fi
else
ewarn "The test suite shows errors when there is an older version of"
ewarn "${CATEGORY}/${PN} installed. Please install =${CATEGORY}/${P}*"
@@ -364,29 +295,6 @@ src_test() {
src_install() {
emake -j1 DESTDIR="${D}" local-install
- if use ctypes-python ; then
- pushd subversion/bindings/ctypes-python >/dev/null || die
- distutils-r1_src_install
- popd >/dev/null || die
- fi
-
- if use python ; then
- swig_py_install() {
- local p=subversion/bindings/swig/python
- rm -f ${p} || die
- ln -s "${BUILD_DIR}" ${p} || die
-
- emake \
- DESTDIR="${D}" \
- swig_pydir="$(python_get_sitedir)/libsvn" \
- swig_pydir_extra="$(python_get_sitedir)/svn" \
- install-swig-py
- }
-
- BUILD_DIR=python \
- python_foreach_impl swig_py_install
- fi
-
if use perl ; then
emake DESTDIR="${D}" INSTALLDIRS="vendor" install-swig-pl
perl_delete_localpod
@@ -455,10 +363,6 @@ src_install() {
rm -fr tools/client-side/svnmucc
rm -fr tools/server-side/{svn-populate-node-origins-index,svnauthz-validate}*
rm -fr tools/{buildbot,dev,diff,po}
-
- insinto /usr/share/${PN}
- find tools -name '*.py' -exec sed -i -e '1s:python:&2:' {} + || die
- doins -r tools
fi
if use doc ; then