summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-04-23 22:35:33 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-04-23 22:35:52 +0200
commit6382ed6bba4dc340c116977bb2a9d5bc467a72e2 (patch)
treedb152d387b2056d5658be6308a3059bf651b24ae
parentapp-antivirus/clamav: Fix building against sys-libs/ncurses[tinfo] (bug #5963... (diff)
downloadgentoo-6382ed6bba4dc340c116977bb2a9d5bc467a72e2.tar.gz
gentoo-6382ed6bba4dc340c116977bb2a9d5bc467a72e2.tar.bz2
gentoo-6382ed6bba4dc340c116977bb2a9d5bc467a72e2.zip
app-office/auto-multiple-choice: Revbump for bug 606744. Needs testing, no keywords.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--app-office/auto-multiple-choice/auto-multiple-choice-1.3.0-r1.ebuild94
1 files changed, 94 insertions, 0 deletions
diff --git a/app-office/auto-multiple-choice/auto-multiple-choice-1.3.0-r1.ebuild b/app-office/auto-multiple-choice/auto-multiple-choice-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..5660b1edcbac
--- /dev/null
+++ b/app-office/auto-multiple-choice/auto-multiple-choice-1.3.0-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs perl-functions latex-package
+
+DESCRIPTION="Create and manage multiple choice questionnaries, including automated marking"
+HOMEPAGE="http://home.gna.org/auto-qcm/"
+SRC_URI="http://download.gna.org/auto-qcm/${PN}_${PV}_sources.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+LANGS="ar es fr ja"
+# we deliberately always install de and en, since this way we dont get a problem
+# with globs and empty directories...
+#
+for lala in ${LANGS}; do
+ IUSE="${IUSE} l10n_${lala}"
+done
+
+CDEPEND="
+ app-text/texlive[dvi2tty,extra,graphics,png,pstricks,science,truetype,xml,X,luatex,xetex,humanities,omega,publishers]
+ app-text/poppler:=
+ dev-perl/XML-LibXML
+ media-libs/netpbm
+ media-libs/opencv
+ l10n_fr? ( app-text/texlive[l10n_fr] )
+ l10n_ja? ( app-text/texlive[l10n_ja] )
+"
+DEPEND="${CDEPEND}
+ app-text/dblatex
+ app-text/docbook-xml-simple-dtd:*
+ app-text/docbook-xsl-stylesheets
+"
+RDEPEND="${CDEPEND}
+ app-text/pdftk
+ dev-lang/perl:=
+ dev-perl/Glib-Object-Introspection
+ dev-perl/Gtk2
+ dev-perl/Gtk2-Notify
+ media-gfx/imagemagick
+ dev-perl/XML-Writer
+ dev-perl/Archive-Zip
+ dev-perl/DBI
+ dev-perl/Text-CSV
+ dev-perl/DBD-SQLite
+ dev-perl/Net-CUPS
+ dev-perl/Email-Address
+ dev-perl/Email-MIME
+ dev-perl/Email-Sender
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.0-desktop.patch"
+ "${FILESDIR}/${PN}-1.3.0-conf.patch"
+)
+
+src_prepare() {
+ default
+
+ local la
+ for la in ${L10N} ; do
+ if ! use l10n_${la} ; then
+ # remove languages that we dont want to install
+ rm -vf "I18N/lang/${la}.po"
+ rm -vf "doc/auto-multiple-choice.${la}.in.xml" "doc/doc-xhtml-site.${la}.xsl.in"
+ rm -rvf "doc/html/auto-multiple-choice.${la}" "doc/modeles/${la}"
+ fi
+ done
+}
+
+src_compile() {
+ perl_set_version
+ export VENDOR_LIB PVR
+ export TEXINPUTS="/usr/share/dblatex/latex/style:/usr/share/dblatex/latex/misc:/usr/share/dblatex/latex/graphics:"
+
+ export MAKEOPTS="-j1"
+ # when doing a parallel build, the package is acting decidedly odd
+ # e.g., the build seems to succeed while actually stuff fails
+ # and subsequent error messages do not have any relation to the real problem
+ # So let's keep this also for easier debugging
+
+ emake \
+ GCC_NETPBM="-I/usr/include/netpbm/ -lnetpbm" \
+ GCC="$(tc-getCC)" \
+ GCC_PP="$(tc-getCXX)"
+}
+
+src_install() {
+ default
+}