summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-05-04 15:46:53 +0200
committerUlrich Müller <ulm@gentoo.org>2018-05-04 15:46:53 +0200
commit63f679ef0b824a35f97d5b787b7173cf3cd57195 (patch)
treeff9721df7134d454500517e28107e91df5bee5d7
parentdev-python/gmpy-2.0.8: arm64 stable (diff)
downloadgentoo-63f679ef0b824a35f97d5b787b7173cf3cd57195.tar.gz
gentoo-63f679ef0b824a35f97d5b787b7173cf3cd57195.tar.bz2
gentoo-63f679ef0b824a35f97d5b787b7173cf3cd57195.zip
dev-tex/tex4ht: Revision bump, updating texmf from TeXLive.
Closes: https://bugs.gentoo.org/654676 Package-Manager: Portage-2.3.35, Repoman-2.3.9
-rw-r--r--dev-tex/tex4ht/Manifest1
-rw-r--r--dev-tex/tex4ht/tex4ht-20090611_p1038-r6.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/dev-tex/tex4ht/Manifest b/dev-tex/tex4ht/Manifest
index 6623d70bb8af..241dc4b50053 100644
--- a/dev-tex/tex4ht/Manifest
+++ b/dev-tex/tex4ht/Manifest
@@ -1,3 +1,4 @@
DIST tex4ht-1.0.2009_06_11_1038.tar.gz 2576719 BLAKE2B d04fd7b5f614414a200b01f11bea9880ea12561873fc08cb2f5f6f62167d6128cc50abbeeee0c7eae5d80046f6d3b504493d66262153c5a534fd1b56bfa1dfcd SHA512 868961c16da63ef20a8af3ec3e56a2b6c518a291cdbc3974f701773dbb55b844f0df06aae4c7b481c96b9e2ba29cb0f1ed1279b6f32340e4708e31bb67170963
DIST tex4ht-texlive-2015-08-03.tar.xz 801488 BLAKE2B 56397450cc600141cbc541188e4a896727af4823982aae20a198d27b51fcb071794a1aa5a4037cf803f9b172c3183a927b7f446757df1520a596b5b6ee150a06 SHA512 a8a56e0d41406df8c76d72eea6f726f012d70a46665d9dfe99c7362790a2f0126f2c21e07c5de08aff7694e9837c47e162aa6790c256b4538f4780551f6e6191
DIST tex4ht-texlive-2017-02-05.tar.xz 826816 BLAKE2B 8387c1fc7326cb4eb74ec82d15ed6a6f07bacd08788b00e3e6583bf993e0d0e0d387269650217a2a2f2e1f4b94cc8e154359d258bf3311820772b5fdc9aeec34 SHA512 c5a62a10b956d1108f288490e966e9c225555a74ace7744058a4464e4b166f3906d429ed8557d640ca0e9b4dbcc4278ef20298e869560a906c85c68ff832be52
+DIST tex4ht-texlive-2018-05-03.tar.xz 858204 BLAKE2B e302f24ca36ee0f61bad0979a139c25ea44128ba518b2736638ae41735e105b40be23338d93b08f0a9c3f9143486deab6551b344de5f74299d94f9edaa58ab37 SHA512 84ff9cec4d3637477d34475f05efc25e75fcb1ddd9b9cda36fbc77957f6e85b6cb456aa30554ed2c832268d6921949dc2fd4e111755269fb92fc7d231d434ca6
diff --git a/dev-tex/tex4ht/tex4ht-20090611_p1038-r6.ebuild b/dev-tex/tex4ht/tex4ht-20090611_p1038-r6.ebuild
new file mode 100644
index 000000000000..d0cfa850fc84
--- /dev/null
+++ b/dev-tex/tex4ht/tex4ht-20090611_p1038-r6.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit latex-package toolchain-funcs java-pkg-opt-2 flag-o-matic
+
+TL_TEX4HT_VER=2018-05-03
+
+# tex4ht-20050331_p2350 -> tex4ht-1.0.2005_03_31_2350
+MY_P="${PN}-1.0.${PV:0:4}_${PV:4:2}_${PV:6:2}_${PV/*_p/}"
+
+DESCRIPTION="Converts (La)TeX to (X)HTML, XML and OO.org"
+HOMEPAGE="http://www.cse.ohio-state.edu/~gurari/TeX4ht/
+ http://www.cse.ohio-state.edu/~gurari/TeX4ht/bugfixes.html"
+SRC_URI="http://www.cse.ohio-state.edu/~gurari/TeX4ht/fix/${MY_P}.tar.gz
+ mirror://gentoo/${PN}-texlive-${TL_TEX4HT_VER}.tar.xz"
+
+LICENSE="LPPL-1.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="java"
+
+DEPEND=">=sys-apps/sed-4
+ virtual/pkgconfig
+ dev-libs/kpathsea
+ java? ( >=virtual/jdk-1.5 )"
+
+RDEPEND="app-text/ghostscript-gpl
+ media-gfx/imagemagick
+ dev-libs/kpathsea
+ java? ( >=virtual/jre-1.5 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cp -a "${WORKDIR}/texmf-dist/"* texmf/ || die
+ eapply_user
+ cd "${S}/texmf/tex4ht/base/unix" || die
+ sed -i \
+ -e "s#~/tex4ht.dir#${EPREFIX}/usr/share#" \
+ -e "s#tpath/tex/texmf/fonts/tfm/!#t${EPREFIX}/usr/share/texmf-dist/fonts/tfm/!\nt${EPREFIX}/usr/local/share/texmf/fonts/tfm/!\nt${EPREFIX}/var/cache/fonts/tfm/!\nt${EPREFIX}${TEXMF}/fonts/tfm/!#" \
+ -e "s#%%~/texmf-dist#${EPREFIX}${TEXMF}#g" \
+ -e "s#/usr/share/texmf/#${EPREFIX}${TEXMF}/#" \
+ tex4ht.env \
+ || die "sed of tex4ht.env failed"
+
+ einfo "Removing precompiled java stuff"
+ find "${S}" '(' -name '*.class' -o -name '*.jar' ')' -print -delete || die
+}
+
+src_compile() {
+ has_version '>=dev-libs/kpathsea-6.2.1' \
+ && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+
+ cd "${S}/src" || die
+ einfo "Compiling postprocessor sources..."
+ for f in tex4ht t4ht htcmd ; do
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o $f $f.c \
+ -DENVFILE="\"${EPREFIX}${TEXMF}/tex4ht/base/tex4ht.env\"" \
+ -DHAVE_DIRENT_H -DKPATHSEA -lkpathsea \
+ || die "Compiling $f failed"
+ done
+ if use java; then
+ einfo "Compiling java files..."
+ cd java || die
+ ejavac *.java */*.java */*/*.java -d ../../texmf/tex4ht/bin
+ cd "${S}/texmf/tex4ht/bin" || die
+ # Create the jar needed by oolatex
+ jar -cf "${S}/${PN}.jar" * || die "failed to create jar"
+ fi
+}
+
+src_install () {
+ # install the binaries
+ dobin "${S}/src/tex4ht" "${S}/src/t4ht" "${S}/src/htcmd"
+ # install the scripts
+ if ! use java; then
+ rm -f "${S}"/bin/unix/oo*
+ rm -f "${S}"/bin/unix/jh*
+ fi
+ dobin "${S}"/bin/unix/mk4ht
+
+ # install the .4ht scripts
+ insinto ${TEXMF}/tex/generic/tex4ht
+ doins "${S}"/texmf/tex/generic/tex4ht/*
+
+ # install the special htf fonts
+ insinto ${TEXMF}/tex4ht
+ doins -r "${S}/texmf/tex4ht/ht-fonts"
+
+ if use java; then
+ # install the java files
+ doins -r "${S}/texmf/tex4ht/bin"
+ java-pkg_jarinto ${TEXMF}/tex4ht/bin
+ java-pkg_dojar "${S}/${PN}.jar"
+ fi
+
+ # install the .4xt files
+ doins -r "${S}/texmf/tex4ht/xtpipes"
+
+ # install the env file
+ insinto ${TEXMF}/tex4ht/base
+ newins "${S}/texmf/tex4ht/base/unix/tex4ht.env" tex4ht.env
+
+ insinto /etc/texmf/texmf.d
+ doins "${FILESDIR}/50tex4ht.cnf"
+
+ insinto ${TEXMF}/tex/generic/${PN}
+ insopts -m755
+ doins "${S}"/bin/ht/unix/*
+}
+
+pkg_postinst() {
+ use java || elog 'ODF converters (oolatex & friends) require the java use flag'
+ latex-package_pkg_postinst
+ elog "In order to avoid collisions with multiple packages"
+ elog "We are not installing the scripts in /usr/bin anymore"
+ elog "If you want to use, say, htlatex, you can use 'mk4ht htlatex file'"
+}