summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2019-05-31 13:08:18 +0200
committerGuilherme Amadio <amadio@gentoo.org>2019-08-16 16:17:45 +0200
commit656ad70ccd8522e73f77e7b0435a439adc3025f0 (patch)
treef3d5d6490ff44bacdf52f1ffea28f1f2515270ec
parentdev-libs/xxhash: version bump to 0.7.1 (diff)
downloadgentoo-656ad70ccd8522e73f77e7b0435a439adc3025f0.tar.gz
gentoo-656ad70ccd8522e73f77e7b0435a439adc3025f0.tar.bz2
gentoo-656ad70ccd8522e73f77e7b0435a439adc3025f0.zip
app-arch/lz4: version bump to 1.9.1
Closes: https://github.com/gentoo/gentoo/pull/12723 Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
-rw-r--r--app-arch/lz4/Manifest1
-rw-r--r--app-arch/lz4/lz4-1.9.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-arch/lz4/Manifest b/app-arch/lz4/Manifest
index 0ec9ca3d75c0..4bb1382050d2 100644
--- a/app-arch/lz4/Manifest
+++ b/app-arch/lz4/Manifest
@@ -1 +1,2 @@
DIST lz4-1.8.3.tar.gz 327897 BLAKE2B e2be80be14c67cf1a07cc6a2e6f6777a87abdd15499b9c32b8096e09284aea19620adf930e28454ce105e325cff684d2625e0a38211705f3c105a80b72f56be5 SHA512 5d284f75a0c4ad11ebc4abb4394d98c863436da0718d62f648ef2e2cda8e5adf47617a4b43594375f7b0b673541a9ccfaf73880a55fd240986594558214dbf9f
+DIST lz4-1.9.1.tar.gz 285336 BLAKE2B 50dfad2e92028a1ccfe186efb5dbe24e4641e104da656990ba5138a84d29fbfea26d96c2d7f64f8d6a686dc98b4890990a280d4d86e321b04f467b65b6c61e1f SHA512 536cdeb6dd73b4769cf9501ad312b004ab01699758534b47ca2eddbc815fd374a3caba40cde36f73a7a70e134065836b733e2b0c023c31740b877ef9317ccf3e
diff --git a/app-arch/lz4/lz4-1.9.1.ebuild b/app-arch/lz4/lz4-1.9.1.ebuild
new file mode 100644
index 000000000000..f68caa90b673
--- /dev/null
+++ b/app-arch/lz4/lz4-1.9.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lz4/lz4.git"
+ EGIT_BRANCH=dev
+else
+ SRC_URI="https://github.com/Cyan4973/lz4/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Extremely Fast Compression algorithm"
+HOMEPAGE="https://github.com/lz4/lz4"
+
+LICENSE="BSD-2 GPL-2"
+# https://abi-laboratory.pro/tracker/timeline/lz4/
+SLOT="0/r132"
+IUSE="static-libs"
+
+CMAKE_USE_DIR=${S}/contrib/cmake_unofficial
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ )
+
+ cmake-utils_src_configure
+}